none
Out of office Auto Reply in OWA is giving error

    Question

  • When we try to configure Auto Replies in OWA, we receive the following error.

    The Web page isn't loading properly. Please reload the page by refreshing your Web browser.
    Technical Information: Uncaught TypeError: Cannot set property 'tabIndex' of undefinedThe entire error report is listed below: Hide Report

    Client Information
    ------------------
    User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
    CPU Class: undefined
    Platform: Win32
    System Language: undefined
    User Language: en-US
    CookieEnabled: true
    -----------------
    Exception Details
    -----------------
    Date: Thu May 10 2018 15:29:22 GMT+0300 (Arab Standard Time)
    Message: Uncaught TypeError: Cannot set property 'tabIndex' of undefined
    Url: https://mail1.ppcksa.com/ecp/14.3.361.1/Scripts/wizardproperties.js
    Line: 26

    Call Stack
    ----------
    Error
        at ErrorHandling.showUnhandledException (https://mail1.ppcksa.com/ecp/14.3.361.1/Scripts/common.js:253:1205)
        at https://mail1.ppcksa.com/ecp/14.3.361.1/Scripts/microsoftajax.js:5:307




    Dump Event
    ----------
    isTrusted = true
    message = Uncaught TypeError: Cannot set property 'tabIndex' of undefined
    filename = https://mail1.ppcksa.com/ecp/14.3.361.1/Scripts/wizardproperties.js
    lineno = 26
    colno = 3563
    error = TypeError: Cannot set property 'tabIndex' of undefined
    NONE = 0
    CAPTURING_PHASE = 1
    AT_TARGET = 2
    BUBBLING_PHASE = 3
    type = error
    target = [object Window]
    currentTarget = [object Window]
    eventPhase = 2
    bubbles = false
    cancelable = true
    defaultPrevented = false
    composed = false
    timeStamp = 261143.4999999983
    srcElement = [object Window]
    returnValue = true
    cancelBubble = false
    path = [object Window]
    composedPath = function composedPath() { [native code] }
    stopPropagation = function stopPropagation() { [native code] }
    stopImmediatePropagation = function stopImmediatePropagation() { [native code] }
    preventDefault = function preventDefault() { [native code] }
    initEvent = function initEvent() { [native code] }

    Detailed Call Stack


    Thursday, May 10, 2018 12:30 PM

Answers

  • Hi,

    Have you tested the issue in other browsers? 

    Below is the output in my lab, I noticed that it is a bit different from yours, so we recommend you to temporarily change the values to be same with following ones and check if issue persists. Use the Set-WebServicesVirtualDirectory to change these.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Asim Anwar Tuesday, May 22, 2018 9:55 AM
    Tuesday, May 15, 2018 9:19 AM
    Moderator
  • Thanks all for your support. The problem was solved by resetting Ecp & OWA Virtual Directories.
    • Marked as answer by Asim Anwar Tuesday, May 22, 2018 9:54 AM
    Tuesday, May 22, 2018 9:54 AM

All replies

  • Check the settings on the Web Services Virtual Directory.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Thursday, May 10, 2018 10:30 PM
  • Hi,

    Agree with Ed.

    Run the following command to check the URL and authentication methods of the EMS VD.

    Get-WebServicesVirtualDirectory | fl *url*,*auth*

    Moreover, make sure that the Mailbox Assistant service is running on Exchange server.
    Also use IE to open OWA and set OOF Auto-reply.

    Similar link: OWA users getting “Critical Error” when accessing their Options

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, May 11, 2018 9:06 AM
    Moderator
  • I got the following results when i run this cmd.

    [PS] C:\Windows\system32>Get-WebServicesVirtualDirectory | fl *url*,*auth*


    InternalNLBBypassUrl          :
    InternalUrl                   : https://mail1.ppcksa.com/EWS/Exchange.asmx
    ExternalUrl                   : https://mail1.ppcksa.com/ews/exchange.asmx
    CertificateAuthentication     :
    InternalAuthenticationMethods : {Basic, Ntlm, Digest, WindowsIntegrated, WSSecurity}
    ExternalAuthenticationMethods : {Basic, Ntlm, Digest, WindowsIntegrated, WSSecurity}
    LiveIdSpNegoAuthentication    : False
    WSSecurityAuthentication      : True
    LiveIdBasicAuthentication     : False
    BasicAuthentication           : True
    DigestAuthentication          : True
    WindowsAuthentication         : True

    Sunday, May 13, 2018 7:44 AM
  • Hi,

    Have you tested the issue in other browsers? 

    Below is the output in my lab, I noticed that it is a bit different from yours, so we recommend you to temporarily change the values to be same with following ones and check if issue persists. Use the Set-WebServicesVirtualDirectory to change these.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Asim Anwar Tuesday, May 22, 2018 9:55 AM
    Tuesday, May 15, 2018 9:19 AM
    Moderator
  • I have already changed Internal Authentication Methods & External Authentication methods according to your recommendation. But with me InternalNLBBypassUrl is blank, do i need to need to set this also same as my internalUrl?


    I tested it in other browsers, i am able make changes in Auto-reply but when i click save on Auto-reply page, i get this error.

     
    • Edited by Asim Anwar Tuesday, May 15, 2018 10:35 AM
    • Marked as answer by Asim Anwar Tuesday, May 22, 2018 9:55 AM
    • Unmarked as answer by Asim Anwar Tuesday, May 22, 2018 9:55 AM
    Tuesday, May 15, 2018 10:16 AM
  • Hi,

    "But with me InternalNLBBypassUrl is blank, do i need to need to set this also same as my internalUrl?"

    Yes, set it to be same with the InternalUrl.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, May 17, 2018 1:53 AM
    Moderator
  • I set InternalNLBBypassUrl same as my internalUrl but the problem still exist.


    • Edited by Asim Anwar Monday, May 21, 2018 11:36 AM Addition
    Monday, May 21, 2018 11:35 AM
  • Thanks all for your support. The problem was solved by resetting Ecp & OWA Virtual Directories.
    • Marked as answer by Asim Anwar Tuesday, May 22, 2018 9:54 AM
    Tuesday, May 22, 2018 9:54 AM