Add-AppxPackage : ... HRESULT: 0x80073CF6, Package could not be registered. Merge Failure : error 0x80070003 : Cannot register the **PACKAGE_NAME** .... RRS feed

  • Question

  • I have a PC running windows 10 enterprise th2 build 1511/10586

    The PC is joined to a domain. The issue occurs in a Domain User Account with Standard User permissions. 

    First - The photo app kept on crashing after about 5 seconds of being launched. 

    So i attempted to re-register the UWA's on the PC using .... 

    Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    (Admin: Powershell)

    This did not fix the issue ... so i attempted to do a user re-registration.  

    Get-AppxPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    (User Level Powershell)

    After this i had lost many application ... Photos, store, video, maps, messenger had become all "Semi" registered. No Icons, and long packages names in the start menu - also none of them would launch.

    so i tried the Admin registration again... this time receiving my error for the first time .... Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6 .... Merge Failure : error 0x80070003 ... etc for the 5 apps. The rest of the UWA's were unaffected.

    At this point i followed -> http://www.howtogeek.com/224798/how-to-uninstall-windows-10s-built-in-apps-and-how-to-reinstall-them/ and attempted to reinstalled the apps.

    This did not work either. Photo apps didn't even seem to be found by the Remove-AppxPackage ... 

    Then i tried...

    Get-AppxPackage *photos* | Add-AppxPackage

    This appeared to work but did not change anything. 

    I also tried to login with my username (domain administrator) and theses apps all worked (however the name was not correct). I then performed an all user registration again from admin Powershell, which fixed my profiles app names but did nothing to the other user account. 

    Doing research this issue has been around for a long time. How do i completely remove these applications, sideload the store app and then proceed to reinstall them like they never existed as i would do with a win32? or alternatively what other ways is there to repair a users installation of these applications? 

    When are we going to get a stable fix for this issue as well... since this isn't the first time i have seen it and has existed since early betas.

    Tuesday, November 24, 2015 4:06 AM

All replies

  • Hi,

    We found several similar cases in TechNet, and even I also had same issue with my all store apps and start button last night in my test environment, somehow it get fixed without any action this morning. Just curious, do you have or had applocker rules applying to workstation or user’s AppData folder?

    I collect some suggestions mentioned as “worked”, see if it can help you.

    Manually deleting the app directory inside the AppData folder

    Changing default owner of registry key to system

    HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages

    Please backup these folders or registry entries before taking any action.


    D. Wu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, November 27, 2015 6:36 AM
  • Sorry for the late response. I have Manually Deleted the app from the AppData folder and windows does not go far enough to even notice. As far as AppLocker - no rules are being applied.

    I do have Side-loading turned on for side-loading corporate apps via the AD, signed by the AD... Dont think this should effect anything. 

    I will check the registry settings.

    I ended up having to recreate the user account but i left the old account for testing purposes.

    • Proposed as answer by Deason Wu Wednesday, December 2, 2015 1:34 AM
    • Marked as answer by Michael_LS Thursday, December 3, 2015 5:31 AM
    • Unmarked as answer by mike_pthermite Monday, January 4, 2016 5:43 PM
    Tuesday, December 1, 2015 11:00 PM
  • I have run into the same problem, none of the suggestions on the WEB have worked.  The broken apps (including the Windows 10 App Store itself !!) show up as long names on the tiles, don't update, and don't run.  This problem seems to go back to Win 8, so it is not new. 


    Friday, January 1, 2016 5:38 AM
  • I'm having the same problem too.

    All modern apps (except Edge and Windows feedback) are broken. Can't even open calculator anymore.

    Tried the "Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -Dis
    ableDevelopmentMode -Register "$($_.InstallLocation)\AppxManifest.xml"}" command but it returns this error:

    HRESULT: 0x80073CF6

    and this: Merge Failure: erro 0x80070003

    And no one talks about this... Everytime the solution is to "create another user".

    This is happening on my work computer. On my home computer I'm having problem with Xbox app only. It won't open... The tile is there but nothing happens when I click on it... Tried reinstalling and nothing does the job. On other users it works normally.

    C'mon... There should be a way to fix the modern apps without having to start over again...

    UPDATE: I had to format my work computer to make all apps work again. And at my home computer, now the mail and calendar apps have the same problem that Xbox App. Nice.........
    Monday, January 4, 2016 10:50 AM
  • None of these worked. 
    Monday, January 4, 2016 5:44 PM
  • I am experiencing the same issue, and have gone throught the steps mentioned.

    What I'd like to add is that I belive the cause is that when resintalling WindowsStore

    add-appxpackage -register "C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.25.5.0_x64__8wekyb3d8bbwe\AppxManifest.xml" -disabledevelopmentmode

    It tries, and fails, to merge with: 

    C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.25.5.0_neutral_split.language-es_8wekyb3d8bbwe\resources.pri

    Because this version doesn't exist. The one that exists is:

    C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.7.1.0_neutral_split.language-es_8wekyb3d8bbwe


    Tuesday, January 12, 2016 1:37 PM
  • I'm in the same boat as mike. I have tried everything including a clean install of Windows 10. Would appreciate any help that I can get towards resolving this issue.
    Friday, January 15, 2016 11:36 AM
  • Just like to add yet another person to the list of those suffering from this problem.  I have tried the various solutions suggested here and on other forums.

    Someone must come up with a solution that works eventually.

    Friday, February 5, 2016 5:22 PM
  • Im adding myself to the lits of people with this problem. I had an issue with my email-app not working as it should. Somone suggested to run a powershell script that would reregister and reinstall all the apps. I got the error above and now i cannot access any apps. (Adge browser seems to work, but nothing else.) Any one have any idee what this is?
    Monday, February 8, 2016 8:13 AM
  • I am yet another sad victim of this problem. I have tried everything to no avail. Microsoft needs to weigh in on this. . .
    Saturday, February 13, 2016 10:01 PM
  • I experience the same problem. All mentioned things on Internet I have tried. This happened some time ago after an update from Windows 10. I have Windows 10 Pro as an upgrade from Windows 7 Ultimate.
    Windows Store and the Solitaire Suite don't work (last one not important) so I cannot add apps from the Store as the Store doesn't work.

    I asked Microsoft for help, they wouldn't, unless I paid 89 euro, with no guarantee that it would help.

    I have been digging now for weeks and absolutely don't want to reinstall Windows 10 again, plus all the stuff I have, as this is too much work.

    Come on Microsoft, find the problem and make a working Fixit.
    The one I downloaded says there is nothing wrong.
    There are far to many people all over the world with this problem now.

    Is this needed?

    • Edited by lobo405 Friday, February 26, 2016 9:50 AM minor typing error
    Friday, February 26, 2016 9:48 AM
  • I've got the same problem, no fix worked.

    I hope Microsoft will work a miracle, soon.....

    Sunday, February 28, 2016 9:34 AM
  • You're not alone with this problem. I have surface pro 3 and i'm in contact with the microsoft support. They are trying to help me. However they don't know how to fix this, and they recommended me to format my computer. (But i told them i won't to format my computer.) So the support will recontact me with several solution.
    Sunday, February 28, 2016 5:06 PM
  • I'm also having the same problem, though my second error is 0x80070003: Reading manifest from location : AppxManifest.xml failed with error: The system cannot find the path specified.

    I'm in the same boat, a new account or a compete reset are not really options.

    Monday, March 14, 2016 5:35 AM
  • I've just been in the registry editor and notice that the Store Key does is not the same as the location.

    My registry key is HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages\Microsoft.WindowsStore_2015.21.25.0_x64__8wekyb3d8bbwe

    and all references in the key and subkey refer to this folder (C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.21.25.0_x64__8wekyb3d8bbwe) where it should be

    C:\Program Files\WindowsApps\Microsoft.WindowsStore_2016.29.13.0_x64__8wekyb3d8bbwe

    however my store version (from  Get-Appxpackage -Allusers in the powershell) is 2016.29.13.0

    Unfortunately It is not possible to change the registry keys as the permissions only allow SYSTEM or the local computer administrator (not the administrative user through the domain account).

    Fundamentally I think this is a permissions issue.  The store has been upgraded, but permissions don't allow the registry keys to reflect those changes, so it's stuck pointing to the old location, which is still there, but it doesn't align with the Appxpackage records.

    Monday, March 14, 2016 6:17 AM
  • It is very upsetting to see this problem unfixed. I have been all over the internet trying to find solutions with no avail. I always had this sort of problem with windows solitaire, but it only recently happened with just about every built-in app I have. Pay Attention Microsoft!
    Wednesday, March 16, 2016 2:36 AM
  • Hi There!

    It sounds like you're on to something here... do you have any idea how to change the location that it points to? Like many others, my app store and calculator are not working.

    Many thanks!

    Friday, April 1, 2016 1:04 PM
  • I had the same problem, I got to it by a different means. For me, the Windows Start Bar quit working entirely. I could get it working again by CTRL+ALT-DEL to bring up Task Manager and then restarting explorer.exe, but I had to do this after every log on. I eventually tried going to PowerShell with Administrator privileges and running:

    Get-AppxPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    But this gave me the write error in every case (a whole bunch of them!).

    I turned off my security/anti-virus protection (Kaspersky Labs in this case) and re-ran the PowerShell command, and viola all the write errors disappeared!

    So I'm one step on the way to fixing the broken Start Bar. Not quite there, but I DID get the Get-AppXPackage command to work this way.

    Sunday, April 3, 2016 9:07 PM
  • Yes - come on Microsoft!!!!!!

    It's also very upsetting to see all the BS about Windows10 when the support engineers are apparently not able to fix absolutely fundamental Windows 10 problems without falling back on nuclear options like reinstalling the OS, creating a new user account, etc.

    Does anybody know any way of getting action from Microsoft or is it just hopeless?

    Sunday, April 10, 2016 8:55 AM
  • Yep, they need to fix this! I can't find ANY official response from MSFT on this. Internet (and this forum too) is full of reported problems with build-in Store apps and powershell commands after 1511 November build but there is no info that they are even aware of this...
    Monday, April 11, 2016 8:39 AM
  • Hi! I am in the same trouble now! Some of the apps I did get back, when I used this advice for each app:


    In Windows 10 Insider Preview build 10074 and 10122, someone may encounter this issue:

    Mail app cannot launch, crash or not work correctly. (Note:Take Mail app as the example.)


    We need to re-register this app or reinstall it from Windows store to solve this issue.

    Solution 1: Re-register this App:

    1. Run Windows PowerShell as Administrator.

    2. Type Get-AppxPackage, press Enter.

    3. From the output list, find the Mail App and remember (Ctrl C) the InstallLocationas blew:

    4. And then type this command: Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "(Ctrl V here - exampel C:\Program Files\WindowsApps\microsoft.windowscommunicationsapps_17.4119.42011.0_x64__8wekyb3d8bbwe\AppxManifest.xml"}

    5. It would run as below:

    Solution 2: If re-register App cannot resolve your issue, Please reinstall the App.

    Step 1: Uninstall it completely

    1. Run Windows PowerShell as Administrator.

    2. Type Get-AppxPackage, press Enter.

    3. From the output list, find Mail App package and remember its PackageFullNameas below:

    4. And then type the following command: Remove-Appxpackage –Package microsoft.windowscommunicationsapps_17.4119.42011.0_x64__8wekyb3d8bbwe

    5. It would run as below:

    Note: After running this command in Windows Insider Preview 10074 build, the Mail icon still appear in the App list and Start menu. However, you cannot click to launch it. Just ignore and continue next step.

    Step 2: Reinstall the App from Windows Store


    Please click to vote if the post helps you. This can be beneficial to other community members reading the thread.

    · Edited by ForumFAQ Monday, June 01, 2015 11:22 AM Update

    · Changed type

     I have not used Solution 2 because my problem is, that I cannot get Store to work. There are many other Apps I still cannot get to work - including making another User, which I can understand can be a solution to.

    I got an error (I cannot remember the number now) when using the above method. Trying to do what they mentioned as a way to get around the problem, I was led to a Windows 8 problem, where it could be fixed with FixIt from Microsoft. The problem is now, that FixIt does not work under Windows 10. (Microsoft please do something about it!). But the same text mentioned, that the problem I got had to do with a Windows Update, where the update seems to have success - and are installed - but some files in the update are not installed correct. Maybe Microsoft should work with that problem, so the hole update is reversed with a failure report to Microsoft and to us users telling us, that they try again, when the problem is corrected.

    Kindly regards

    Mogens Bjørre (mbjoerre@outlook.dk)


    Monday, April 18, 2016 2:57 AM
  • I am also having this problem... even though adding myself to the long list may not help at this point.

    Come on Microsoft....

    Thursday, April 28, 2016 9:05 PM
  • In a fortnight after installation I got the same problem. I spent two days searching for various ways to solve it but none worked out. Creating a new account appeared to be a semi-solution and the only full way is to re-install all that again. What a pity (mildly speaking).
    Saturday, May 14, 2016 6:52 AM
  • Dude, I'm facing the same problem here, I went ahead for Microsoft support chat and they were like subscribe to their 1 year plan and they will take care of that shit. This is bullshit man, I mean come on - It all started with apps not getting installed through Windows store and the solution provided by the Microsoft guy in the forum broke everything. 

    and now they don't have a solution,.

    Monday, May 16, 2016 7:21 AM
  • For me it all started while trying to install some apps through Windows Store, it kept on asking me to retry and threw up error 0x80248014, I went ahead and searched about it and followed what the Microsoft support told to do from the link and started to become a mess.


    Now if i search for windows store it shows this.

    And now I found that there are a lot of my Windows store apps that has gone for a toss.

    Microsoft should find a solution instead of askiing us to subscribe to their support line for a year, the first response I got after getting in touch with the support at Microsoft Answer Desk.

    The other solutions like reinstall the OS and create a new User, come on you and i know there are better ways to do things. Thank god that I'm not dependent on any of these Windows Store apps. Looking for forward for some Magic to happen from Microsoft. 

    Monday, May 16, 2016 8:26 AM
  • Unfortunately I will also be adding myself to this long list.

    I have been tearing my hair out trying to fix this.

    Have tried every solution found online. Hoping, like very few people on here, that one day I'll wake up; log in; and discover it's all back. A girl can dream...

    In the meantime looks like I'll just hang around this thread in hope of a fix or Microsoft to pull their fingers out of their assholes and deal with this.

    • Proposed as answer by DSain Friday, August 16, 2019 4:05 PM
    Monday, May 16, 2016 5:48 PM
  • Oh well, guess I´ll be reinstalling the OS or repairing it this weekend. There is no IT solutions for end users, only for Businesses, so paying might go a long way, if your data is really that important and your time as well. What end users do get is customer service, which is like calling a foreign country and speaking to Abdul who´s never even been outside his country.

    Thursday, May 19, 2016 12:56 AM
  • The same issue for all windows store app (including windows store)... can't find solution... Microsoft goes bad
    Tuesday, May 24, 2016 9:15 AM
  • Hi Folks ... I'm unsure where to post this fix that I have discovered by chance/educated guess work.

    Having suffered the problem of the Windows 10 Store crashing immediately after start-up on my main personal user account of my desktop PC for some time now following upgrade to W10, I have tried the numerous suggested fixes listed on many forums all to no success.

    Symptoms were that while the problem persists on my personal user account it doesn't usually occur on any other user accounts created which can run the Store app and successfully perform app updates etc.

    Once or twice following failure of the Store my personal user account, other accounts would also hit the problem of the Store crashing. This was easily fixed by running the fix suggested in several forums as below:

    From cmd promt run ...
    PowerShell -ExecutionPolicy Unrestricted -Command "& {$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest}"

    Now while this fixed the Store for all other users it did not for my personal user account where the whole problem started from.

    When I ran the above command from the offending user account it failed with the failure mode of this forum thread:

    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered. (Exception from
    HRESULT: 0x80073CF6)

    Thus taking the advice of the error message I extracted the error message in full from the event log and lo and behold it was clear that the system was looking for files in a folder that didn't exist.

    Windows cannot find the resource package manifest in the bundle file:
    C:\Program Files\WindowsApps\Microsoft.WindowsStore_11602.1.26.0_neutral_split.scale-125_8wekyb3d8bbwe\AppxManifest.xml.

    While my system had the folder as below:

    C:\Program Files\WindowsApps\Microsoft.WindowsStore_11602.1.26.0_neutral_split.scale-150_8wekyb3d8bbwe

    present and correct it did not have the folder ...125...

    A quick copy of the folder:
    C:\Program Files\WindowsApps\Microsoft.WindowsStore_11602.1.26.0_neutral_split.scale-150_8wekyb3d8bbwe

    And renaming the copied version to:
    C:\Program Files\WindowsApps\Microsoft.WindowsStore_11602.1.26.0_neutral_split.scale-125_8wekyb3d8bbwe

    Then rerun cmd line:

    PowerShell -ExecutionPolicy Unrestricted -Command "& {$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest}"

    and Bob's your uncle ... the Store works once more and is updating apps successfully. Phew!

    Give this one a try if like me you've had this error a while and none of the suggested fixes works.

    Caveat: I have no idea why this works and thus obviously I do not understand the root cause of the underlying fault.

    Microsoft: Could you please have someone look into this fix that I have stumbled upon and diagnose the root cause this suggests and provide a cleaner fix for the non-techies. Plus of course fix the root cause within your software. 

    • Proposed as answer by andy.sousa Thursday, June 9, 2016 1:23 AM
    Thursday, June 2, 2016 7:37 PM
  • After pounding my head against the wall for so long about this issue and no answers from Microsoft... THANK YOU SO MUCH for the above reply, as this lead me to the key to the whole problem!!!

    And I didn't rename any app folders, as the whole thing lies with the naming of manifest xml files in this directory:


    The issue was that the system was looking for files with "neutral_split.scale-125" in the name, when only files with "neutral_split.scale-100" existed in that directory. After making copies of the files relating to the failed apps and renaming them to what it was looking for, I was able to then register the failed apps individually.

    The strange thing about it is that it only affected a certain domain account profile (I have personally encountered numerous instances of this). Any other user could log into the system, and the apps worked fine. Deleting the user profile did not resolve the issue, as something is still tying the manifest info to the GUID of the user. For instance... even with the profile entirely cleared out, the same account picture still follows the user when a new profile is created. My next step would have been trying to figure out where this is being stored, as it obviously has nothing to do with HKLM\Software\Microsoft\Windows NT\ProfileList.

    The question for Microsoft is... WHY DOES THIS HAPPEN??? It is a has been a persistent issue ever since "Metro" apps were created in Windows 8, and there has been no answer or fix from Microsoft that I have been able to find. I have been delaying full deployment of Windows 10 mainly due to this problem. I have most users here still running Windows 7.


    See below:

    PS C:\Windows\system32> Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.WindowsStore_11602.1.26.0_x64_
    _8wekyb3d8bbwe\AppxManifest.xml" -DisableDevelopmentMode
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered. (Exception from
    HRESULT: 0x80073CF6)
    NOTE: For additional information, look for [ActivityId] 26ecc3e5-bd0f-0006-e373-ed260fbdd101 in the Event Log or use
    the command line Get-AppxLog -ActivityID 26ecc3e5-bd0f-0006-e373-ed260fbdd101
    At line:1 char:1
    + Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.Win ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : WriteError: (C:\Program File...ppxManifest.xml:String) [Add-AppxPackage], IOException
        + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

    Microsoft Windows [Version 10.0.10586]
    (c) 2015 Microsoft Corporation. All rights reserved.

    Windows PowerShell
    Copyright (C) 2015 Microsoft Corporation. All rights reserved.

    PS C:\Windows\system32> Get-AppxLog -ActivityID 26ecc3e5-bd0f-0006-e373-ed260fbdd101

    About to service package
                                           Microsoft.WindowsStore_11602.1.26.0_x64__8wekyb3d8bbwe. Setting the package
                                           state to disabled returned with 0x80070490.
    6/2/2016 2:55:53 PM       475          error 0x80070002: Reading manifest from location: C:\ProgramData\Microsoft\Windo
                                           kyb3d8bbwe.xml failed with error: The system cannot find the file specified.
    6/2/2016 2:55:53 PM       402          error 0x80070003: Reading manifest from location: AppxManifest.xml failed with
                                           error: The system cannot find the path specified.
    6/2/2016 2:55:53 PM       322          error 0x80070003: Cannot register the
                                           package because the following error was encountered while trying to read the
                                           package: The system cannot find the path specified.
    6/2/2016 2:55:53 PM       300          error 0x80070003: Cannot register the Microsoft.WindowsStore_8wekyb3d8bbwe
                                           package due to the following error: The system cannot find the path specified.

    • Proposed as answer by Slackjaw45 Friday, June 3, 2016 6:01 PM
    • Unproposed as answer by Slackjaw45 Friday, June 3, 2016 6:07 PM
    • Edited by Slackjaw45 Friday, June 3, 2016 6:19 PM
    Friday, June 3, 2016 5:53 PM
  • if u have solved the problem.... can u tell me what to do step by step?, pleaseeeee

    because im not good with this at all....

    Saturday, June 4, 2016 5:24 AM
  • Yep, this did it. Finally. 

    After running your CMD script (which basically called a PS shell and had it run the same old Get-AppxPackage string that the rest of the net is trying) it would fail and tell me to use Get-Appxlog -ActivityID 6070b752-b94e-0002-04ec-71604eb9d101 for more details. 

    I went over to PS and ran that...which told me two things close to the end:

    error 0x80070002: Reading manifest from location: C:\ProgramData\Microsoft\Windo
    kyb3d8bbwe.xml failed with error: The system cannot find the file specified.


    Windows cannot find the resource package manifest in the bundle file:
    C:\Program Files\WindowsApps\Microsoft.WindowsStore_11602.1.26.0_neutral_split.scale-100_8wekyb3d8bbwe\AppxManifest.xml.

    So not only was the _neutral_split.scale-100 folder missing in C:\ProgramData\Microsoft\..., the corresponding AppxManifest.xml was also missing in C:\Program Files\WindowsApps\... .  Once I was able to make copies of the -150 folder and .xml files in their respective locations (had to take ownership of the AppRepository and WindowsApps folders first...keep that in mind) and rename those copies to -100_ the CMD run worked perfectly and I was able to get Microsoft Store running again. 

    Thanks so much!!!

    Sunday, June 5, 2016 2:30 AM
  • I have used instructions by Slackjaw45 and madtown_jeremy and managed to finally fix the Windows Store!!

    What I did was the following:

    1. In administrative cmd I executed:

    PowerShell -ExecutionPolicy Unrestricted -Command "&  {$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation +  '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register  $manifest}"

    2. The above failed and it mentioned an ActivityID. I went into Powershell and entered:

    Get-AppxLog -ActivityID replace_this_with_the_ActivityID_returned_when_executing_command_in_1_above

    3.  A log will be displayed.  What you need to look at is:

    05/06/2016 18:58:48       475          error 0x80070002: Reading manifest from location: C:\ProgramData\Microsoft\Windows\AppRepository\Microsoft.WindowsStore_11602.1.26.0_neutral_split.THIS_PART_WILL_BE_DIFFERENT_FOR_YOUR_SYSTEM_8wekyb3d8bbwe.xml failed with error: The system cannot find the file specified.

    05/06/2016 18:58:48       726          Windows cannot find the resource package manifest in the bundle file:
                                           C:\Program Files\WindowsApps\Microsoft.WindowsStore_11602.1.26.0_neutral_split.THIS_PART_WILL_BE_DIFFERENT_FOR_YOUR_SYSTEM_8wekyb3d8bbwe\AppxManifest.xml.

    4. Go to C:\ProgramData\Microsoft\Windows\AppRepository (you will need to get ownership of this folder and any subfolders).

    5. Look for a file called Microsoft.WindowsStore_11602.1.26.0_neutral_split.THIS_PART_WILL_BE_DIFFERENT_FOR_YOUR_SYSTEM_8wekyb3d8bbwe.xml

    6. Copy the above XML file to somewhere else and rename it to the filename that was being expected in step 3.

    7. Copy the renamed file to: C:\ProgramData\Microsoft\Windows\AppRepository

    8. Go to C:\Program Files\WindowsApps (you will need to get ownership of this folder and any subfolders).

    9. Look for a folder called Microsoft.WindowsStore_11602.1.26.0_neutral_split.THIS_PART_WILL_BE_DIFFERENT_FOR_YOUR_SYSTEM_8wekyb3d8bbwe

    10. Copy the above folder to somewhere else and rename it to the folder that was being expected in step 3.

    11. Copy the renamed folder to: C:\Program Files\WindowsApps

    12. Close all open programs, command prompts, etc... and click on the Windows Store.  This time it will open :-)

    Sunday, June 5, 2016 6:10 PM
  • Finally Fixed!!!

    I finally was able to fix this issue, but it took a lot of different sources over and above what is provided in this thread. I put the exact procedure into my blog here. It has step-by-step instructions for how to fix this very annoying problem.


    Please upvote me if this works for you!

    Monday, June 6, 2016 1:11 AM
  • thak u guys :)
    Monday, June 6, 2016 12:46 PM
  • I had a similar problem with the Mail app. I did not need steps 8-11 in Godwin's fix above to fix it.

    My problem seems to have been caused by having support for various non-US keyboard layouts installed. This caused the Mail app to be installed with additional language localization data for each keyboard input method. But a subsequent update seems to have updated only the US-English version of the app, leaving my app in an inconsistent (broken) state.

    My fix uses the Event Viewer tool and a command prompt to copy the XML file to the location shown in the Event Viewer error message.  For more details about my fix (it is equivalent to Godwin's fix, steps 1-7, just a little bit different in the way it is done), see this link:


    (I also think the fix posted by ChaosFreak is similar, and should work, too, haven't compared it in detail.)

    Monday, June 6, 2016 5:15 PM
  • I had a similar problem with the Mail app. I did not need steps 8-11 in Godwin's fix above to fix it.

    Yep... I don't think you need to copy the actual app folders and rename. All I did was copy and rename the xml file used to register the windows app found in *C:\ProgramData\Microsoft\Windows\AppRepository\* and the app folder naming takes care of itself for the affected profile when you use the PS command to register (the renamed xml file contains the correct reference for the actual app folder).

    SO glad this issue is being resolved from the efforts we are making here! I find it utterly amazing and SAD that NO ONE from Microsoft has provided any reliable answer for this that I could find, and believe you me... I have searched EXTENSIVELY.

    Once again, the community steps up to resolve a problem that should have at least had an answer from the horse's mouth a LONG time ago...


    and Bob's your uncle ... the Store works once more and is updating apps successfully. Phew!

    • Edited by Slackjaw45 Tuesday, June 7, 2016 7:50 PM
    Monday, June 6, 2016 8:39 PM
  • I had a similar problem with the Mail app. I did not need steps 8-11 in Godwin's fix above to fix it.

    My problem seems to have been caused by having support for various non-US keyboard layouts installed. This caused the Mail app to be installed with additional language localization data for each keyboard input method. But a subsequent update seems to have updated only the US-English version of the app, leaving my app in an inconsistent (broken) state.

    My fix uses the Event Viewer tool and a command prompt to copy the XML file to the location shown in the Event Viewer error message.  For more details about my fix (it is equivalent to Godwin's fix, steps 1-7, just a little bit different in the way it is done), see this link:


    (I also think the fix posted by ChaosFreak is similar, and should work, too, haven't compared it in detail.)

    Like you I also have installed support for various non-US keyboard layouts. In fact the missing file and folder was related to one of these non-US localisations.

    Today I realized that I had the same problem with the Windows 10 weather app and I fixed it in the same way as I did for Windows Store.  What I also discovered was the following:

    On my hardrive I already had a file and folder with the name Microsoft.BingWeather_4.9.76.0_neutral_split.language-XX_8wekyb3d8bbwe

    but when launching Bing Weather it was looking for an older version: Microsoft.BingWeather_4.9.51.0_neutral_split.language-XX_8wekyb3d8bbwe
    so it was closing since it was not there.

    After I copied the renamed Microsoft.BingWeather_4.9.51.0_neutral_split.language-XX_8wekyb3d8bbwe to the specific paths, Windows Weather worked but it also deleted the renamed one I had copied (Microsoft.BingWeather_4.9.51.0_neutral_split.language-XX_8wekyb3d8bbwe)!

    So it is now using the latest version 4.9.76 and it is working (before the whole fix procedure it was looking for 4.9.51 which was not there).

    Tuesday, June 7, 2016 5:54 AM
  • THANK YOU THANK YOU THANK YOU! By summarizing everything into one blog entry, you have saved my heavily customized user account, and deterred the nuclear and Death Star options! 

    As AndersKlemets notes below, I believe this is due to installation of other language modules, as the issues I had were with French, German, Spanish, Luxembourgish, and Russian (keyboard only).

    Wednesday, June 8, 2016 4:25 PM
  • I completely agree with you re languages. I had installed language support for French, German, Spanish, and Luxembourgish, as well as Russian keyboard only.
    Wednesday, June 8, 2016 4:26 PM
  • I agree that this issue is related to extra keyboards / non-English language support.

    I also found that it affects those apps with local content (weather, news, sports, money) + Windows Store.

    Also all apps which could not open were stuck in version even though version was already present on the hard-disk.  The 'fix' completed the update to and deleted

    Thursday, June 9, 2016 6:02 AM
  • Thanks very much for the solution, n.able-tech-services!
    Saturday, June 11, 2016 8:01 AM

    I spent so many hours, trying to understand this f.. problem.

    The problem for me was occuring on Surface Pro 4 with several accounts : a MS live.com account, an outlook.fr account and a domain account for my work. First time it happened was on the MS live.com account. I started to loose Windows Store but it was working on the other accounts.

    I managed to fix it using this nice FIXWIN10 tool that you can find on the net.

    Then, the problem occurde with my domain account and it was the beginning of the nightmare. Merci Bill !!!

    Thanks to your posts, I could get Windows Store back on this account, but the apps are still not registered and I am afraid I need to register them one by one, even the genuine "Photos" app delivered with W10. What a shit !

    Unfortunately, when I run the command

    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    Then I get a multitude of 0x80073CF6 messages for each app.

    I am not able to find a easy way to register all apps in one go. The bad directories or file names are really annoying. There must be a way to point to the right directories. Anybody has an idea where an index-type file would be ?

    I have found a way to solve the problem, but it is too much ! (using MCT) ... here --> 


    I think I will wait for the next fix from MSFT, but when ???

    Good luck to all !


    Saturday, June 11, 2016 3:10 PM
  • Unbelievable! It worked after copying 3 files...

    Thanks ChaosFreak

    Sunday, June 12, 2016 7:57 PM
  • You are a deity!

    This was exactly the problem, thank you so much. Was pounding my head against my monitor for a week trying to fix this. Much props to you!

    Tuesday, June 14, 2016 8:01 AM
  • AWESOME!!!! Truly solved it. And the SCARY PowerShell Script at Step.19 is the key to all, in my opinion. Thank you very much, saved me a whole day!
    Monday, June 27, 2016 12:36 PM
  • Legend!  Thanks so much for working through this.  It's been plaguing me for months and finally working.
    Thursday, July 7, 2016 6:24 AM
  •  This truly was one of the most annoying and frustrating Windows problems I had to debug. Thank you so much for putting this answer together. Like everyone else here, I've spent the entire day attempting various solutions but nothing worked, until your approach!!! I am so happy now. Thank you! 

    Microsoft devs, you should be ashamed that the entire set of Windows 10 Modern Apps can be utterly destroyed by such a simple bug. Here's your fix to implement in a future update: If the file doesn't exist, create one off of a similar file if there is one!! So simple!

    Monday, July 11, 2016 5:01 AM
  • Created an account just to say thank you. This worked like a charm.
    Thursday, June 22, 2017 4:16 AM
  • My laptop started experiencing this issue now in 2018 three years after this was originally posted here! I see there is finally a solution to the problem herein. I will be seeing if this will work for me when I have some time (Microsoft seem to think we users have infinite time dealing with their buggy solutions). Meanwhile, I have this to say to Microsoft: you guys should be ashamed of yourself for proving no input on the matter and for not having resolved the issue after this long. It makes me wonder if the Universal Windows Platform is really worth the trouble if these are the kind of issues we're going to be experiencing. UWP needs to be able to be reinstalled independently of the rest of the system; after all, isn't that what UWP is supposed to be - a separation of the operating system and the run-time environment? If so it should be possible to uninstall it or reinstall it completely separately from the rest of the system. Until that's not possible, UWP is not a proper independent layer. As it stands right now, UWP feels like spaghetti code nested deep with the operating system. That's bad implementation-wise and bad for maintainability and manageability by developers, administrators, and end-users. Come on Microsoft!
    Monday, April 16, 2018 1:36 PM
  • I'd like to post my own findings in here as well in case anyone has a similar issue.

    My Windows 10 Pro installation was seemingly bugged from the start with some weird issues after upgrading from Win7 Pro. Not only was the Media Creation Tool having issues at the time with Win7 x64 that I managed to dance around and finally get it to do an upgrade but after installing Win10 it seemingly had an issue with any video driver I installed except for the Microsoft Basic Adapter driver whenever I put my PC into sleep mode and woke it up videos would fail to play and YouTube wouldn't work until a reboot and it seemed a little bit sluggish, I tried everything, disabling fast startup, disabling hibernation, messing with my power settings which were already set correctly, tried various versions of my R9 270's drivers from a few months back to the most current and nothing solved it, I figured at this point it had to be an audio driver issue which I could find no fault in or possibly a driver that was running from my previous Win7 installation that Win10 didn't nuke when upgrading. Which led me to disable the Ai Charger driver from ASUS, I don't use the feature myself and it's not needed for the system to run. Well, that ended up being a big mistake and I went through the pain staking process of having to bust out a PS/2 keyboard and try to diagnose why only USB mice and keyboards wouldn't work on Win10 after disabling a driver that wasn't needed, this in turn also seemingly disabled some services in Windows as I believe disabling the ASUS driver actually stopped some of the HID driver services from functioning as it was so deeply embedded into my system. Every single HID had that ASUS driver attached. Long story short I was able to re-enable the driver and get Windows to recognize KB/M again.

    And this is where another problem began. So the whole situation bugged my install of Win10 even further and System Restore wouldn't properly restore because the WindowsApps folder was locked and even System Restore couldn't access it. This is supposed to have full TrustedInstaller and System permissions but I'm assuming the installer service UWP apps use was disabled for some reason and for another reason even System didn't have access to the folder. And around the same time the Realtek Audio UWP app wouldn't install, don't know if that's related but it started before the issues actually cropped up and it seems to be a common issue with the Realtek app. Then I noticed no Windows Store apps would update, so I decided to run WSReset which did nothing, ran the Windows Store troublshooter which suggested purging it and reinstalling it, did this and bam, WS gone completely and the GetApp command wouldn't work, it would error out as this thread suggests no matter what I tried.

    So I did an in-place upgrade via my Win10 Pro USB drive after exhausting every possible fix and assumed there was a service permission or config problem that was stopping PS from being able to install the WS package.

    Three hours later, my system is now nice and fresh but an in-place upgrade does not mess with WindowsApps files though all the services were restored to their former glory.

    So I decided I'd check the WindowsApps folder since the package installer couldn't "find it". I found it, tried to acces it and I was denied even with admin rights. I checked the ownership settings and found that it was seemingly corrupt as System, admins and users had had no access to the folder which would explain why PS ran as admin couldn't install to it. I did an advanced ownership take over on it and voila, PS could reinstall WStore without a hiccup and all my installed apps updated inside the WStore app.

    So far no problems so if anyone is having a similar issue you can try to take ownership of the WindowsApps folder and leave the permissions intact for System and TrustedInstaller.

    But at the end of the day the original issue that caused all of this headache in the first place is still there, I cannot successfully wake my PC without having to reboot it in order to enjoy videos but at least II'll be ready for when Halo Infinite launches on PC.

    Saturday, January 19, 2019 2:28 PM
  • I use Eset Internet Security and this did the trick. There were still errors (but now not <g class="gr_ gr_101 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="101" id="101">immeditely</g> from the beginning), and my problems got solved:
    -from the beginning, calculator and photos <g class="gr_ gr_217 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="217" id="217">wasn't</g> able to start for different reasons
    -after I've first run that command I wasn't able to open the Settings app from <g class="gr_ gr_478 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling multiReplace" data-gr-id="478" id="478">it's</g> start menu button, now it also got fixed
    Saturday, May 25, 2019 7:06 PM