OWA 2010 SP1 Search problems RRS feed

  • Question

  • Greetings! Curious if anyone else is finding issues liek this with OWA after the update to SP1;

    We have a diverse client base of Window XP, Visa, Win7 and Mac OS-X machines (school district), running various versions of IE and Firefox to access OWA.

    Prior to the SP1 update all users were able to use the search function in OWA, however after SP1 we are left with Firefox users who are unable to perfrom searches, they receive the following error;

    "The action could not be completed"

    Running the same search in IE works fine. The firefox versions range from 3.5.11 up.

    Friday, September 10, 2010 5:57 PM

All replies

  • Hi,

    AFAIK its a known issue with SP1 for further assistance please read this article I hope this will help you.



    Shafaquat Ali.

    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, URL: http://blog.WhatDoUC.net Phone: +923008210320
    Friday, September 10, 2010 6:10 PM
  • Hiya,

    I hadn't heard of it as a known issue? Pre-release there was a lot of testing with Firefox from various customers; we have many users on all those platforms, plus various flavours of Linux using OWA premium w/ Firefox; In fact I've just searched my mail from Firefox to find mention of any related issue - so there may be a solution.

    First questions - Does this occur on any other browser? E.g. Chrome, Safari on Mac? Does it happen with every copy of Firefox, or just some? Does it occur with the latest Firefox update 3.6.9?


    Steve Goodman
    Check out my Blog for more Exchange info or find me on Twitter

    • Proposed as answer by Pankaj.Rai Saturday, September 11, 2010 3:31 PM
    Friday, September 10, 2010 8:07 PM
  • Shafaquat,

    Thank you for the follow up. I didn't find anything in the posting that specifically related to firefox. Can you direct me to the known issue?

    Monday, September 13, 2010 2:24 PM
  • Hi Steve,

    No, at this point it only occurs on Firefox 3.5.11 and above, mainly on Mac's but occasionally on windows. I have one user who has reported the issue on IE 7, but I have not confrimed that yet.

    It does not happen with every version of firefox, but it does seem to be a problem that specific users can reproduce each time. I have seen a user reproduce it on 3.5.11, update to 3.6.9 and get the same result.

    Thanks for the follow up!


    Monday, September 13, 2010 2:30 PM
  • Hi Keith,

    I would like to repro if possible. Can we rule out a few things though?

    1) If you pick a user who has this issue, find the mailbox database they are on, does the Test-MailboxDatabase -MailboxDatabase <DB> command show any error?

    2) Is there anything in the event logs on the CAS or Mailbox servers that the user would be located on/access through at the time of the search?

    3) Does your EWS internal/external URL's have the same FQDN (e.g. mail.contoso.com) as your OWA URLs (if not, should they?):

    Get-WebServicesVirtualDirectory *|fl Server,ExternalURL,InternalURL
    Get-OWAVirtualDirectory *|fl Server,ExternalURL,InternalURL

    4) Does the issue follow the user(s) around whatever computer they use firefox on, or is it specific computers running firefox?

    5) Is there any difference in the firefox extensions between users who this works for and doesn't work for?


    Steve Goodman
    Check out my Blog for more Exchange info or find me on Twitter

    Monday, September 13, 2010 3:08 PM
  • Thanks Steve,

    I am having our support team reach out to the clients to gather this info and will post back what we find.

    Great blog by the way!


    Wednesday, September 15, 2010 6:06 PM
  • We have the same issue since applying 2010 SP1, except our problem does occur with IE 7 and 8.  Have not found a resolution.
    Thursday, September 16, 2010 6:41 PM
  • What does Test-MailboxDatabase -MailboxDatabase <DB> show, if you try against a DB a user who cannot search is on?


    Steve Goodman
    Check out my Blog for more Exchange info or find me on Twitter

    Thursday, September 16, 2010 7:28 PM
  • In our case the following app event is logged with search attempts:

    Log Name:      Application
    Source:        MSExchangeIS Mailbox Store
    Date:          9/17/2010 7:42:01 AM
    Event ID:      9877
    Task Category: Content Indexing
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Servername

    Content Indexing function 'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error code from MSSearch.
    Mailbox Database: Mailbox Database 0963940198
    Error Code: 0x80043629

    We have performed the following to attempt resolution:

    1.  Stopped search indexer, deleted catalogs, and restart indexer.  Same result.

    2.  Created a new test mailbox database and test user, with the same result.

    No search problems prior to SP1.

    Friday, September 17, 2010 12:48 PM
  • I get nearly the same error, but with a different Error code. The problem started immediately after installing SP1. The error happens only in Outlook with a full search in the search pane. Searching for a subarea ( e.g. "subject:test" ) doesn't result in that error. Further OWA doesn't raise the error.


    There is a third thread in this forum that has more or less the same symptoms. So it is likely that there is a bug in SP1 and it would be really helpful if MS would take a look at it.



    Here is my error:


    MSExchangeIS Mailbox Store: 9877: Content Indexing function

    'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error

    code from MSSearch. Mailbox Database: Mailbox Database 0030305139 Error

    Code: 0x80041606



    Michael Kocum [DataEnter]


    Sunday, September 19, 2010 5:24 PM
  • Yeah, it's just wonderful.  It actually really stinks for me.  I use OWA almost exclusively when out of the office and not having search function has forced me to either bust out the laptop or logon to a TS system for searches.
    Thursday, September 23, 2010 12:50 AM
  • I'm having the exact same error as you Michael, also right after installing SP1. It only occurs with Outlook searches, OWA is unaffected. I re-created the catalogs but to no effect.  :-(    MS please look into it.


    Friday, September 24, 2010 4:46 PM
  • Hello, I've faced with the same problem. Browsers and OSes do not matter.

    Log Name:      Application
    Source:        MSExchangeIS Mailbox Store
    Date:          9/17/2010 7:42:01 AM
    Event ID:      9877
    Task Category: Content Indexing
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Servername

    Content Indexing function 'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error code from MSSearch.
    Mailbox Database: Mailbox Database 0963940198
    Error Code: 0x80043629



    For the moment I've found workaround:

    Search is working in OWA only from Favorites\Unread Mail. It is searching through the all mailbox ( not only filtered as new).

    I think it is trouble in OWA....


    Wednesday, September 29, 2010 4:13 PM
  • Yup, exactly the same here. I can't search from "inbox" or any other folder and the error above is reported on the exchange server. New database/user makes no difference.

    Searching on unread works and also as above it's showing everything rather than just the unread ones when I search, It's a workaround for now to ease some of the agro from staff here, but it's not ideal.




    Monday, October 4, 2010 9:00 AM
  • Hi Guys,

    I think I've fixed it on our server now, I had to rerun the schema upgrades for SP1 (using the sp1 setup files...) and restart the exchange services.  After that, search works as intended again.



    Monday, October 4, 2010 9:39 AM
  • Hi Guys,


    I've tried the setup /PrepareSchema + reboot as suggested, but still get the same problem with OWA search.


    Content Indexing function 'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error code from MSSearch.
    Mailbox Database: Mailbox Database
    Error Code: 0x8007007e

    Monday, October 4, 2010 3:03 PM
  • Did you do /prepareAD as well?
    Monday, October 4, 2010 4:09 PM
  • Did you do /prepareAD as well?

    WOW WOW WOW DrCheese128 simply the best!



    PS: first - setup /PrepareAD

          second setup /PrepareSchema + reboot

    • Proposed as answer by OVE19 Wednesday, October 6, 2010 9:22 AM
    Tuesday, October 5, 2010 8:18 PM
  • PS: first - setup /PrepareAD

          second setup /PrepareSchema + reboot

    Hi, this is the solution?

    Which setup? From the Exchange 2010 SP1? The setup should anyway refresh the schema, or not?

    We have the same problem only with OWA and with Firefox and IE.



    Wednesday, October 6, 2010 9:31 AM
  • Which setup? From the Exchange 2010 SP1? The setup should anyway refresh the schema, or not?

    We have the same problem only with OWA and with Firefox and IE.



    Yeah, Even tho we'd installed SP1 using a schema admin account it looks like it hadn't done it, no idea why.
    Wednesday, October 6, 2010 11:30 AM
  • Hi

    I've tried now, described above. Unfortunately it did not work for me.

    Any other ideas?



    Tuesday, October 12, 2010 12:25 PM
  • Here the same... It did not work for me to..
    Thursday, October 14, 2010 7:27 AM
  • same here: windows 7 with office 2010.


    Monday, October 25, 2010 6:18 PM
  • Didn't work for me either.  I am unable to search in Exchange after SP! and i tried both setups using exchange 2010 sp1


    Help!  Driving my users nutz

    Wednesday, October 27, 2010 2:38 AM
  • Any ideas..?


    Function CISearch::EcGetRowsetAndAccessor detected that content indexing was disabled for database 'Mailbox Database 0116413845' because of error '0x80041820' from MSSearch.


    Is found in the event logs and owa gives the error the action could not be compelted.  Only happened after sp1 update.

    Thursday, November 4, 2010 4:23 AM
  • Hi

    Yesterday i installed the Update-Rollup 1 for Exchange Server 2010 SP1. I hoped this fixes the problem. I'm afraid not.

    Friday, November 5, 2010 4:49 PM
  • We have the same issue since applying 2010 SP1, except our problem does occur with IE 7 and 8.  Have not found a resolution.
    We have this problem too - no search in any browser using OWA with Exchange 2010 SP1. We're going to reboot the servers shortly to see if that fixes ...
    • Proposed as answer by WestNab Monday, November 8, 2010 4:15 PM
    Monday, November 8, 2010 2:13 PM
  • We found 'Microsoft Search (Exchange)' service on Client Access Servers was set to 'Manual' and not running. Start and set to Automatic - seems to fix! Is it this simple to fix yours?

    This is the fix I tried to flag, but somehow the flag is on the previous post ...

    • Proposed as answer by WestNab Monday, November 8, 2010 4:19 PM
    Monday, November 8, 2010 4:18 PM
  • Hello WestNab,

    This fix our substring search problem in OWA.  I don't understand why this service was marked as MANUAL vs. AUTOMATIC.  Maybe somebody from Microsoft Exchange Team could respond and suggest that this service should be marked as AUTOMATIC.

    Thank you,


    Monday, November 8, 2010 5:01 PM
  • Still have the same issue.  I have done the ad prep, restarted microsoft exchange search and search indexer and also made sure they were on Automatic.

    Any other thoughts?

    Friday, November 12, 2010 6:56 PM
  • Our "Microsoft Search (Exchange) Service is also set to 'Manual', but still running, because i have often rebuilded the index. I think the Microsoft Search service starts on demand.
    Monday, November 15, 2010 11:42 AM
  • Just thought I would chime in here as well. I'm running a DAG exchange 2010 SP1 w/ UR 1. I get the following error about 30 times a day. Outlook searches work about 3 out of 5 times. For the 2 times it doesnt work, Outlook sits there thinking with no search results and this error is logged in the exchange server.


    Content Indexing function 'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error code from MSSearch.
    Mailbox Database: SATA1_MailboxDB
    Error Code: 0x80041606

    Thursday, December 9, 2010 8:15 PM
  • After I installed SP1 Update rollup 1, the search worked. After a reboot the search does not work again. I also ran the SP1 setup.exe /prepareAD and /prepareschema command without any luck.

    Deleted the indexes, and started to rebuild it. I hope this will solve the problem.

    Saturday, December 11, 2010 8:51 AM
  • Guys, I know this not the solution but somehow I managed to install SP1 update rollup 1 again, and after this update the search works until I restart the server.

    Funny isn't it? :-)

    I think we have to wait for the fix from MS developers accourding to this topic:


    Saturday, December 11, 2010 3:10 PM
  • i had the same problem. migrated from 2003 to exchange 2010 sp1 with rollup 2. i also had the problem that OOF messages were not sent for some users. i created a new mailbox database and moved the users and the search started to work instantly. seems something with the store was not ok.. but i had created a new store during the migration and nothing bad with the server happend like power outtage.. strange. 
    Wednesday, January 19, 2011 10:31 AM
  • After reboot search is broken. To fix just restart MSSearch services and service works again. I've changed Startup option of MSSearcg to Automatic ( delayed ) . It helps for some time. Can not guarantee 100% that it is solution ( can not reboot exchange a lot to test it :) .
    Monday, February 28, 2011 8:26 PM
  • So, 6 months+ after SP1 and no hotfix or an official answer on the problem with search through owa?


    I have run setup /Prepare-AD/Schema from my CAS-HUB server and then restarted but I still get the same error. It is really frustrating...


    And just to be sure, I have run the commands from this CD: SW_DVD9_NTRL_Exchange_Svr_2010_X64_MultiLang_1_ProdAct_wSP1_X17-13445.ISO


    Is that ok or am I missing something?

    Sunday, April 3, 2011 10:36 PM
  • I have run the schema updates above, Installed SP1 Rollup 1 - that didn't help.

    Restarted Exchange Search - that didn't help.

    Restarted Server - that didn't help.


    I hope Microsoft fixes this.  P.S. I went through a 2 day phone support session with Microsoft on this and they could not make it work either.

    Sunday, April 24, 2011 11:50 AM
  • Exchange 2010 SP1 Rollup 3v3  also did not fix it.  Following the history of this issue it is strange that at least 5 different solutions exist that fix some systems and not others.  I hope this is on Microsoft's agenda.  Their support person said it is a "known issue" but it sounds like she was reading from these forums because her attempts to fix the issue were the same ones that I have seen on various forums. 

    Does Microsoft not know there is a problem and do they know what the cause(s) can be ?

    I had an experienced administrator from a large bank tell me they never install SP1 on anything, because they have burned to many times in the past.


    Sunday, April 24, 2011 10:16 PM
  • An update from me.


    I have setup a second Database mail server and added this as a DAG member. Each time I activate the database on the new DB Server, search in OWA works perfect. Problem exists only on the first one. I am thinking on entirely removing the old DB Server and installing it from scratch. I think thsi will fix the problem although this is not a proper solution for everyone...

    Monday, April 25, 2011 9:15 AM
  • A while ago we opened a support ticket to Microsoft about this. Yesterday I received another status update about this.

    It definitely IS a bug and Microsoft has admitted it.

    Tuesday, May 3, 2011 8:00 AM
  • Do they have any ETA? How long ago did you open the ticket? Thanks
    Tuesday, May 3, 2011 11:50 AM
  • I just found this issue today.  I have been running SP1 for a while with no issue.  The issue started overnight, without any updates or computer reboots.  It has seemingly appear from nowhere.
    Monday, May 9, 2011 2:37 PM
  • I installed SP1 update rollup 3v3 then the installer asked a reboot. After the reboot I still expreienced the problem. I installed the update rollup again, no reboot required, and the problem is gone. The only thing I fear that not having to reboot the server. I sure that after the reboot the problem occurs again.

    Somewhere I read that this problem is mailbox database related. Anyone can create a new mailbox database and move a few mailbox there and see that they can search or not?

    Monday, May 9, 2011 2:45 PM
  • Does anyone knows what to do when setup /prepareAD and PrepareSchema don't start because there a difference between version ?

    Installed : Exchange 2010 SP1 with Update rollup 3

    Setup files : Exchange 2010 SP1.

    Wednesday, May 11, 2011 1:01 PM
  • As far as I know You don't have to update the schema if You install SP1 ur3v3.

    Anyway are You member of the Schema admins group?

    Wednesday, May 11, 2011 1:58 PM
  • Hello.  Just wanted to add my 2 cents.  We are running Exchange 2010 SP1 on a Windows 2008 64 bit SP2 virtual server.  This search issue just started occurring after 6 months of pretty hardcore use.  We have 25 databases with a total of 480GB of email.  To get it working again, we just restarted the 2 MS Search Indexing services.  Of course, chances are it is going to reoccur, but this technique is working for us at the moment.
    Wednesday, May 11, 2011 9:18 PM
  • I have all the rights I Need.
    I opened a case at Microsoft Support Center.

    Wait & See.
    Thursday, May 12, 2011 2:08 PM
  • Right

    Microsoft announced me Exchange 2010 SP2 will correct this bug.
    It will be available in July.

    Now, I just have to wait...

    Tuesday, May 17, 2011 2:20 PM
  • I dont suppose this is written anywhere? Or did they just tell you over the phone? Thanks

    Wednesday, May 18, 2011 2:27 PM
  • They told it to me by phone and email.
    But I think it will be a rollup instead of SP2.

    Thursday, May 19, 2011 8:15 AM
  • Thanks to you all, especially confirming that microsoft will provide an update for this in the form of a rollup or SP2.  I tried searching via filter drop down for Unread emails, and the seach does work for unread mail, but thats not really the full mailbox.  I have a Exchange 2010 SP1 to which I installed the latest Rollup v3.3 and that didnt have any effect, still get the " The action could not be completed. Please try again". might log a call with Microsoft just to see if they can provide a hotfix before the newer rollup release in July.

    Restarting the MS Search and recreating full text index didnt work either.

    Thursday, May 19, 2011 4:24 PM
  • In my testing, searching in OWA didn't work on six databases, but did work on two. Ironically enough, those two databases were on the same server - the other databases are on different servers. So, even though it could be database-level related, it might be server-related instead.
    Tuesday, May 24, 2011 9:57 PM
  • Thought I may as well add myself to this list.  This happens randomly for all our databases (4 of them).  Searches within Outlook 2010 work sometimes and other times just fail.  On the mailbox server we see:

    Content Indexing function 'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error code from MSSearch.

    Mailbox Database: Users A-M

    Error Code: 0x80041606

    Running Exchange 2010 SP1 Rollup 2 here.  Was going to see if Rollup 3v3 fixes it but from the looks of it it doesn't.

    We run Outlook 2010 via Citrix Xen so it is not in cached mode.  I have rebuilt the indexes and this has done nothing.  Next step was going to be creating a new databse and moving users to that database but given we have one public folder database and four standard ones we can't due to the 5 database limit on 2010 standard!!  Frustrating. 

    Wednesday, May 25, 2011 4:57 AM
  • Restarting the MS Search service fixes this for us as well (as a workaround).  Hopefully it will be fixed permanently in sp2.
    Tuesday, May 31, 2011 5:22 PM
  • This is apparently fixed in rollup 4 for SP1 but it has been pulled due to issues.  Check it out when it comes back again as v2 or rollup 5

    Monday, July 18, 2011 11:46 PM
  • This is apparently fixed in rollup 4 for SP1 but it has been pulled due to issues.  Check it out when it comes back again as v2 or rollup 5

    I hope they re-release this soon because it's very annoying. Haven't gotten much heat from this yet since most people are on vacation.. MS please release a fix soon!
    Wednesday, July 20, 2011 1:48 AM
  • I can confirm that the solution above fixed search and indexing for me.

    I was getting Event ID: 9877 Error Code: 0x8007007e after attempting a search in OWA.

    A quick look confirmed that I didn't have any of the symlinks required in my exchange bin folder. 

    Tuesday, August 16, 2011 1:05 PM
  • "FIXED !!!"

    Thank You,  This has been a problem for us because we are heavy OWA users.  I am grateful for the solution, but I am also surprised that it took so long for this solution to find this forum.  

    Thursday, August 18, 2011 1:04 PM
  • Hi,

    In my case i have restarted following services and it worked for me.

    • Microsoft Exchange Search Indexer
    • Microsoft Search
    • Microsoft Active Directory Topology
    • RPC

    Please note that MsADT and RPC may disconnect users outlook connection for some time.




    Wednesday, September 7, 2011 10:03 PM
  • hi guys i am facing the same as mentioned above please give me resolution.




    Wednesday, September 14, 2011 9:49 AM
    • Proposed as answer by wasim_sha Friday, September 16, 2011 4:08 AM
    Wednesday, September 14, 2011 10:31 AM
  • Hi Everybody,

    On 8 October we had a controlled shut down for maintenance over data center and Exchange Servers is offline (a DAG with four mailbox servers and NLB with two CAS/HT servers) after the activity and check the status of databases copies was Failed in the ContentIndexState item, I ran the command Update-MailboxDatabaseCopy-CatalogOnly for each DB, the state changed to Healthy, but on Monday, October 10, users began to report that the searches in Outlook and OWA not working.

    I started reviewing the incident; in the active mailbox server 9877 events appeared. Search by Google and Microsoft forums and found several solutions with some effectiveness and some not. Currently the organization is with SP1 RU 3V3.

    One such solution was to use ResetSearchIndex.ps1 script on one of the DB to verify its effectiveness, and not working. Of the many forums that I found is this post, Repair-ExchangeSearchSymlinks.ps1 script, but the environment does not correspond to a single server and therefore leave it as a last resource, additionally installing the RU 5 was in my plans solution.

    That same day an active mailbox server hardware failure, the server was out 26 hours. The server kept copies began hosting the 9877 event from the active server fails to recover.

    Currently I use copies balancing and resume databases scripts in the early morning hours as scheduled tasks, the last event in 9877 reported by the passive server was on October 12th at 23:55, the next day the server recovery took priority, by the script, but the last event on that server 9877 was the day October 10 13:25, 45 min before the failure, after that no more events appeared 9877 and ran searches for users of these databases stored on that server pair. While the other remained active server 9877 event.

    However, we returned to the data center maintenance on October 15, copies suspended, dismount DB and shutdown. Three hours went on the system, the DB was up correctly and missing databases in search for repair, were solved. For this case copies balancing and resume databases scripts was not execute, when the system went on the 9877 event was already history, the last event reported was two hours before the event, October 15 at 16:00. Currently the search function in DB is works, I've tested, I will wait on Tuesday if users report something different.

    I copy all my experience with this incident and you can draw your own conclusions. PD Sorry for my english.

    Sunday, October 16, 2011 3:41 PM
  • Hi will ,

    Thi sissue has been solved in Rollup 6 with Exchange server 2010 with sp1

    here is details; http://support.microsoft.com/kb/2616127


    Best Regards, Sonat YAYLALI
    Tuesday, November 8, 2011 1:08 AM
  • Hi Sonat,


    SP1 Update rollup 6 not helped for me. :-((((





    Monday, November 21, 2011 10:51 AM
  • Hi.


    Just to be sure. Tamas did you do ALL what the 2616127 instructed you to (including the reg entry). Applying the rollup is not enough.


    "After you install the update rollup, to have us set the maximum number of query restriction nodes to 1,000,000 for you, go to the "Fix it for me" section. If you prefer to set the maximum number of query restriction nodes yourself, go to the "Let me fix it myself" section."

    Wednesday, January 4, 2012 11:55 AM
  • Hi,

    Rollup 6 doesn't resolve the problem for me.

    And I've correctly followed all the 2616127 instructions.

    Any other idea ?

    I'll try to apply SP2 if nobody have idea.


    Edit : It works for me (http://blogs.technet.com/b/exchange/archive/2011/06/30/after-installing-exchange-2010-service-pack-1-searching-via-owa-or-outlook-online-mode-fails.aspx), thanks swb-mct!

    • Edited by Noreu Thursday, January 5, 2012 10:24 AM
    Wednesday, January 4, 2012 4:39 PM
  • Exchange 2010 sp2 still did not fix the search issue on OWA....

    Any other ideas???

    Thursday, February 2, 2012 12:19 AM
  • Hello, 

    We've had the same issue.  Outlook was searchable- no issues, OWA was searchable in only in the Favorites Unread which would show everthing which is a work around.  The Inbox was unsearchable.   We were also seeing the same error above as Jasonev was seeing.

    Configuration 4-node Mailbox Role server in a DAG configuration.  2 mailbox servers with active databases had no issues for users attempting to search OWA.  2 mailbox servers did have the issues searching. 

    I moved the active databases after hours so the two mailbox servers could be restarted without impacting users.  I created a new database and copies on all servers.  I moved a test user mailbox to function test the OWA search issue.

    I ran the Repair-ExchangeSearchSymlinks.ps1 as outlined in http://blogs.technet.com/b/exchange/archive/2011/06/30/after-installing-exchange-2010-service-pack-1-searching-via-owa-or-outlook-online-mode-fails.aspx on only 1 server and tested.

    Results were the same.  I did a followup of the file structure for the Symlinks and the files were present on both functioning and nonfunctioning Search servers.  I also reviewed the tasks of the Repair-ExchangeSearchSymlinks script and saw the 2 stop services commands, the MS Exchange Search Indexer and the msftesql -exchange. 

    So that just led to doing a restart of one of the servers.  I was able to test the search function and functioned normally.  Restarted the second server and the same, functioned normally. 

    • Proposed as answer by DaveKreitel Wednesday, February 29, 2012 6:01 AM
    Friday, February 24, 2012 6:52 PM
  • Hello,

    We started having this issue after April 2012 patches. Exchange servers are 2010 SP2 RU1. Has anybody else had this problem recently? So far none of the offered solutions have worked.

    Tuesday, April 17, 2012 12:43 PM
  • http://blogs.technet.com/b/exchange/archive/2011/06/30/after-installing-exchange-2010-service-pack-1-searching-via-owa-or-outlook-online-mode-fails.aspx resolved the issue for me too, AFTER THE MAILBOX SERVER WAS RESTARTED. Took about 6 Hours for the Index to rebuild for a 225GB Database [time between Event ID 109(start) and Event ID 110(complete)].

    Wednesday, April 18, 2012 6:40 PM
  • I'm the administrator for a SBS 2011 server that is still having this issue. I have rebuilt the Index file several times without much luck. Randomly the search will work, but more often not.  I’m at my wits end and any suggestion on how to fix this issue would be great.
    Friday, June 22, 2012 4:47 PM
  • I run into the same issue.

    Exchange 2010 SP2 installed, i just discovered the problem with the help of a OWA user.
    I can't run /prepareAD or /prepareschema because the AD version i got is greater than the one on the Exchange DVD.

    Tried to run the powershell scripts mentioned here but didn't solve the problem.

    I'm very surprised Microsoft did not end with a real FIX. Most of the posts talks about SP1 installation problem. We are now 1 year later and still having the problem despite multiple Rollup and Service pack.

    Please help us find a solution.


    Tuesday, July 3, 2012 9:45 AM
  • I finally get rid of the issue.

    Despite the fact Rollout 1,2 or 3 of the SP2 doesn't contain any fixes for this problem, installing the rollout 3 made the problem gone away.
    In the meantime i was still trying to fix the problem. All my CI files were OK and reset 2 or 3 times, the symlinks were OK too but it didn't work until i installed the SP2 Rollout 3.

    Some exe and dll files are replaced, maybe that cure the thing. I will monitor the server for the next week but for now, OWA search is now working.


    Wednesday, July 18, 2012 3:33 PM
  • We have the same problem.  We are on SP2 ru2.  I will report back after we apply the rollup3.

    Monday, July 30, 2012 6:21 PM
  • I am also having this same problem.  Multiple uses cannot search in OWA regardless of what their browser is.  (Exchange 2010 SP1 v14.1.218.15)  I have done some research and have found that there's essentially two options. 

    1. Run the script seen here: 


    2. Install SP2.

    Does SP2 include the script fix as mentioned above?

    Cheers - Will

    • Edited by WBrach Monday, August 20, 2012 3:18 PM
    Monday, August 20, 2012 3:17 PM
  • Did the rollup work?

    Cheers - Will

    Monday, August 20, 2012 3:24 PM
  • Can anyone confirm if the issue is fixed in Exchange 2010 sp2 RU3?

    Friday, September 7, 2012 7:32 AM
  • Am also looking for a solution to this as I have a client who is suffering the same issues on an SBS 2011 installation.  Looking to deploy Exchange 2010 SP2 to see if this fixes the issue, but would be keen to know if the above solutions have worked? Anyone? 


    Wednesday, September 12, 2012 4:01 PM
  • I had this problem on SBS 2011 (exchange 2010 w/SP2 up to RollUp6 installed)

    works if you do search from unread mail

    have tried rebuilding indexes/restarting search index service/deleting catalogs / rebuilding / running repair scripts - these work for a little while then stop

    doesn't make a difference which browser you use

    Migrated from SBS 2011 to Full Exchange Std 2010 w/SP3 on a Windows 2008R2 server - still same even though it is a new server (forklift upgrade using swing migration)

    Am waiting to move mailboxes of users that predominately use OWA to a fresh mailbox database to see if that makes a difference.

    I can't believe that microsoft acknowledged this as a bug in SP1 and it is still on-going - maybe they won't bother fixing it and try to push everyone to Office 365?

    Larry (Netforce)

    Tuesday, March 5, 2013 11:03 AM
  • Open outlook using Outlook/cleanfinders switch as this will reset the search folder for that mailbox.

    Then just check in OWA whether the problem exists.

    Tuesday, March 5, 2013 1:23 PM