locked
Limited Internet after Upgrading? RRS feed

  • Question

  • I'll try to do a complete rundown of everything as sensibly as I can.

    I upgraded my Asus Transformer T100TA tablet from 8.1 to 10, and I noticed I had no internet (it stated limited connectivity on everything). I found that it was a bit clunky as well, so I reset back to 8.1, immediately shut down the tablet, and did a fresh install, wiping all partitions in the process. After getting drivers installed for all the unknown devices, everything started working fine.

    Fast forward to yesterday, I downloaded the 10130 64-bit iso, checked its SHA-1 to make sure it matched with HashTab, and proceeded to upgrade one of my desktops (the one I'm on now) to windows 10.

    Before I get into what happened, the components of the desktop:

    2 Windforce GTX 970s in SLI
    1 Intel 4970k
    2 8GB sticks of Ram
    1 MSI Z87 Mpower MAX AC motherboard
    1 Samsung SSD (250GB) for the OS
    2 3-TB Seagate Barracudas in Raid-0 for all other data/games/programs, with a few exceptions

    I had changed the program files locations in the registry (to default the installation path to my Raid array), so I reverted those changes back before upgrading, and made a system restore point first, just in case. After upgrading, I noticed a few things lacking: My NVidia drivers had disappeared, my first monitor was missing and not functioning (only my second monitor was working), and the only display drivers were from Microsoft. A few programs (like DeskScapes and Fences) weren't working properly, but that is to be expected. The real problem, however, is that my internet stated it had "Limited Connectivity". I have it plugged in via Ethernet to my gateway, and internet was working fine before the upgrade. I tried connecting to the wifi, and it also stated Limited Connectivity. Strangely enough, when I tethered my phone's data as a hotspot, and connected to it, it listed no devices connected (though the text that said "there are no devices connected" disappeared as well) where it usually states "Jordan-PC" or something of the sort, and my computer shot back that it also had Limited Connectivity. My first guess was to let Windows troubleshoot, but troubleshooter encountered errors and had to close. I checked that the service was running for it, and it was. Weird. I then proceeded to download the 8.1 64-bit drivers from my motherboard's website to another computer, and brought them over to this one. After uninstalling the drivers, I reinstalled them and rebooted, and continued to have the same problem. I also tried messing with winsock, flushing the dns, and a few other command-line tricks, to no avail. ipconfig /all returned just that there were no connections (or something like that, there were no connections and no adapters listed) and I could not figure out how to fix this problem.

    I decided to search my problem from another device, so I did. I went through several "tutorials" and fixes listed online, and none seemed to work, though most suggested to do things I'd already tried.

    After fighting with it for a couple hours, I decided to just revert back to Windows 7 and post the issue here (typing on the other device was a nuisance). Well, after reverting back, guess what? The limited connectivity issue followed me here! This time, Windows troubleshooter could run, but it simply returned that an "unknown error" was stopping all my adapters (my ethernet, wifi, and evolve's) and gave no more information other than to contact support. Well, luckily I had made a restore point right before upgrading to Windows 10 IP, so I booted up system restore and told it to check the differences between then and now. It told me there were no differences from what was installed then to what was installed now,  whether it be drivers or software. I went ahead and ran the restore anyways, and here I am, typing to you with a fixed internet issue.

    I'm not sure what could cause an issue like this, but I figured I'd report it here. Hopefully a fix is put together and I can try out the next build on here. I was also wondering if you guys had any thoughts as to what the problem is? It could just very well be the drivers released by MSI aren't working on Windows 10 yet, but then why would the problem follow me back to Windows 7, among other oddities?
    Tuesday, June 9, 2015 6:28 PM

Answers

  • Hi Lethal,

    Thanks for feedback your issue here after upgrading to Windows 10.

    For the issue was brought back to Windows 7, I considered that the driver information could be corrupted which cause your issue.

    The wireless issue after upgrading to Windows 10 can be caused the driver compatibility. Since Windows 10 version 10130 is not the final released version and is the newest system for Microsoft Windows users, the drivers for your device will sometimes not compatible with current system.

    I just suggest you try to revert the network adapter driver back to the older version which works fine on Windows 8.1 to see if it can work fine.

    We can also try to reinstall the latest driver in compatibility mode to check your issue.

    If the network still fails to work, I recommend to check the setupapi.dev.log under %windir%\inf, locate the device and find the line below:

    dvi:             Rank         - 0x00000000

    Then, corresponds the score in this link:

    Identifier Score

    http://msdn.microsoft.com/en-us/library/windows/hardware/ff546297(v=vs.85).aspx

    The score near 0x00003FFF means that the driver and device may not compatible with current system.

    Since Windows 10 tech preview is the newest released version and still in test, we may need to wait for the manufacturer’s driver update to compatible with Windows 10.

    Thanks for your understanding.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, June 10, 2015 7:59 AM
    Moderator