none
Outlook 2013 Paints Slowly Over RDP

Answers

  • Hello everyone,

    Seems that both of you encountered the slow performace problem for Office 2013 over RDP. But it would not happen in precious Office version.

    This problem doesn't happen when running other programs, like Visual Studio 2012. This means the problem should be only related to Office 2013 or RDS server.

    I also notice you've also get the same result even in Office with safe mode, e.g. Outlook safe mode.  Thus, add-ins, macros or form itself is not the root of issue. Since that you have not tested the behavior when you direct to use it, please let me know the result in your ealiest free time.

    Please detail what's the Windows Server version you are using for our further research. Different Windows Server version has the different RDS version it gets.

    And please make sure the server and client has fully patched so far. Feel free to post back.

    Tony Chen

    Tuesday, September 24, 2013 6:01 PM
    Moderator

All replies

  • Mike,

    Thank you for posting this question and I am hoping now with your 3rd thread that this question gets answered as I am having the exact same issues.  All of the MS Office Suite Applications that I am using over RDP (Remote Desktop) are running painfully slow and lagging.  The biggest issue for me is typing and deleting text.  Whenever I am composing an email or document, each key stroke takes seconds to render or even longer to delete off the screen.

    Why is this happening over RDP, I have changed all of my setting for best performance and removed all Addins.

    Please give some recommendation to resolve the slow paint in MS Office Applications when RDP to VM.


    Dylan Reynolds CRM Developer & Customizer/ Proj. Manager

    Monday, September 23, 2013 8:05 PM
  • Hello everyone,

    Seems that both of you encountered the slow performace problem for Office 2013 over RDP. But it would not happen in precious Office version.

    This problem doesn't happen when running other programs, like Visual Studio 2012. This means the problem should be only related to Office 2013 or RDS server.

    I also notice you've also get the same result even in Office with safe mode, e.g. Outlook safe mode.  Thus, add-ins, macros or form itself is not the root of issue. Since that you have not tested the behavior when you direct to use it, please let me know the result in your ealiest free time.

    Please detail what's the Windows Server version you are using for our further research. Different Windows Server version has the different RDS version it gets.

    And please make sure the server and client has fully patched so far. Feel free to post back.

    Tony Chen

    Tuesday, September 24, 2013 6:01 PM
    Moderator
  • Hi,

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Sunday, September 29, 2013 12:06 PM
    Moderator
  • Hi,

    I'm marking the reply as answer as there has been no update for a couple of days.

    If you come back to find it doesn't work for you, please reply to us and unmark the answer.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Wednesday, October 02, 2013 5:30 PM
    Moderator
  • I have the same issue RDP Win 7 (Windows 7 64 bit) at home to  Win 7 at work only certain computer models in specific Dell OptiPlex 780 Windows 7 64 bit-Radeon 3450 video card, Office 2013 only, this is what I found: If you drop your color depth in Remote Desktop connection to 15 bits all runs great! however at 32 bit High color, horrible lag and paint on screen (office 2013 only). I updated NIC as well as video card drivers, disabled animations, hardware graphics acceleration in Office under options on the remote computer in my cubicle, nothing worked until I dropped the color depth to 15 bits high color. My main computer at work is an OptiPlex 790 with a AMD Radeon HD 6450 video card and there is no problem in 32 bit high color mode from home when I remote in to it. Office 2010...never had a problem with it.
    • Edited by Carlos12ad Tuesday, November 12, 2013 9:39 PM
    Tuesday, November 12, 2013 9:37 PM
  • I've upgraded to Office 2013 (Excel) and downgraded once before.  Tried it again this week and it is unusable over RDC.  Going back to 2010.  Any hope that this might be fixed?

    Here's the particulars about my environment.  I am a growing number of remote workers that have used MS Office products for over 10 years - remotely.

    Tuesday, February 25, 2014 3:05 AM
  • This is still an issue, fully patched 2013 Outlook with Office 2013 SP1
    Wednesday, February 26, 2014 1:39 PM
  • Marking this post as an answer (when it obviously does not answer the question) does not help users.  This is still an open issue with no resolution.  I've been fighting Office 2013 over RDP for months now.

    FYI - I'm RDPing from Windows 7 Ultimate SP1 to Windows 7 Ultimate SP1. The destination machine is running as a VMWare client.  Everything is patched and up-to-date.  Hardware accel is disabled.

    Tuesday, April 01, 2014 9:07 PM
  • This is an older thread but is the most relevant I have found. We get this too with Remote Assistance. Even on the same LAN. It will be temporarily relieved if we start a new session. Would like to see a solution as it makes assisting users with Office 2013 nearly impossible. Machines are Windows 7 x64/ Office 2013 (Word and Excel)

    Wednesday, September 24, 2014 5:23 PM
  • There is a work around - BUT - why doesn't Microsoft do their job and answer people with problems??  Change the color setting to 24 or 16 versus the default of 32!
    • Proposed as answer by IWT Friday, January 23, 2015 2:19 PM
    Monday, September 29, 2014 10:41 PM
  • Thank you Boward57! 

    For the lay folks out there, when you connect via mstsc/rdp, you can click on the "show options" at the bottom before you connect - then click on the display tab - there you can adjust the color setting for remote desktops... I have noticed that this helps in other areas of performance too.  Another tip for slow RDP sessions regarding the mouse - you can set the mouse scheme in the control panel to "none"...

    Friday, January 23, 2015 2:32 PM
  • You provided NO solution. Please provide a solution as I am having the same issue and the user does not have any problem with Outlook on the workstation. Its outlook 2013 and mouse clicks, typing and redrawing of the windows take forever, when nothing else on the machine does this. 
    Tuesday, October 13, 2015 2:55 PM
  • This information was not helpful.  We need someone from the Outlook development team to actually look into what can be done to improve performance over RDP.  This is so painful that it makes using Outlook 2013 impossible over RDP.
    Monday, November 02, 2015 9:15 PM
  • Having changed the RDP color setting to 24 as it's been suggested has helped with the slowness. But using 32 is like pulling teeth.
    Thursday, November 19, 2015 4:06 AM
  • Same problem here. Windows Server 2008 R2 SP1, same slow painting for all Office apps regardless of desktop client. Changing the color depth to 24 or 16 seems to improve things, but I would prefer a solution instead of this work around.
    Monday, January 11, 2016 5:08 PM
  • The response above is not a solution.  There is one workaround that is listed multiple times below - reduce Remote Desktop (RDP) color resolution from 32-bit to something smaller like 24-bit or 16-bit.  This change immediately improved my ability to utilize Office 2013 (e.g. PowerPoint, Outlook) over Remote Desktop.  The default color resolution of Highest Quality (32-bit) causes the use of any Office 2013 application to be so slow as to be unusable.  What's worse is that at times, it even "swallowed" keystrokes and mouse clicks.  That means that it didn't just delay an input from me as the remote user, it actually somehow lost my keyclick or mouse click.  This was a problem using Remote Desktop from Windows 7 Pro and from Mac OSX 10.9.5.  In both cases, as soon as I began using Office 2013 on a Windows 7 Pro machine via Remote Desktop, I noticed horrible lag in both screen paints and response to key and mouse clicks.  In both cases, the solution was to reduce the Remote Desktop color resolution.  I consider this a temporary workaround.
    Tuesday, May 10, 2016 9:27 PM
  • Also experiencing this issue on a fully patched Windows 2008R2 RDS server. Office 2013 Pro Plus from VLSC with all Microsoft Office updates. Disabling hardware acceleration, animation, etc...does not really help at all. Still very slow. As a last resort I just enabled a GPO that limited the color resolution to 24-bit. Apparently the Office 2103 Click to Run install from Office 365 did not have the slowness issues. Also its worth mentioning that the user mailboxes are on Exchange Online. They are not using cached mode. I have not tested cached mode, but apparently all office apps are slow as well, not just outlook. The typing is slow and gets swallowed as well.

    Really hoping for a fix for this....

    Thursday, May 12, 2016 6:17 AM
  • Wow! it's been ages im trying to resolve this and you gave me the solution!

    Thanks so much.

    Friday, February 03, 2017 5:58 PM
  • This was driving one of our customers crazy and no matter what I did, the issue would persist. Dropping the color depth resolved the issue. Thank you for your post. 
    Friday, May 05, 2017 9:30 PM