locked
Windows 7 suddenly doesn't release modified memory after file transfer anymore. RRS feed

  • Question

  • Up until four hours ago everything worked just fine. I was transferring a large amount of data from one drive to another, as I do regularly. The transfer had been running for about an hour, when windows suddenly froze. I did a hard reboot and restarted the transfer, which started at a normal 120MB/s but rapidly dropped to around 30 MB/s, at which point the machine froze again. I tried a third time, which finally produced a chache_manager blue screen.

    I've since determined that all the data that is supposed to be transferred gets loaded into modified memory but never released again. I start out at 1.4 of 6 used, then I move a 3gb file, after which it sits at 4.4 of 6. It only releases after a reboot. Otherwise it fills to maximum and freezes. Resource manager tells me that when full 1.4 GB are used and 4.5 GB are sitting in modified memory.

    All drivers are up to date, so is all firmware.

    The only changes I've made recently are:

    Installed a new HDD yesterday - Started filling that immediately and didn't have any problems yesterday

    Installed a new external HDD today - Has been filling for two hours before the problem started, but that one is disconnected now, so I doubt it's the problem

    Updated to a new version of avast - this is the most recent change. I've since uninstalled avast, but it didn't seem to be causing the problem.

    Dear Windows supporters: I already know what the problem is, what I need to know is how to fix it. It's not drivers, it's not a missing windows update, yes I've tried rebooting, yes I've tried safe mode. Please don't copypaste your standard answer. Thank you


    • Edited by Rodario Monday, September 9, 2013 5:36 PM
    Monday, September 9, 2013 5:32 PM

All replies

  • Hi,

    I would like to suggest you try the following:

    1. You may update BIOS.

    2. I also would like to suggest you enable disk write caching.

    Turn Disk Write Caching On or Off

    a. Right-click My Computer, and then click Properties.
    b. Click the Hardware tab, and then click Device Manager.
    c. Expand Disk Drives.
    d. Right-click the drive on which you want to turn disk write caching on or off, and then click Properties.
    e. Click the Policies tab.
    f. Click to select or clear the Enable write caching on the disk check box as appropriate.
    g. Click OK.

    3. You may also increase virtual memory.

    Change the size of virtual memory

    http://windows.microsoft.com/en-us/windows7/change-the-size-of-virtual-memory

    4. I would like to confirm how it works in safe mode. If it works, I would like to suggest you temporarily disable all unnecessary hardware devices in Device Manager, such as Modem, sound card or external device.

    Device Clean Boot
    ==============
    Please unplug all unnecessary devices to test your computer's performance. In this situation, your system will only have the basic hardware devices and it should be more stable.
     
    If it is inconvenient to unplug the devices, we can disable them in Device Manager. Please refer to the following steps:

    a. Click "Start", type "DEVMGMT.MSC" in the Search textbox and press Enter. Please click “Allow” if the User Account Control window is prompted.
    b. Expand "Sound, video and game controllers".
    c. Right click on your Sound Card, select "Properties"
    d. Click "Driver" tab, click Disable (Disable the selected device). Click OK.
    e. Please use the same method to disable other hardware such as: Modem, network card, CD-R drive. Please note some devices such as video adapter are not available to be disabled.

    If the issue persists, please give us the following information for our further research:

    a. minidump (C:\Windows\Minidump folder )
    b. Msinfo32 (Local Disk (C :) \Program Files\Common Files\Microsoft Shared\MSInfo).

    Please use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the MSInfo and the minidump to a public folder and share the URLs with us.I will be glad to assist you to analysis the data.

    Regards,

    Blair Deng


    Blair Deng

    TechNet Community Support


    • Edited by blair deng Wednesday, September 11, 2013 2:36 AM
    Wednesday, September 11, 2013 2:35 AM
  • I was having this same issue, I disabled write caching on all of my drives and my 'Modified' memory usage in my resource manager dropped from 4GB to ~540MB.

    Wednesday, September 18, 2013 11:00 PM