none
Failed On Start error

    Question

  • Hi,
    I have a persistent problem in all my workflows. Whenever i try to start any of my workflows like the simple  Approval workflow, I get the Failed On Start message and the followig entry in the log file.
    I am using FBA with a custom membership provider. The app pool account is local admin so no rights issue. I am going to try this on a different machine.

    RunWorkflow: System.ArgumentException: Value does not fall within the expected range.     at Microsoft.SharePoint.Workflow.SPWorkflowActivationProperties..ctor(SPWorkflow workflow, Int32 runAsUserId, String associationData, String initiationData)     at Microsoft.SharePoint.Workflow.SPWinOEWSSService.MakeActivation(SPWorkflow workflow, SPWorkflowEvent e)     at Microsoft.SharePoint.Workflow.SPWinOeEngine.RunWorkflow(Guid trackingId, SPWorkflowHostService host, SPWorkflow workflow, Collection`1 events, TimeSpan timeOut)     at Microsoft.SharePoint.Workflow.SPWorkflowManager.RunWorkflowElev(SPWorkflow originalWorkflow, SPWorkflow workflow, Collection`1 events, SPRunWorkflowOptions runOptions)


    any help is appreciated

    Thanks and Regard
    ibm
    Sunday, December 16, 2007 3:23 PM

Answers

  • Hi,
       SOLVED: Just added my app pool identity as "Full Control" from the "Policy For Web Application" section. before that i did everything like adding the user to wss_admin_wpg etc but no avail.
       One thing is for sure that the error descriptions/exceptions in sharepoint are nightmare. For example if i changed my identity to some user with lower privilege it gives "trial expired" error. Hilarious..

    regards
    Irfan Bashir
    Tuesday, December 18, 2007 8:39 PM

All replies

  • Hi,
       SOLVED: Just added my app pool identity as "Full Control" from the "Policy For Web Application" section. before that i did everything like adding the user to wss_admin_wpg etc but no avail.
       One thing is for sure that the error descriptions/exceptions in sharepoint are nightmare. For example if i changed my identity to some user with lower privilege it gives "trial expired" error. Hilarious..

    regards
    Irfan Bashir
    Tuesday, December 18, 2007 8:39 PM
  • Perfectly worked. Thanks a million.

    Wednesday, December 19, 2007 11:07 AM
  •  irfan bashir wrote:
    Hi,
       SOLVED: Just added my app pool identity as "Full Control" from the "Policy For Web Application" section. before that i did everything like adding the user to wss_admin_wpg etc but no avail.
       One thing is for sure that the error descriptions/exceptions in sharepoint are nightmare. For example if i changed my identity to some user with lower privilege it gives "trial expired" error. Hilarious..

    regards
    Irfan Bashir


    Additionally, if you still can not start the workflow, you can try below command, it is to change your app pool identity as the farm admin, thus is SYSTEM account.

    C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN>stsadm -o updatefarmcredentials -userlogin ds\sseadmin -password password

    Then it MUST work!
    Tuesday, May 20, 2008 10:44 AM
  • Hi,
    I have the same issue with wss 3 and I have two applications pools: DefaultAppPool (identify - network service user)  and SharePoint-80 (identify - Local system user). How can I determine which one is the default and what to do next. It's a production environment so I'm a bit stressed out.
    Tnx a lot in advance
    Sunday, July 27, 2008 12:28 PM