locked
Hyper-V on host: virtual switches leads to very slow or no internet on host at all RRS feed

  • Question

  • Dear friends,

    Recently I stumbled upon an issue concerning Hyper-V on my laptop. So I'm running the Hyper-V on my own laptop, running virtual machines on my laptop. I created 2 virtual switches, an external virtual switch connected to ethernet and a internal virtual switch. The issue is that whenever I start any virtual machine (independent if the VM is using an internal or external virtual switch), I'm slowly starting to get issues with the internet on my host. The issues are either very very slow internet connection or just no internet at all, referring to some DNS issues. But sometimes after a few minutes it can come back from no internet (DNS error) to very slow internet connection.

    I tried to remove all my virtual switches. Then I made just 1 virtual switch: an internal virtual switch. I assigned this virtual switch to one of my virtual machines, but still the issue remained from the moment I started the VM using this virtual switch. So it's not just for external switches that this issue exists, but also for internal switches.

    EDIT: I noticed a new "pattern" concerning my internet connectivity issues. So whenever I make a VM and assign it to a virtual switch (internal virtual switch for example), there is no issue by default (because the adapter IPv4 settings are set to automatic = DHCP). But whenever I start to assign static IPv4 addresses to for example my internal virtual switch (which is recommended obviously for servers), this is the moment when my internet starts freaking out... 

    Does this problem sound familiar to anyone out here?

    Thanks in advance,

    Nicolai


    Thursday, December 15, 2016 10:03 AM

All replies

  • Hi,

    I have seen similar issues in a couple of scenarios

    1. Do you have Windows NIC teaming in use on your host?
    2. Do you have VMQ enabled on your VM Network adaptors? if so does disabling it resolve the issue?

    What brand are your network adaptors?

    Thursday, December 22, 2016 4:23 PM
  • I guess this entire topic supposed to be moved into section Windows 10 as I bet you are talking about client Hyper-V. I have exactly this issue in Windows 10 Client Hyper-V - DNS resolution is very slow or something like this - on my host in all browsers there is a pesky delay of about 10-20 seconds to get the site opened/name resolved.

    Just a quick Google search shows that this problem is generic one but there is no easy solution. I tried to reorder protocols/bindings priority with no luck along with other solutions I found - so I give up and tried to live with this for a while :). Today I just called MSFT support and was instructed to perform Network Reset (Windows Settings (Win + I) > Network and Internet > Network reset) - it forced system reboot in 5 minutes. And lo and behold after reboot I got long forgotten web pages opening speed in all browsers, but the thing is that this operation just kills Hyper-V network switches. I recreated internal switch - all good, then external - and it is slow again :( So it is definitely has something to do with Client Hyper-V external switch but I'm still not sure how to fix it.

    Monday, March 6, 2017 10:01 AM
  • After encountering the issue (Win ver 10.0.15063), which manifested as extremely slow response time for the host machine, despite good ping & tracert performance, I did some digging into network-adapter settings for the vEthernet external switch.

    In the "Internet Protocol Version 4 (TCP/IPv4)" binding, the Hyper-V Mgr had transferred the settings the parent physical NIC, *except* from DNS settings, even tho Hyper-V had removed those settings from the parent NIC.  In short, no DNS settings were visible for the vEthernet switch.

    So, I manually added appropriate DNS settings to the virtual switch, adding a primary and secondary, and problem solved.

    Notes: 

      The parent NIC was originally manually set prior creating the virtual switch with Hyper-V.  The issue might not occur, if DHCP look-up had been selected, and likewise, it may be that the vEthernet could be set to get DNS entries via DHCP.

      I have not yet created VMs within Hyper-V on this PC, so no feedback on the VM performance at this juncture, including whether the same internet look-up delays would have occurred without having manually set the DNS entries--tho I much suspect the VMs would have the same issue, unless the DNS entries area put in.

      No feedback on TCP/IPv6 settings--My internal LAN runs on IPv4.

    Tuesday, August 29, 2017 1:43 PM
  • This appears to have worked for me!

    1. Went into the IPv4 Properties of the Hyper-V (Default Switch) Network Adapter;

    2. Set the IP address of the DNS server to the one on my network (even though it was on a different subnet to the IP of the adapter);

    3. Everything seemed to immediately speed up with the most noticeable being web page browsing (DNS resolution);

    When the Hyper-V (Default Switch) is installed Windows 10 appear to make it the primary adapter for communication so all traffix goes thorugh this first (I noticed this when I went into nslookup and it quoted the 172. address associated with this adapter).

    Sunday, January 28, 2018 4:10 PM
  • Hey. My solution for this was to check the IPv4 checkbox in the properties window of my networkbridge (Microsoft Network Adapter Multiplex Driver). It was unchecked. Quick and easy :)
    • Proposed as answer by lexschulz Friday, February 22, 2019 7:35 PM
    • Unproposed as answer by lexschulz Thursday, May 23, 2019 7:32 AM
    Friday, February 22, 2019 7:34 PM
  • Hey. My solution for this was to check the IPv4 checkbox in the properties window of my networkbridge (Microsoft Network Adapter Multiplex Driver). It was unchecked. Quick and easy :)

    Thank you!

    I was searching for a solution for many weeks. This one helped.


    Saturday, March 2, 2019 8:12 PM
  • I think I know what's causing my slow down but no idea how to resolve it.

    My host is on my home wifi of 192.168.135.#

    My 3 virtual machines are on 192.168.21.#.  1 is a Domain Controller, and the other 2 are servers.  They are copied from a client site so I just left them like this.  They communicate with each other properly.

    I changed my Virtual Network Adapter from Private to Internal so that I can RDP into them and use Alt-Tab to cycle through them and my host.  That's when things slow down.

    I believe what's happening is my host is going to the virtual DC for it's DNS now and after a few seconds, it goes to my wifi DNS and away it goes.

    Any ideas how to resolve?  I know I could change virtuals to be on the 192.168.135.# network but I'm afraid I'll brake something on the virtuals that are currently working perfectly.

    FYI... the virtuals have no need to access external internet.  I just switched it to Internal so I could RDP to the virtuals instead of using vmconnect which doesn't allow me to use Alt-Tab to switch between them, but switches between applications in the individual virtual itself.

    Wednesday, May 15, 2019 1:24 AM
  • Update:  I believe I have resolved this issue.  What I did was change the DNS on the domain controller virtual to my wifi's DNS setting and it seems things have sped up quite a bit.  I'd say 80%, if not 100% of the speeds prior.
    Wednesday, May 15, 2019 4:45 PM
  • Hello, 

    i was having a similar issue , my browser was slow after configuring hyper-v switch on my windows 10 machine.

    here is a simple work around that worked well for me.

    go to Network Bridge Status and then open Network Bridge Properties and put a check mark / enable IPV4 protocol.

    

     

    Wednesday, February 12, 2020 8:01 AM