locked
Homegroup Icon RRS feed

  • Question

  • I have been using Win7 RC since its release and have not have a homegroup icon on my desktop until now.  I was using Firefox when my fans spun up rapidly and the screen proceeded to go black.  Ctrl+alt+del was ineffective and I had to restart via the restart button.  Afterwards I had the new icon on my desktop.  Any ideas?
    Thursday, September 24, 2009 4:31 AM

Answers

  • Hi,

    Please take the following steps to leave the homegroup.

    1.Open HomeGroup by clicking the Start button , clicking Control Panel, typing homegroup in the search box, and then clicking HomeGroup.
    2.Click Leave the homegroup.
    3.Click Leave the homegroup, and then click Finish.

    If the icon still appear on the desktop, you can open a Registry Editor and delete related registry.

    Note: pay attention to back up your registries before any modification, any incorrect modification can cause unrecoverable damage.

    1. Press Win + R to open a run box.
    2. Type: regedit and hint Enter.
    3. Navigate to:

    Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\Explorer\Desktop\NameSpace\

    4. Find a folder (key) with the name {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} , this is the registry entry Homegroup icon. Delete the folder from the registry.
    5. Press F5 to refresh the desktop and see if the icon disappears.

    Best Regards.
    Dale

     

    • Marked as answer by Dale Qiao Tuesday, September 29, 2009 1:29 AM
    Friday, September 25, 2009 9:05 AM

All replies

  • Hi,

    Please take the following steps to leave the homegroup.

    1.Open HomeGroup by clicking the Start button , clicking Control Panel, typing homegroup in the search box, and then clicking HomeGroup.
    2.Click Leave the homegroup.
    3.Click Leave the homegroup, and then click Finish.

    If the icon still appear on the desktop, you can open a Registry Editor and delete related registry.

    Note: pay attention to back up your registries before any modification, any incorrect modification can cause unrecoverable damage.

    1. Press Win + R to open a run box.
    2. Type: regedit and hint Enter.
    3. Navigate to:

    Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\Explorer\Desktop\NameSpace\

    4. Find a folder (key) with the name {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} , this is the registry entry Homegroup icon. Delete the folder from the registry.
    5. Press F5 to refresh the desktop and see if the icon disappears.

    Best Regards.
    Dale

     

    • Marked as answer by Dale Qiao Tuesday, September 29, 2009 1:29 AM
    Friday, September 25, 2009 9:05 AM
  • I am running Windows 7 Ultimate and I am the administrator of my laptop.  

    Tried both of your suggestions and neither worked.

    There is no 'Leave the homegroup' link in the HomeGroup window of my Control Panel.  

    When I tried the regedit/delete option I got the message 'Cannot delete {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}: Error while deleting key'.


    Wednesday, February 29, 2012 11:06 PM
  • I found another tip elsewhere which advised to go to Control Panel/System & Security/Admin Tools/Services and disable the HomeGroup Listener & Provider services.  Did this and was then allowed to delete the registry entry and the icon is now gone.

    Comments:

    1. I wish that MS would refrain from making services virtually mandatory.  It is not helpful and I for one strongly resent the amount of time I've wasted when a standard delete option on the icon would have been a simple and quick solution.

    2. I had the HomeGroup services set as 'manual' but the Provider service started automatically anyway.  Another example of MS's highhanded attitude and overruling of users' settings.

    3. Lots of other thoughts on the matter, but am so angry about this that I'd better shut up.

    • Proposed as answer by AlphaPWNED Friday, May 23, 2014 1:23 AM
    Wednesday, February 29, 2012 11:43 PM
  • Thank you very much for this fix! It annoyed the hell out of me to have this desktop icon that Microsoft feels the need to make permanent. I should have the option to remove it if I want! Thanks again! My OSD is once again under control :)
    Sunday, January 26, 2014 3:39 AM
  • IT STILL WONT GO AWAY!!!!!!!!!!!!!!!!!!!
    Saturday, February 15, 2014 5:01 PM
  • I tried Kelizan's method and it worked. It finally went away.  Now, why did the Libraries icon appeared? This is annoying. Do I have to spend a few hours trying to get rid of that one also?

    Good day.

    J. Cool


    • Edited by J. Cool Saturday, March 15, 2014 4:16 PM
    Saturday, March 15, 2014 4:15 PM
  • This helped me remove it, my problem was that HomeGroup Provider was on and i just hit stop and now it's gone.
    Friday, May 23, 2014 1:24 AM
  • Thank you! Free from that icon at last! Thank you!

    Best Regards,

    Dale

    Friday, August 8, 2014 12:09 AM
  • hey man, thanks for the advice, but the only thing that I could do was open up my control panel, then go the the search bar and type in: Homegroup, and then go to the view tab and click the check-box that said hidden icons.... Is there anything else that I need to do? Like, is there something that I will experience, having not deleted it, that I wouldn't have experienced had I chosen to delete it? Can "Homegroup" actually harm my computer in any way?

    Tuesday, September 9, 2014 3:13 AM
  • Al fin conseguí quitar el icono que alguien ha inventado el modo de que por narices tenga que estar en mi escritorio. Gracias, la solución es correcta.
    Thursday, January 8, 2015 12:59 PM
  • All i did was go to home group and go to settings for it and pressed leave and the icon was gone i have a windows 8 laptop hope this helps some people
    Tuesday, July 28, 2015 4:46 PM