locked
Can't set internal SMTP servers, breaking anti-spam RRS feed

  • Question

  • Hi, in our on-premise Exchange there is a PowerShell setting, Set-TransportConfig -InternalSMTPServers , which is used to inform Forefront Protection for Exchange ("FPE") of any non-Exchange SMTP servers that might be handling messages before they arrive at Exchange. This setting is necessary to ensure that the anti-spam functionality of FPE can properly look back through the message header and determine which internet host actually delivered the message, and determine if that host is on a blacklist, or whatnot.

    In Exchange Online Protection, though, it seems that there is no argument under Set-TransportConfig to establish such settings. I *can* see the setting under Get-TransportConfig, but I can't set it.

    This is a problem for us because we route mail internally first via on-premise, non-Exchange mail gateways before the messages are routed to Exchange Online. Exchange online always believes that our internal mail gateways are the originating server, when in fact, it's one hop back. The result is that Exchange Online's anti-spam functionality is not working correctly.

    How can I address this issue? I can't really re-route my MX record directly to the cloud yet.

    Tuesday, July 29, 2014 6:04 PM