none
Public folders - Can't add folders to Secondary Hierarchy folders through Outlook RRS feed

  • Question

  • I have an issue going out where I cannot add or create subfolders in public folders through Outlook.  The folders that are affected are the ones that are in the secondary hierarchy.  If I try to create a subfolder that is listed within the primary hierarchy mailbox, I can create it with no problems at all.  It's only the folders that are apart of the Secondary Hierarchy. 

    Now, I can certainly add new subfolders to the folders in the secondary hierarchy with no problems through EAC and through EMS. 

    I've check my folder permissions and I have full ownership of the top level folder. 

    I can add content into the folders themselves as well as other users can.  But, we cannot create new folders.  Outlook gives me a message:  "Cannot create the folder."

    Has anyone come across this before?  Any ideas?  I'd also like to know if I can turn up the event logging level on an event category for just public folders.  Not sure if I can, but does anyone know if you can?


    JB

    Tuesday, March 8, 2016 10:35 PM

All replies

  • Are you talking about alternate "non-MAPI" public folder trees?  That's a feature that never worked right and has been abandoned.  The secondary trees never had Outlook support, only OWA.  Let's say that it's "by design".  I'd recommend you remove the non-MAPI trees.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Wednesday, March 9, 2016 12:58 AM
    Moderator
  • I'm not sure as I haven't heard of the term "non-mapi" trees. What is that? In case we are speaking of two different things, you know when you create your first public folder mailbox, it becomes your primary. If you create a second public folder mailbox, it's listed as secondary. You can see that in the EAC under the public folders/ public folder mailboxes table. The problem lies with the data in the secondary hierarchy mailboxes.

    JB

    Wednesday, March 9, 2016 3:07 AM
  • Your terminology isn't accurate, which is why I was confused.  There is one hierarchy, period.  If you have multiple public folder mailboxes, each serves the complete hierarchy because it is replicated between them.

    Please describe the complete sequence of steps you are following and exactly what happens.  Please don't take shortcuts in the description.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, March 9, 2016 5:40 AM
    Moderator
  • Well, I'm only trying to explain it based off of how I see Microsoft defining it.  Of course, my explanation may not be in accordance by Microsoft's definition of the terms.

    Okay, so to start with the end user POV from Outlook.  The end user has full ownership to all public folders.

    1. I open up Outlook, expand my public folders --> All public folders --> Folder B
    2. I right click Folder B and choose New Folder.
    3. I name my folder, Folder B-1.  I click OK.
    4. Outlook pops up the message:  "Cannot create the folder".

    Now, when I do the same steps for Folder A, I'm able to create my subfolder (A-1) just fine.

    The noticeable difference is where content of these public A and B folders is stored. Folder A's content is residing in Public Folder Mailbox 1... which in the EAC lists this mailbox as the Primary Hierarchy.  Or rather the column is labeled "Contains".  So I guess I should say that PFM1 contains the primary hierarchy.

    Folder B's contents is in PFM2, which is listed as, or contains "Secondary Hierarchy". 

    So to sum it up, I can create sub-folders when the content is in PFM1.  I cannot if I have content in PFM2, 3, 4, etc.  Any mailbox that is listed as, or contains Secondary Hierarchy.  Did this help?

    Public Folder Mailbox Hierarchy.


    JB

    Wednesday, March 9, 2016 2:38 PM
  • What the "CONTAINS" column means is that the fourth one is the writable copy of the hierarchy but the others can be read by clients for load balancing of requests.  The hierarchy is a list of all folders everywhere.  All copies of the hierarchy are the same.  The location of the hierarchy is completely independent of the content of the individual folders.  A public folder exists in just one public folder mailbox.

    The folder content is wherever you put it.

    Upon creation, subfolders are created in the same mailbox as the parent folder.

    You can move public folders to different mailbox databases later.

    https://technet.microsoft.com/en-us/library/jj906435(v=exchg.150).aspx

    Back to your original question, when the user tries to create the new folder, check the parent folder to see what public folder it resides in, and then look to see if maybe that mailbox is over quota.  If so, maybe you'll want to increase the public folder mailbox quota or use the link above to split the content across new public folder mailboxes.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, March 9, 2016 6:00 PM
    Moderator
  • But the issue is presides in that scenario. When the content is in the other public folder mailboxes, it's that content that I cannot add or create new folders.  Right now, I have PFM1, PFM2, PFM3... PFM1 (being my primary or writable mailbox) works just fine. When content is or has been moved to PFM2 or PFM3 (which according to my screenshot is listed as secondary, or read-only), I cannot create folders.  Now I know that quota is NOT an issue because I can add emails/files/etc. into the folders themselves.  Calendar appointments get added to the calendars that are listed in PFM2 and 3.  It's the creation of a new one that we cannot do.

    I only point out the secondary and primary hierarchy description is because that's what's being affected.  It's only affecting the content inside the Public Folder Mailboxes that are listed as containing secondary hierarchy.  The only one that works is when the content is in the PF Mailbox that is listed as the primary.

    Now according to my original post, the only way to add new subfolders under the problem parent folders (which are still residing in PFM2, PFM3, 4... etc.) is through EAC or EMS.  That works just fine.  It's only through Outlook that this occurs.


    JB


    • Edited by JBerg712 Wednesday, March 9, 2016 6:27 PM Update
    Wednesday, March 9, 2016 6:22 PM
  • Does this help?

    https://support.microsoft.com/en-us/kb/3035230


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, March 9, 2016 6:27 PM
    Moderator
  • Currently I know that on our Exchange servers the LAN Manager authentication level is set to not defined.  I'm not sure if having the lmcompatibilitylevel key removed means it's defaulting to a certain value or not, but I know most of our servers don't have this defined.  Do you know if that will make an impact on Exchange operation by enabling and setting the authentication level for LM?  Does this setting require a reboot of the server?

    Edit:  Nevermind that last question.  I see the article says to restart 3 services.   Will try that later tonight.


    JB


    • Edited by JBerg712 Wednesday, March 9, 2016 7:07 PM
    Wednesday, March 9, 2016 7:05 PM
  • UPDATE...

    This morning I made the necessary changes to the security policy and we are still experiencing the issue.  Still no go. 

    For now, at least for my more heavily used folders, I may have to move them into the my PF Mailbox that contains the primary hierarchy.  I know this to be a workaround to the issue.


    JB

    Monday, March 14, 2016 12:56 PM
  • Hi,

    I have exactly the same issue in my environment. The Microsoft KB does not change anything.

    I cant' create folder on my PF maiboxes (secondary hierarchy) but only one my "root" PF.


    • Edited by JordanOH Tuesday, May 17, 2016 8:57 PM
    Tuesday, May 17, 2016 8:57 PM
  • So far Jordan, my work around has been to move the content to the mailbox that is labeled as containing the Primary Hierarchy and it works. 

    I don't consider this a solution at all, just a work around. 

    By the way MS is doing public folders now, the amount of content that other users are needing to delegate access too would benefit from being in a separate mailbox because of how much content is in it.  So I would prefer it to be in it's own separate public folder mailbox, but if my end users cannot delegate it from Outlook, then there's no point.  So far that's been my workaround.

    To NOTE, and in all honesty, I found this out as well... if 1 public folder mailbox would suffice for all our public folder content, I would probably do it that way for the reason that when I make permission changes to a public folder, if my end user's default public folder is set to another mailbox, I have to run a powershell command so that those permissions do take effect or else it won't take effect immediately for the end user.

    [PS] C:\Windows\system32>Get-Mailbox -PublicFolder | Get-MailboxStatistics | where {$_.MailboxType -ne 'PublicFolderPrimary'} | Update-PublicFolderMailbox -InvokeSynchronizer

    Once the other PF mailboxes have been synchronized, then users are actually able to access. 

    Based off of the behavior, there's more to these additional mailboxes than just containing a 'secondary hierarchy'.  They almost act like public folder databases that are replicated between each other.  Of course I've never had to invoke an update to my replicated database in order to get a user access to a PF before.


    JB

    Wednesday, May 18, 2016 3:59 PM
  • Hi,

    In my situation we are using PF in multi-organizations system. So, use a new seperate PF maiblox for each new organization would be good.

    About "Update-PublicFolderMailbox -InvokeSynchronizer" cmdlet, does this one allow to "bypass" the permission problem for secondary hierarchy ?




    • Edited by JordanOH Wednesday, May 18, 2016 4:09 PM
    Wednesday, May 18, 2016 4:09 PM
  • I don't believe it's bypassing anything.  Now I may be wrong, but the behavior I'm seeing with my public folders is that say I grant User Jim access to PF called 'Billing'.  If I run a Get-Mailbox "Jim" | fl Def* I can see the DefaultPublicFolderMailbox.  If Jim's DefaultPublicFolderMailbox is a mailbox that listed as: "contains secondary hierarchy", then if he tries to access the "Billing" folder, he's still denied access.  And this is after I've set his permissions on that folder.  I've given him Editor access.  Well he's still denied which I'm guessing his permissions to that folder haven't been seen or read or applied to his 'DefaultPublicFolderMailbox'.  Once I run the Update-PublicFolderMailbox, that finally allows him to see and access the 'Billing' Public Folder. 

    Now in another case if I were to set Jim's DefaultPublicFolderMailbox to the one mailbox that is the "contains primary hierarchy" then I don't have to run that command.  It's granted to him instantaneously. 

    As far as the problem from what I'm posting about, no this command doesn't do any good for that.  My users that have full ownership of a folder that it's content is within a PF Mailbox that contains secondary hierarchy, they cannot grant access to that folder.  If he has ownership to folders that reside in my primary hierarchy mailbox, then he grant those just fine.


    JB

    Wednesday, May 18, 2016 6:02 PM
  • Hi!

    Did you manage finally with your problem? Already several years I looking for solution, but still didn't get any results. I really hoped that migration to Exchange 2019 should be helpful. Moreover I've made full decommission PF structure and created it from stretch. But the problem still exists. I cannot create, rename and move folders located in secondary hierarchy mailbox. But I found one strange thing: when primary hierarchy located on new Exch2019 but secondary mailbox on my old Exch2013, that still exists in my environment - all works fine! I have no ideas why it happens. Probably problem somewhere out of Exchange. 

    Monday, June 24, 2019 8:13 PM
  • Same problem started here some week ago (November 2019): Exchange 2013, people and admins can no longer create folders from Outlook 2013/2016/2019 to public folders located on "Secondary Hierarchy".

    Users with Outlook for MacOS are able to create folders without problems. The same users, when using outlook from windows, cannot create new folders.

    Edit: solved with this:

    https://support.microsoft.com/en-sg/help/3035230/owner-cannot-create-modern-public-folders-by-using-outlook-in-exchange

    (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa raised from 1 to 2)

    • Edited by PGiovanni Tuesday, December 10, 2019 12:19 PM
    Tuesday, December 10, 2019 11:36 AM