locked
how to configure sip trunk (no gateway to choose from) RRS feed

  • Question

  • Hi guys,

    I have a trial set up with a sip trunk provider and I'm trying to get the Lync side configured for test calls by following their OCS 2007 R2 documentation.

    I am in the Lync Control Panel and have a dial plan and voice policy set, now I'm trying to configure a Route.  I get to the part about "Associated Gateways" but when I click Add there is nothing to choose from in the list.  How do I populate this list so I can get this going?

    Thanks!

    Wes

    Saturday, October 9, 2010 6:02 PM

All replies

  • In your topology builder you will want to specify a gateway, and associate it with a mediation server.

     

    The gateway will be whatever information the sip trunking provider specifies for you to connect to.

     

    Once you specify that in your topology builder, you can then select it for routes and trunk configurations.

     


    Randy Wintle |MVP:Communications Server, MCTS: UC Voice Specialization | Winxnet Inc
    Saturday, October 9, 2010 6:21 PM
  • Thanks Randy, I figured it would be in top. builder, but the problem is I can't figure out where to do this.  Is it under mediation pools?  PSTN Gateways? On the standard edition front end server itself?

    My only mediation server is collocated on the FE server, will that work?

    Saturday, October 9, 2010 6:31 PM
  • OK I think I got it sorted (put it under PSTN Gateways)...  When trying to make a call though I get "Your organization does not support calling this number"
    Saturday, October 9, 2010 6:44 PM
  • Got that sorted I guess... now getting "The call could not be completed due to a busy network"
    Saturday, October 9, 2010 7:00 PM
  • Now any number I try to call, lync says "+1 (555) 555-5555 cannot answer this call"
    Saturday, October 9, 2010 7:59 PM
  • The sip trunk provider says nothing is coming through on their end...  I'm not seeing anything when I analyze the sipstack and s4 logs... are there other things I should be logging for this?
    Saturday, October 9, 2010 8:43 PM
  • seeing this in the lync log:

     

    A PBX gateway has been marked as less-preferred.

    Gateway name: 68.68.124.47

    Response Code: 488

    Consecutive Failure occurrences: 33

    Cause: The gateway responded with the same failure response multiple consecutive times and is being marked as less-preferred.

    Resolution:

    Verify that the gateway is functioning correctly.

    Saturday, October 9, 2010 9:11 PM
  • Is the provider certified with OCS 2007 R2?

    If not, you may run in to some issues, but should be able to get it working in general.

     

    Make sure your provider is accepting TCP connections on whatever port you specified for the PSTN gateway in the topology builder, I believe it is default TCP 5068

     

    Also, make sure you have a route that matches the number you are dialing, you control these routes through the control panel under voice routing.


    Randy Wintle |MVP:Communications Server, MCTS: UC Voice Specialization | Winxnet Inc
    Sunday, October 10, 2010 1:49 AM
  • Sip Trunk provider had the wrong ip configured... calls work now, w00t!

    Anyone know a good resource for setting up normalization rules for the US?  Is it possible to configure 7-digit dialiing based on the user's area code, instead of having to do 1+10digit?

    Sunday, October 10, 2010 3:38 AM
  • Check this out, these guys put up a great tool

     

    https://ocs.buchanan.com/OCSOptimizer/

     

     


    Randy Wintle |MVP:Communications Server, MCTS: UC Voice Specialization | Winxnet Inc
    Sunday, October 10, 2010 1:21 PM