locked
Promise FastTrak 100 Vista RC1 Driver RRS feed

  • Question

  • Has anyone found a successful Promise driver for Windows Vista? The XP drivers worked for beta 2, but with RC1 Vista says that those drivers are incompatible.

     

    Thanks!

    Saturday, September 9, 2006 11:46 PM

All replies

  • I am having the same trouble with Intel SATA 82801FR AHCI -- worked fine in B2, now in RC1 dead.
    Saturday, September 16, 2006 7:07 PM
  • Hi, the same here. I first install B2 than i did an upgrade to RC1 5600. Promise FastTrak 100 TX2 was working fine. But then i reinstall the machine from scratch, now it can install the driver. So here is what i will do as soon as i have the time:

    Reinstall the machine again with B2 than make the upgrade to RC1 5728. I hope this wil help.

    Regards

    Dark Fury

    Tuesday, September 26, 2006 7:54 PM
  • Does someone has managed to install a driver for this device ?

     

    i'm running the RC2 x64 and i 've the same probleme with a Promise Ultra 133 TX (really similar to the FastTrak 100)

    Tuesday, October 10, 2006 10:23 PM
  • Hi,

    i found the following tip in the blog of Daniel Melanchthon.

    He used the Windows 2003 driver of the Promise Ultra133 TX3, you get it here:

    http://www.promise.com/support/download/download2_eng.asp?productID=87&category=all&os=100

    I tried that and it worked with RC1 and RC2, so give it a try.

    Regards

    Dark Fury

    Wednesday, October 11, 2006 9:29 AM
  • I ve try this one , but Windows doen't want to install it , i see in different post that at the installation windows was ok to take the driver from disquette and it's worked , may be there is a way to force windows to install a driver , i ve try by the list method , same thing Windows doesn't recognise driver in the location (XP/2003) if you have another please tell me.

     

    If there is not , i ll try to reinstall and give the driver to windows a this moment but it's suck...

    I've forget to mention i've a Vista x64, it could be the reason , what are you using ?

    Friday, October 13, 2006 1:02 PM
  • Ok Vista x64 that will be the answer, i use Vista x86.

    Vista x64 needs signed drivers. What you can try is the following: Press F8 during boot to get to the bootmenu. Here you should find samething like driver signing disable or samething like that. But you have to do this every time. If that works all you can do i hoping that the release version supports the controller or promise get a signed x64 driver of the launchpad

    Let me know if that helped you.

    Dark Fury

    Friday, October 13, 2006 5:47 PM
  • I just try , bad luck it dosen't worked.

    I think i'll take the x86 version and it ll solve everything ;)

    Thanks for the help
    Friday, October 13, 2006 7:30 PM
  • If you use Promise's eSupport asking about beta drivers for Vista, they'll reply that there are none....However....

    If you call their tech support line, they'll email you the beta drivers.  I did this yesterday and I now have them.

    The number is 408-228-1400 Opt#:4

    The driver version I have is for the TX2300 and is version 2.06.0.324
    Wednesday, January 31, 2007 4:35 PM
  • As i live in australia and very hard to call promise directly at correct times. it possible if u can send me the beta drivers through email?

    if so can you please email them to pictorien[no-spam]@gmail.com remember to take out the [no-spam]


    Thanks in advanced.


    its been driving me nuts the last couple of weeks.
    Thursday, February 8, 2007 11:54 AM