locked
Hide doesn't work in Standard for Proclarity 6.3 RRS feed

  • Question

  • When I hide a single row member, in Proclarity Standard 6.3, it removes ALL row members for the dimension.

     

    I have installed the latest patch, but it didn't help.

     

    Does anyone else have this problem?

    Monday, January 7, 2008 5:55 PM

Answers

All replies

  • Hi Sylvia,

     

    I cannot reproduce this using 6.3.2214 and Adventure Works.  If you can produce this scenario using Adventure Works please let me know the steps taken in order to do so and I'll be happy to look into it.  On the other hand, if this happens to be a problem specific to your cube we'll do our best to see what we can figure out.  If we cannot resolve this over the forum it may be wise to open a support case if this is prohibiting your users from using certain functionalities of Web Standard.  I look forward to your reply.

     

    Thanks,

    Amanda

     

    Tuesday, January 8, 2008 3:05 PM
  • If you have more than one dimension on the rows and you choose to hide a member, it does not just hide the row you clicked on but it removes the member from the query, effectively removing every occurrence of that member from the rows.  I'm guessing that is what you are seeing.  ProClarity expects the query to be symmetrical so there is no way for the tool to remove a single row in the grid when there is more than one hierarchy on the Rows axis, unless that row is blank.  Blank rows can be removed using the Hide Empty Rows filter.

     

    Regards,

     

    Jason

     

    Tuesday, January 8, 2008 6:51 PM
  • Thanks for the quick response.

    I've tried several cubes and views, all work in 6.2 but not in 6.3. 

     

    I'll try re-installing 6.3 and if it still doesn't work I'll open a support case. 

     

    Thanks,

    Sylvia

    Tuesday, January 8, 2008 11:11 PM
  • Reinstalled 6.3 over 6.2 and applied the .2214 patch. Still have the problem.

    One more item.  The "Hide" works on rows, with or without data, if you don't filter on empty rows.  (i.e. Hide Empty Rows is unchecked) 

    If Hide Empty Rows is checked, applied, and then you try to hide a row, all the row members are removed.

    Did you try your Adventure Works test with the empty row filter on?

     

    Sylvia

     

    Wednesday, January 9, 2008 7:37 PM
  • Hello again Sylvia,

     

    Thanks so much for the additional information.  I tried what you suggesting, using non-empties in my query, and I see the same results.  Using the Hide feature eliminates the entire query from the view, only leaving the column headings.  I am submitting this issue to our lab to see if they have any thoughts or suggestions.  I will post an update to this forum posting once I receive a reply from them.  Thanks for bringing this to our attention.

     

    Kind Regards,

    Amanda Ruffner

     

    Wednesday, January 9, 2008 11:24 PM
  • Hello again Sylvia,

     

    The only way to work around this issue is simpy by disabling the hide emtpy row feature in your Professional views.  I hope this is feasible.  By doing this you will be able to use the "Hide" feature in Web Standard.  Hope this helps.

     

    Kind Regards,

    Amanda

     

    Monday, January 14, 2008 5:16 PM
  • As we were just testing 6.3, we may continue with 6.2 until this issue is fixed.

    When would you expect a hotfix for this to be available?

     

    Thanks.

     

    Sylvia

    Tuesday, January 15, 2008 4:41 PM
  • Hi Sylvia,

     

    That sounds like a good workaround for the time being.  I highly recommend opening a ticket with the ProClarity Support group; that is the only way to raise visibility if this is a problem within the product.

     

    Kind Regards,

    Amanda

     

    Wednesday, January 16, 2008 5:57 PM
  • Hello,

     

    Wanted to addon that a business case has been submitted to the developers for this issue.  Initial investigation has revealed that this only happens with views pointing to SSAS2005 cubes.  Views pointing to AS2000 cubes are not affected by this issue.

    Friday, February 1, 2008 6:15 PM
  • We're having this same issue.  Please be sure to update this thread when there is a resolution.

     

    Thanks!

     

    Thursday, February 7, 2008 6:46 PM
  • We will update this thread as soon as there is more information as to if/when it will be fixed.

     

    Thanks,

     

    Sean

    Monday, February 11, 2008 8:16 PM