locked
How to stop monitor layout changing on laptop RRS feed

  • Question

  • Whenever I reboot, redock, or resume my laptop, Win7 resets my monitor layout to "duplicate" from "extended." While it is easy enough to switch back using WinKey+P, it is annoying, and it ties up the computer for 5-20 seconds while it first resets my display to duplicate and then redraws the extended layout. Windows also displays popups telling me that my screen resolution is now not "optimum" (duh, it WAS optimum before Windows screwed it up).

    Since this occurs after all other startup and docking functions take place, and KBs say this behavior is dictated by the type of computer (desktops default to extended and laptops default to duplicate), it must be controllable somewhere in Windows. How can I control or disable the default monitor layout?

    I disabled TMM in the registry to no effect.

    --John
    Wednesday, January 27, 2010 4:52 PM

All replies

  • Hi John,

    You issue is more related to the graphic card driver, since the monitors' settings is controled by the driver. It's better to update the graphic card driver, you can get the latest version from your laptop's manufacture, or you can get the graphic card's offical webiste.

    Good luck!


    John
    • Marked as answer by Arthur Xie Tuesday, February 2, 2010 9:21 AM
    • Unmarked as answer by John-123 Sunday, March 14, 2010 3:48 PM
    Thursday, January 28, 2010 5:59 AM
  • This is not a driver issue, it is a win7 issue (the driver is behaving just fine, it gives the layout Windows asks for). Windows 7 automatically selects a screen layout based on the type of computer. Laptops get duplicate, desktops get extend (this I found somewhere in MS KB, although I can't find the link right now). I can see a command line window popping up on docking. I want to stop that command from happening, or better yet, force a default on docking to extended layout.
    Sunday, March 14, 2010 3:48 PM