none
Permissions on Project Manager group giving to much access (to projects not owned) RRS feed

  • Question

  • Using MS PS 2010

    I have a group set up for Project Managers using the category of "My Projects" granting access to projects "owned by user" or "user is a team member".  I'm discovering that the PM can modify schedules, build team...on projects where they are only a "member".  I'm assuming that the category permissions on that group are opening this ability since the category gives access to both?  What is the best way to handle this?  I need PMs only to be able to edit projects they own but see projects they are also a member of.

    Wednesday, February 26, 2014 8:59 PM

Answers

  • K-Dee --

    Welcome to the fast-paced world of Project Server 2010!  Your problem is not new, and you are correct that the My Projects category permissions within the Project Managers group is what is causing this problem.  The resolution would be this:

    1. Open the My Projects category for editing and deselect the User Is a Team Member checkbox, and then click the Save button.
    2. Create a new Category and name it something like My Read-Only Projects.
    3. In the Users and Groups section of the page, add the Project Managers group to the list on the right.
    4. In the Permissions for Project Managers data grid, select the Open Project checkbox.  If you want your PMs to see the these projects in the Project Center page, also select the View Project Schedule in Project Web App checkbox and the View Project Summary in Project Center checkbox.
    5. In the Projects section, select ONLY the The User Is On That Project's Project Team checkbox.
    6. Expand the Views section at the bottom of the page.
    7. In the Views section, select the PWA views (Project and Project Center) you want your project managers to be able to apply to projects in which they are only team members.
    8. Click the Save button.

    Hope this helps.


    Dale A. Howard [MVP]

    • Marked as answer by K-Dee Wednesday, February 26, 2014 10:02 PM
    Wednesday, February 26, 2014 9:51 PM
    Moderator
  • Hi K-Dee,

    It's a while since I looked at this, but why don't you try the following...

    What you need to do is create a new category and then apply this new category to the Project managers group.

    1. Create a new category, and select the Checkbox "the user is the project owner..."

    2.  Edit the Group Project Managers, and note the permissions associated with the Category My Projects.  Add the new category, and make the permissions the same as the current My Projects category.  Remove the My Projects category.

    Test thoroughly!


    Ben Howard [MVP] | web | blog | book

    • Marked as answer by K-Dee Wednesday, February 26, 2014 10:02 PM
    Wednesday, February 26, 2014 9:57 PM
    Moderator

All replies

  • K-Dee --

    Welcome to the fast-paced world of Project Server 2010!  Your problem is not new, and you are correct that the My Projects category permissions within the Project Managers group is what is causing this problem.  The resolution would be this:

    1. Open the My Projects category for editing and deselect the User Is a Team Member checkbox, and then click the Save button.
    2. Create a new Category and name it something like My Read-Only Projects.
    3. In the Users and Groups section of the page, add the Project Managers group to the list on the right.
    4. In the Permissions for Project Managers data grid, select the Open Project checkbox.  If you want your PMs to see the these projects in the Project Center page, also select the View Project Schedule in Project Web App checkbox and the View Project Summary in Project Center checkbox.
    5. In the Projects section, select ONLY the The User Is On That Project's Project Team checkbox.
    6. Expand the Views section at the bottom of the page.
    7. In the Views section, select the PWA views (Project and Project Center) you want your project managers to be able to apply to projects in which they are only team members.
    8. Click the Save button.

    Hope this helps.


    Dale A. Howard [MVP]

    • Marked as answer by K-Dee Wednesday, February 26, 2014 10:02 PM
    Wednesday, February 26, 2014 9:51 PM
    Moderator
  • Hi K-Dee,

    It's a while since I looked at this, but why don't you try the following...

    What you need to do is create a new category and then apply this new category to the Project managers group.

    1. Create a new category, and select the Checkbox "the user is the project owner..."

    2.  Edit the Group Project Managers, and note the permissions associated with the Category My Projects.  Add the new category, and make the permissions the same as the current My Projects category.  Remove the My Projects category.

    Test thoroughly!


    Ben Howard [MVP] | web | blog | book

    • Marked as answer by K-Dee Wednesday, February 26, 2014 10:02 PM
    Wednesday, February 26, 2014 9:57 PM
    Moderator
  • Thank you for the quick response; will build now and test  :)

    Wednesday, February 26, 2014 10:02 PM