none
Hiding Control Panel items with Group Policy–Windows 7

    Question

  • Hiding Control Panel items with Group Policy–Windows 7

    

    i apply above GPO but user hand GPO not working this

    Sunday, July 24, 2016 8:45 AM

Answers

All replies

  • Did you add it using the details below?

    "For Windows Vista, Windows Server 2008, and earlier versions of Windows, the module name should be entered, for example timedate.cpl or inetcpl.cpl. If a Control Panel item does not have a CPL file, or the CPL file contains multiple applets, then its module name and string resource identification number should be entered, for example @systemcpl.dll,-1 for System, or @themecpl.dll,-1 for Personalization. A complete list of canonical and module names can be found in MSDN by searching "Control Panel items". 

    Sunday, July 24, 2016 10:15 PM
  • Hi,

    In my opinion, the canonical name of Microsoft.AdministrativeTools and Microsoft.WindowsFirewall should be ok.

    Windows 7 support the canonical name. and I have tested and it works.

    For more information about canonical name, you could refer to the article below.

    Canonical Names of Control Panel Items

    https://msdn.microsoft.com/zh-CN/library/windows/desktop/ee330741(v=vs.85).aspx

    Have you installed updates MS16-072?

    If yes, you could try to fix the problem with actions below.

    1. Add the Authenticated Users group with Read Permissions on the Group Policy Object (GPO).
    2. If you are using security filtering, add the Domain Computers group with read permission.

    For more information, you could refer to the articles below.

    MS16-072: Security update for Group Policy: June 14, 2016

    https://support.microsoft.com/en-us/kb/3163622

    MS16-072 – Known Issue – Use PowerShell to Check GPOs

    https://blogs.technet.microsoft.com/poshchap/2016/06/16/ms16-072-known-issue-use-powershell-to-check-gpos/

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 25, 2016 2:36 AM
    Moderator
  • Thanks Jay Gu,

    i got the silly mistake.

    Add the Authenticated Users group with Read Permissions on the Group Policy Object (GPO)

    Monday, July 25, 2016 10:31 AM
  • Arghh..yes last months update screwed that up. Computers now require the ability to read all GPOs which didnt used to be the case
    Monday, July 25, 2016 10:35 AM
  • Hi Jay,

    I hide two Item Successfully. but when i Click On Mail 32 Get a error. How can i access this item @ this step.

    Monday, July 25, 2016 10:38 AM
  • > I hide two Item Successfully. but when i Click On Mail 32 Get a error.
    > How can i access this item @ this step.
     
    You need to identify its Name - "Mail (32 bit)" might work :)
     
    Monday, July 25, 2016 11:07 AM
  • Hi Martin,

    i can't identify its name... some one said MLCFG32.CPL. i too much confuse about this issue. 

    Monday, July 25, 2016 11:51 AM
  • Hi,

    To fix the problem, you could try this:

    Hyperlinks are not working in Outlook

    https://support.microsoft.com/en-us/kb/310049

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 26, 2016 5:17 AM
    Moderator
  • Hi Jay

    user mode or administrator mode where i troubleshoot ? 

    NB: User Mode not access internet option. 

    Wednesday, July 27, 2016 6:05 AM
  • administrator mode


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by biplob9s Wednesday, July 27, 2016 9:59 AM
    • Unmarked as answer by biplob9s Wednesday, July 27, 2016 10:57 AM
    Wednesday, July 27, 2016 8:33 AM
    Moderator
  • Hi,

    What the status of the problem mail(32 bits)?

    In addition, for the problem of hide control panel items, it has been resolved, please mark relate reply as answer as it would be helpful to anyone who encounters the similar issue.

    Thank you.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 28, 2016 2:09 AM
    Moderator
  • Hi Jay,

    i troubleshoot both admin and user hand about this issue but resolve this issue... sorry for late reply. 

    Thanks,

    Biplob

    Thursday, July 28, 2016 9:41 AM
  • Hi,

    Is the problem persists?

    If yes, try this(the version of office is 2013):

    If you encounter this issue when you open the Mail icon. Then we doubt it may be related to the missing or corrupt Mlcfg32.cpl. The control panel app for mail is Mlcfg32.cpl. To fix

    the Mlcfg32.cpl, please refer to the following steps:

    1. Ensure that the following Control Panel file exists in the following locations:
    C:\Program Files(x86)\Microsoft Office 15\Office 15
    C:\Program Files(x86)\Microsoft Office 15\ClentX86 or ClientX64\Root\Office15

    2. Locate to following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Control Panel\Cpls

    Note: Ensure to back up the registry before any modification or deletion.

    3. Ensure that the mlcfg32.cpl registry entry exists and its value set as follows:

    Drive:\PROGRA~2\MICROS~4\Office15\MLCFG32.CPL

    If the mlcfg32.cpl registry entry does not exist, you must create it.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Sunday, July 31, 2016 1:59 AM
    Moderator