locked
When replacing text, Word formats quotation marks according to default language, not according to actual text language RRS feed

  • Question

  • I use the German version of Word 2010 (64 bit) and have a document formatted as "English (USA)". When I type "quote", it gets (correctly) formatted as

    “quote”

     

    However, when I type *quote* and then replace "*" with a quotation mark, it is (incorrectly) formatted as

    „quote“

     

    This is because the default language is set to German, and Germany uses this style. I tried it the other way round, set the default language to English and formatted the document as German - it got formatted according to the English style.

    So, there seems to be the bug that the "search and replace" function evaluates the AutoFormat options according to the default language, not according to the document or text language.

    Tuesday, January 18, 2011 6:56 PM

Answers

  • With smart quotes turned off, you can have Word replace specific quote characters. For example, if you activate NUMLOCK, you can press Alt+0148 to insert ”, Alt+0147 to insert “, and Alt+0132 to insert „ (type the numbers on the numeric keypad).
     
     

    Stefan Blom, Microsoft Word MVP
    • Proposed as answer by Harry Yuan Thursday, January 20, 2011 4:51 AM
    • Marked as answer by Sally Tang Friday, January 28, 2011 7:26 AM
    Wednesday, January 19, 2011 8:28 PM
  • Hi svhelden,

    For Find/Replace, you can work around the problem with:
    Find = ' "'
    Replace = ' ^0147'
    and
    Find = '" '
    Replace = '^0148 '
    (without the single quotes). That should take care of most cases - you may need to add some variants to deal with quotes preceded/followed by other characters.


    Cheers
    Paul Edstein
    [MS MVP - Word]
    • Proposed as answer by Harry Yuan Thursday, January 20, 2011 4:51 AM
    • Marked as answer by Sally Tang Friday, January 28, 2011 7:26 AM
    Wednesday, January 19, 2011 8:55 PM

All replies

  • As a workaround, have you tried temporarily turning off the Smart Quotes and then performing the find and replace?

     


    Stefan Blom, Microsoft Word MVP
    Wednesday, January 19, 2011 6:25 PM
  • Yes. When I turn off Smart Quotes and do "find and replace", I get only straight quotes as replacement (but I need English-style smart quotes). And in any case, ALL quotes are replaced (whether I enter a straight quote, an opening smart quote or a closing smart quote as search criteria, always all kinds of quotes get replaced). So, this is of no use to me.

    I found another workaround though, which is to change the default language to English for the time I work on these documents. But after all, it seems to be a bug - maybe it will be fixed in Word 2016 ;)

    Wednesday, January 19, 2011 8:06 PM
  • With smart quotes turned off, you can have Word replace specific quote characters. For example, if you activate NUMLOCK, you can press Alt+0148 to insert ”, Alt+0147 to insert “, and Alt+0132 to insert „ (type the numbers on the numeric keypad).
     
     

    Stefan Blom, Microsoft Word MVP
    • Proposed as answer by Harry Yuan Thursday, January 20, 2011 4:51 AM
    • Marked as answer by Sally Tang Friday, January 28, 2011 7:26 AM
    Wednesday, January 19, 2011 8:28 PM
  • Hi svhelden,

    For Find/Replace, you can work around the problem with:
    Find = ' "'
    Replace = ' ^0147'
    and
    Find = '" '
    Replace = '^0148 '
    (without the single quotes). That should take care of most cases - you may need to add some variants to deal with quotes preceded/followed by other characters.


    Cheers
    Paul Edstein
    [MS MVP - Word]
    • Proposed as answer by Harry Yuan Thursday, January 20, 2011 4:51 AM
    • Marked as answer by Sally Tang Friday, January 28, 2011 7:26 AM
    Wednesday, January 19, 2011 8:55 PM
  • Thanks for the tip.
    • Edited by Stefan BlomMVP Monday, July 28, 2014 4:00 PM (removed excessive quoting)
    Thursday, January 20, 2011 6:58 PM
  • It is nice to suggest workarounds, but this is definitely a bug...

    In the search/replace box, you can choose the destination language. Changing to English doesn't solve the problem.

    The same issue occurs with the French version of Word 2010 (instead of English curly quotes, we get chevrons, although the document is set as being in English).

     

    I hope Microsoft can patch this in the next Office update.

    Wednesday, May 18, 2011 7:08 PM