locked
Problem on wireless internet connection when enable on server LAN card RRS feed

  • Question

  • Hi,

    I have a windows server 2008 R2 with 2 LAN card and a wireless adapter connection. But only using 1 LAN and wireless connection. I use my wireless connection (192.168.1.x) for internet connection and 1 of the LAN (10.1.1.x) for internal connection. My server internet connection will not be able to connect when I enable the internal LAN. But the server internet connect will be working when I disable the LAN card.

    Any advice on this?

    Thanks in advance.

    Tuesday, June 16, 2015 8:09 AM

Answers

  • Dear,

    Before using static IP for WAN , make sure you remove the Default Gateway from LAN Network Adapter and set it to static IP too .

    Then add the route entry to your routing table from an elevated CMD.

    example " route add -p 10.1.1.0 MASK 255.255.255.0  "gateway 10.1.1.x"

                    Command       LAN                Net mask                LAN gateway

    1-Open CMD from Run

    2-Type "  ipconfig /all "then Enter

    3- Search for the below:

    Note: check the Wireless adapter settings and not the local Ethernet settings:

     IPv4 Address. . . . . . . . . . . : 192.168.4.12
     Subnet Mask . . . . . . . . . . . : 255.255.255
     Default Gateway . . . . . . . . . : 192.168.4.1

    .xxxxxx

    .xxxxxxxx

    .xxxxxxxxxx

    DNS Server............................192.168.4.1

    Now you got your network information

    to set up static IP address on wireless adapter on server.

    1- Open Network and Sharing center

    2- Change Adapter Settings

    3- Right Click Wireless adapter then select properties

    4- Choose Internet Protocol V4 ( TCP/IPv4) then properties.

    5- click on use the following IP and set them with information gather earlier

     IPv4 Address. . . . . . . . . . . : 192.168.4.12
     Subnet Mask . . . . . . . . . . . : 255.255.255
     Default Gateway . . . . . . . . . : 192.168.4.1

    6- Click Static DNS

    Normally if you don't have alternative DNS server it is the same as Default Gateway

    as in this example 192.168.4.1

    Regards

    IS 

    Tuesday, June 23, 2015 8:33 AM

All replies

  • Hi,

    According to your description, my understanding is that the server can’t access Internet when both wireless(connects to Internet) and wired(connects to internal) adapters are enabled.

    If Internet can be accessed once wired adapter is disabled, you may confirm that if the default gateway causes this problem. connects to both networks, open CMD and type route print to display the route table. Confirm the gateways of both network.

    This is an official article about Default Gateway Configuration for Multihomed Computers, just for your reference:
    https://support.microsoft.com/en-us/kb/157025

    Best Regards,
    Eve Wang                                                                                                                                

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, June 17, 2015 8:18 AM
  • Hi,

    I am not sure is it a routing problem. My server internet icon in Control Panel -> Network and Internet ->Network and Sharing Center screen will shown a red cross icon, on the connection to Internet, when I enable the local NIC. But the red cross icon will be gone when disable the local NIC. Is this due to the routing?

    Thank you.


    Wednesday, June 17, 2015 9:39 AM
  • Hello,

    So it showing as disconnected when enabling Local Ethernet adapter?, this is not related to routing table configuration.

    there should be a conflict in drives installed, so after you enable the LAN adapter it is disabling the other.

    Refer to the wireless driver manual to check if any conflicts occurring.

    Uninstall  wireless driver and then reinstall it using recommended settings for Windows 2008 R2.( check for compatibility issues )

    Remove the default gateway from LAN adapter and leave the wireless adapter default gateway set. Then open CMD and add route entry for LAN.

    Route add -p 10.1.1.0 MASK 255.255.255.0  "gateway 10.1.1.x"

    Regards

    IS

    Wednesday, June 17, 2015 10:12 AM
  • Hi,

    The problem is rectified.

    Its due to static ip address set on the wireless adapter. The internet connection is working if I set the ip to use dynamic with LAN NIC enabled. But internet connection will failed if I set the wireless to use static ip.

    I did tried to uninstall and reinstall the the wireless driver but still gave the same problem.

    Btw, any idea how can I set my wireless adapter to use static ip, together with my LAN NIC enabled and my wireless internet connection is still working?

    Thank you.


    • Edited by ES G Friday, June 19, 2015 3:02 AM
    Friday, June 19, 2015 3:00 AM
  • Hi,

    Please post the ipconfig /all, and route print result of your current TCP/IP configuration.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, June 23, 2015 6:57 AM
  • Dear,

    Before using static IP for WAN , make sure you remove the Default Gateway from LAN Network Adapter and set it to static IP too .

    Then add the route entry to your routing table from an elevated CMD.

    example " route add -p 10.1.1.0 MASK 255.255.255.0  "gateway 10.1.1.x"

                    Command       LAN                Net mask                LAN gateway

    1-Open CMD from Run

    2-Type "  ipconfig /all "then Enter

    3- Search for the below:

    Note: check the Wireless adapter settings and not the local Ethernet settings:

     IPv4 Address. . . . . . . . . . . : 192.168.4.12
     Subnet Mask . . . . . . . . . . . : 255.255.255
     Default Gateway . . . . . . . . . : 192.168.4.1

    .xxxxxx

    .xxxxxxxx

    .xxxxxxxxxx

    DNS Server............................192.168.4.1

    Now you got your network information

    to set up static IP address on wireless adapter on server.

    1- Open Network and Sharing center

    2- Change Adapter Settings

    3- Right Click Wireless adapter then select properties

    4- Choose Internet Protocol V4 ( TCP/IPv4) then properties.

    5- click on use the following IP and set them with information gather earlier

     IPv4 Address. . . . . . . . . . . : 192.168.4.12
     Subnet Mask . . . . . . . . . . . : 255.255.255
     Default Gateway . . . . . . . . . : 192.168.4.1

    6- Click Static DNS

    Normally if you don't have alternative DNS server it is the same as Default Gateway

    as in this example 192.168.4.1

    Regards

    IS 

    Tuesday, June 23, 2015 8:33 AM