locked
Email notifications sometimes stop RRS feed

  • Question

  • Hello

    I have SCSM 2012. Already second time I got a problem that  email notifications stop sending. Log on SCSM server has no any error at all. First time problem was solved with restarting Management Service. And all notifications that was not delivered were pushed to recipients.

    Is there any ways to push notifications without restarting the service? Is there any logs for notifications that were sent?

    Thank you

    Monday, October 15, 2012 9:53 AM

Answers

  • If there are problems with sending emails from SCSM you will find them in the Operations Manager Application event log of the server.

    Also you can check the status of the notification workflows in the SCSM console-> Administration -> Workflows -> Status. There you can check the Status of each notification workflow (when it is fired, and which result).


    Andreas Baumgarten | H&D International Group

    Tuesday, October 16, 2012 5:47 PM
  • Mark the notification workflow in the list.

    In the panel below the list you can see some more details -> "Need Attention" and "All instances" tab. On "All instances" tab you can view the log of each instance. Also you can see if and when the workflow started/triggered/fired.


    Andreas Baumgarten | H&D International Group

    • Marked as answer by Dmytro S Wednesday, October 17, 2012 6:09 PM
    Wednesday, October 17, 2012 12:02 PM

All replies

  • Hi,

    any issues should be logged within the Operations Manager event log on the management server, I would check there for any issues first.


    As long as you learn something new every day, the day is not wasted.

    Monday, October 15, 2012 10:25 AM
  • Thank you. Found error much earlier.

    Found next:

    Event ID 33880

    A Windows Workflow Foundation workflow failed during execution.
     
    Workflow Type: Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow

    Workflow Identifier: ea7b2ff9-2175-47b4-cf0b-40d02288b5f6

    Exception Type: System.UriFormatException

    Exception Message: Invalid URI: The hostname could not be parsed.

    Exception Stack:    at Microsoft.SystemCenter.ExchangeConnector.ExchangeInbox.ProcessMail()
       at Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow.Execute(ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.CompositeActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)
       at System.Workflow.Runtime.Scheduler.Run()


    Log Name:      Operations Manager
    Source:        Exchange Connector
    Date:          13.10.2012 10:46:08
    Event ID:      0
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      "servername"
    Description:
    Exchange Connector: Couldn't find Exchange web service URL or credentials in registry.  Trying default credentials and auto-discover service. Exception message: Object reference not set to an instance of an object.

    Then event from connector:

    Exchange Connector: Exchange web service URL could not be found in registry.  Continuing assuming using auto discovery using the email address: "SCSM Account"

    Then event from connector:

    Exchange Connector: Error while processing emails for email address "SCSM Account"

    Then event from connector:

    Exchange Connector: Setting status for Exchange connector 'ExchangeConnector.cecf7247a6984461a53b94654f64823c' to 'Finished With Error'


    I found that it's related to information about account and password in Exchange Connector tree in Registry. But in the past it worked perfect. I have a copy of SCSM-server registry a month ago and in it also there is no such information but it worked.

    • Proposed as answer by Morten Meisler Saturday, October 27, 2012 9:22 PM
    Monday, October 15, 2012 12:15 PM
  • The Exchange Connector is responsible of incoming emails (incoming emails to SCSM). The outgoing emails are send to the server you specified in the SCSM console -> Administration -> Notifications -> Channels.


    Andreas Baumgarten | H&D International Group

    Monday, October 15, 2012 9:44 PM
  • Thank you

    I know this.

    1. But how to check it's health?

    2. Is there any log of sending notifications?

    Tuesday, October 16, 2012 2:40 PM
  • If there are problems with sending emails from SCSM you will find them in the Operations Manager Application event log of the server.

    Also you can check the status of the notification workflows in the SCSM console-> Administration -> Workflows -> Status. There you can check the Status of each notification workflow (when it is fired, and which result).


    Andreas Baumgarten | H&D International Group

    Tuesday, October 16, 2012 5:47 PM
  • There I only see Name, Management Pack, Sealed or no, Enabled or no, Created date and Last modified date. Where should I see details here?
    Wednesday, October 17, 2012 10:44 AM
  • Mark the notification workflow in the list.

    In the panel below the list you can see some more details -> "Need Attention" and "All instances" tab. On "All instances" tab you can view the log of each instance. Also you can see if and when the workflow started/triggered/fired.


    Andreas Baumgarten | H&D International Group

    • Marked as answer by Dmytro S Wednesday, October 17, 2012 6:09 PM
    Wednesday, October 17, 2012 12:02 PM