locked
No Option To Install SNMP Service on Windows Server 2016 Standard (1607) RRS feed

  • Question

  • We have a new Win 2016 Standard edition which as far as i know, it doens't have SNMP Service installed by default. But when i go to Server Management - features, I don't see the SNMP Service option to install.

    Also tried from powershell but get-windowsfeature shows a 20% then disappear and nothing changes. Using -LogPath i see:

    116: 2018-05-17 12:26:10.033 [ServerManagerPS]           Complete initializing log file.
    116: 2018-05-17 12:26:10.065 [ServerManagerPS]           Enumerate server component started. Component names: SNMP-Service
    116: 2018-05-17 12:26:10.471 [ServerManagerPS]           Enumerate server component ended with Success.


    What am i missing ? is there other way to installing it or am I doing something wrong ?

    Thanks in advance


    • Edited by Gabrielvbs Thursday, May 17, 2018 5:08 PM
    Thursday, May 17, 2018 4:32 PM

All replies

    • Hi,
    • That's very odd indeed, I just tested on my Windows Server 2016 Standard (1607) and I saw the SNMP feature in the Server Manager.

    What you could try is to reinstall the Server Manager and MMC consoles.

    • Mount the full windows server 2016 image:

    mkdir c:\w2016

    dism /mount-image /imageFile:D:\sources\install.wim /index:2 /mountDir:c:\w2016 /readonly

    • Install the Server Manager and MMC consoles only:
    Dism /online /Enable-Feature /FeatureName:Server-Gui-Mgmt /all /source:c:\w2016\windows\ /quiet

    Kind regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Thursday, May 17, 2018 5:42 PM
  • I also have this issue, Did the reinstall of the Server Manager solve it?
    Monday, December 3, 2018 12:11 PM
  • I have also the same issue on 12 servers, the installation of the Server Manager did not solve the issue.

    any installation I tried failed :

    >Add-WindowsCapability -Online -Name "SNMP.Client~~~~0.0.1.0"

    Gave no error but nothing is installed

    >DISM /online /add-capability /capabilityname:SNMP.Client~~~~0.0.1.0

    Failed as well

    Wednesday, October 16, 2019 12:03 PM