none
enabling execution of PowerShell ISE scripts RRS feed

  • Question

  • I'm learning how to use and run a script to run a backup with robocopy and I get the powershell message "cannot be loaded because the execution of scripts is disabled on this system. Please  see "get-help about_signing" for more details."

    I learnt that I had to change the security policy and found out about the command "C:\PS>Set-ExecutionPolicy Unrestricted".  But how do I use this? I ran CMD.exe as administrator and entered it but this command is not valid. I tried including it in the Powershell script but that didn't change anything because presumably the script failed to run before seeing the command.

    I am running Powershell as Administrator (by right clicking then selecting 'run as administrator'. My system has only one user and it has Admin rights but I can't change the Powershell properties so that it always runs as Administrator (please see image). Is this indicative of the cause of my problem?

    Bottom line is I don't know what to do to make Powershell run my script. Any help would be much appreciated, TIA .... GregImage

    Sunday, February 19, 2017 1:20 PM

Answers

All replies