none
Using SCTSetting.adm Timer in Group Policy RRS feed

  • Question

  • With the new release of Windows SteadyState, I decided to test this on our domain with a few computers I have in storage (Computers running Windows XP Pro). The only problem I seem to be having is with the timer. The following error message comes up when logging onto the test account.

     

    Cannot find script file "C:/Program Files/Windows SteadyState/bin/SCTLogoff.vbs

     

    When I went to the program files and windows steadystate folder, sure enough there was no bin, or logoff.vbs script. 

     

    Thanks,

    Jeremy Johnson

     

     

    Thursday, June 21, 2007 4:06 PM

Answers

  • hi Jeremy,

     

    Franklin is right. The "HKCU\Software\Microsoft\Windows\CurrentVersion\Run" should read " %SCTPath%SCTUINotify.exe".

     

    By the way , we should perform a clean uninstallation of  the SCT v1 before installing SteadyState to avoid unkowned issues.

    Friday, June 22, 2007 4:34 AM

All replies

  • Greetings Jeremy,

     

    This is leftover from the previous version of the Shared Computer Toolkit.  In the registry hive of the restricted user the value Logoff in the key "Software\Microsoft\Windows\CurrentVersion\Run" should read "%SCTPath%SCTUINotify.exe" not "%windir%\system32\WScript.EXE %SCTPath%bin\SCTLogoff.vbs".

     

    It looks like you may have to save each public user once with the new GUI before administering them with group policy.  The template SCTSettings.adm sets the time for the logoff, but assumes that the new value above is already in place.

     

    Franklin

    Friday, June 22, 2007 12:03 AM
  • hi Jeremy,

     

    Franklin is right. The "HKCU\Software\Microsoft\Windows\CurrentVersion\Run" should read " %SCTPath%SCTUINotify.exe".

     

    By the way , we should perform a clean uninstallation of  the SCT v1 before installing SteadyState to avoid unkowned issues.

    Friday, June 22, 2007 4:34 AM
  • Did you find a solutions to this problem. I am getting the same message on a PC that has never had the SCT v1.0 installed on it.  Just Windows SteadyState.

    Tuesday, October 30, 2007 4:32 PM
  • Hi Dldab,

     

    Is the computer a domain member? This issue can occur if you had applied a Shared Computer Toolkit Group Policy Template from the server side. (SCTLogoff.vbs is a file included in SCT).

     

    If that's the situation, please delete the Shared Computer Toolkit Group Policy from the related OU.

     

    If the issue persists after that, you can also delete related registry keys directly.

     

    Method 1:

    ----------------------

    1. Log on as local administrator, temporarily add the affected user account to Local Administrator group.

    2. Log on as the affected user account.

    3. Run regedit and then locate the following branch:

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]

     

    4. Right click the Logoff key and then click Delete.

    5. Remove affected user accounts from Local Administrator group.

     

    Method 2:

    ----------------------

    1. Logon to the problematic client as build-in administrator and pen regedit.exe.

    3. Highlight the HKEY_LOCAL_MACHINE item, click File -> Load Hive, and select the NTUser.dat from the problematic user profile folder.

    4. Name the loaded hive, such as SCTuser, and then locate the registry key

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]

     

    5. Right click the Logoff key and then click Delete. Highlight SCTuser and click Unload Hive from File Menu.

    6. Repeat the above steps for all affected users.

     

    Best Regards,

    Wednesday, October 31, 2007 4:57 AM