locked
user picture does not show in User Information List RRS feed

  • Question

  • Hi,

    when browsing any list in People and Groups or any other list that is based on the User Information List, the user's picture does not show up.

    The profile sync is working correctly, new users in AD are correctly imported with their property

    The picture property in the user's profile detail is referencing a picture in a picture library, so every user has something like http://myportal.local/picturelibrary /userxxx.jpg. The path is correct

    When browsing a user's MySite the picture shows up correctly, which means the picture is ok

    Adding a user manually in the SSP, has the same behaviour, so it should not be a profile sync problem

    I've tried restarting the timer job, deleting the cache, but still the same

    there are no entries when running stsadm -o sync -listolddatabases

    I've also tried most of steps in http://blogs.technet.com/b/nishants/archive/2010/08/23/troubleshooting-user-profile-sync-issues-in-office-sharepoint-server-2007.aspx

    Any suggestion is appreciated

    Wednesday, November 10, 2010 9:45 PM

Answers

  • The problem was that the content DB was in stopped state, in CA, application management, content databases (the DB status was Offline)

    in the sharepoint logs this error pointed to the culprit:

    Aborting sweepsynch for guid instance 54043964-515b-4e3e-a5b2-a90dcf2c97e6 due to null or non-online content database

    • Marked as answer by Michele. _ Thursday, November 18, 2010 4:19 AM
    Thursday, November 18, 2010 4:19 AM

All replies

  • hi did you try this one:

    http://www.21apps.com/sharepoint/user-profiles-why-do-my-changes-not-show-in-other-sites/

    hope this help

    thanks

    -ws


    SharePoint administrator, MCTS,MCITP
    • Marked as answer by Peng Lei Thursday, November 18, 2010 3:20 AM
    • Unmarked as answer by Michele. _ Thursday, November 18, 2010 4:10 AM
    Wednesday, November 10, 2010 10:09 PM
  • Hi,

    The settings are correctly set as in the article.

    The timer jobs Profile Synchronization and Quick Profile Synchronization run regularly

     

    thanks

    Mic

    Wednesday, November 10, 2010 11:31 PM
  • The problem was that the content DB was in stopped state, in CA, application management, content databases (the DB status was Offline)

    in the sharepoint logs this error pointed to the culprit:

    Aborting sweepsynch for guid instance 54043964-515b-4e3e-a5b2-a90dcf2c97e6 due to null or non-online content database

    • Marked as answer by Michele. _ Thursday, November 18, 2010 4:19 AM
    Thursday, November 18, 2010 4:19 AM