locked
Server Manager Refresh Failed error 800F0818 RRS feed

  • Question

  • Any help would be great

    I am running Windows Server 2008 SP2 x64 R1. I have all the latest security patches applied. When i open Server Manager and attempt to view the Roles or Features I get a refresh failed error with the error details below.

    "Unexpected error refreshing Server Manager: Exception from HRESULT: 0x800F0818"

    I checked the Server Manager Log and found a larger number of the Event ID 1601 shown below

    An unexpected exception was found: System.Runtime.InteropServices.COMException (0x800F0818): Exception from HRESULT: 0x800F0818 at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo) at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package) at Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo() at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize() at Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollection documents) at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)



    I tried the Server Manager command line tool ServerManagerCMD.exe but the command "ServerManagerCMD.exe -query" produced the error message below.

    "Error: Failed to intialize."

    Although I get a different error in Server Manager that the people that update Windows6.0-KB947821-v5-x64.msu seems to help I ran it anyway to see what the log would show in the CheckSUR.log. The log below shows no errors but one waring.

    =================================

    Checking System Update Readiness.

    Binary Version 6.0.6002.22202

    Package Version 6.0

    2009-09-28 19:01

     

    Checking Windows Servicing Packages

     

    Checking Package Manifests and Catalogs

     

    Checking Package Watchlist

     

    Checking Component Watchlist

     

    Checking Packages

     

    Checking Component Store

     

    Summary:

    Seconds executed: 263

     No errors detected

    (w)        Unable to get system disk properties     0x0000045D      IOCTL_STORAGE_QUERY_PROPERTY Disk Cache      







    Wednesday, September 30, 2009 11:55 PM

Answers

  • I seem to have fixed my error.

    I found that the sand box switch /s: did not seem to be working; files were left in the same directory as the cabs after a given cab had run.

    Lets say I had two cabs in one folder to apply with pkgmgr.

    Cab1.cab
    Cab2.cab

    I run the command line

    pkgmgr /ip /norestart /m:Cab1.cab

    The cab gets expanded to same directory as the cab files and then installed. After the install the expanded files are not removed.

    When I go to apply the second cab there is still abunch of stuff from the first one left in the folder.

    so i run command line below

    pkgmgr /ip /norestart /m:Cab1.cab

    reboot and get the server manager error.

    If however I move each Cab file to a special folder apply it with the command line then delete everything in the folder I can apply all the patches without creating the issue.

    Hope this helps some one.
    • Marked as answer by MrWillieMatt Friday, October 9, 2009 7:22 PM
    Friday, October 9, 2009 7:20 PM

All replies