locked
“Network Error - 53” while trying to mount NFS share in Windows Server 2008 client RRS feed

  • Question

  • CentOS | Windows 2008

    I've got a CentOS 5.5 server running nfsd. On the Windows side, I'm running Windows Server 2008 R2 Enterprise. I have the "Files Services" server role enabled and both Client for NFS and Server for NFS are on.

    I'm able to successfully connect/mount to the CentOS NFS share from other linux systems but am experiencing errors connecting to it from Windows. When I try to connect, I get the following:

    C:\Users\fooadmin>mount -o anon 10.10.10.10:/share/ z:
    Network Error - 53
    
    Type 'NET HELPMSG 53' for more information.
    

    (IP and share name have been changed to protect the innocent :-) )

    Additional information:

    • I've verified low-level network connectivity between the Windows client and the NFS server with telnet (to the NFS on TCP/2049) so I know the port is open. I've further confirmed that inbound and outbound firewall ports are present and enabled.
    • I came across a Microsoft tech note that suggested changing the "Provider Order" so "NFS Network" is above other items like Microsoft Windows Network. I changed this and restarted the NFS client - no luck.
    • I've confirmed that the share folder on the NFS server is readable/writable by all (777)
    • I've tried other variations of the mount command like: mount 10.10.10.10:/share/ z: and mount 10.10.10.10:/share z: and mount -o anon mtype=hard \\10.10.10.10:/share * No luck.
    • As per the command output, I tried typing NET HELPMSG 53 but that doesn't tell me much. Just "The network path was not found".

    I'm lost on how to proceed with troubleshooting. Any ideas?

    Thursday, August 29, 2013 12:27 AM

Answers

All replies

  • There are usully two aspect that come to mind:

    1. Syntax of mount command

    2. Mismatch of NFS versions

    Third reason is here

    http://blogs.technet.com/b/sfu/archive/2011/11/21/getting-network-error-53-network-path-not-found-quot.aspx

    Rgds

    Milos

    Thursday, August 29, 2013 1:20 AM
  • I recently struggled with this error and it turned out to be the share permissions.  It's a bit confusing as with SMB, you would get an Access Denied error instead of Not Found error (which is what 53 is).  Since it was a Not Found error, I was assuming there was a problem with the installation or the client configuration rather than a security restriction.
    Tuesday, January 13, 2015 11:09 PM
  • Any news on the solution to this problem? The replies below are just useless links that does not address this problem at all.
    Wednesday, July 11, 2018 12:12 AM
  • In the first example above the syntax is incorrect.

    See https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/mount

    i.e. mount -o anon \\10.10.10.1\share Z: and not as the example typed.

    See also ... https://graspingtech.com/mount-nfs-share-windows-10/

    Wednesday, July 11, 2018 2:09 PM