none
Função SE com PROCV - LinhasXColunas

    Question

  • Prezados

    Tenho a seguinte situação segundo a imagem:
    Tabela_Exemplo

    Na linha F2 utilizo a seguinte formula:

    SE($F$1=$A:$A;PROCV($E2;$B:$C;2;0);"nda")

    Na linha F2 utilizo a seguinte formula:

    SE($G$1=$A:$A;PROCV($E2;$B:$C;2;0);"nda")

    Nas outras colunas segue a mesma logica.

    A questa é a seguinte: como fazer com SE e PROCV para trazer a informação solicitada - Total de cada dia produzido por cada colaborador segundo sua matricula?


    Desde já agradeço a atenção.

    Wednesday, November 14, 2012 2:35 PM

Answers

All replies

  • Em outras palavras, você quer fazer um PROCV com critérios. Veja: http://www.ambienteoffice.com.br/excel/PROCV/#procv_com_criterios

    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    Wednesday, November 14, 2012 9:51 PM
  • Uma função bem mais prática e rápida seria "=SE(F$1=$A:$A;PROCV($E2;$B:$C;2;0);"nda")" Só puxar pra baixo e depois pro lado! nem seria preciso de uma por um! ;) Mas esta que você fez também está legal!
    Saturday, January 04, 2014 12:00 AM
  • Eu utilizaria planilha dinâmica para esse caso.
    Thursday, July 30, 2015 2:11 PM
  • Olá Felipe, estou tendo um problema que talvez muitos tenha.

    Utilizo a formula SE junto com a PROCV conforme abaixo:

    =SE(K21=K20;PROCV(K21;L16:M21;2;FALSO);"")

    ...::: PROBLEMA :::...
    Tenho duas colunas, a primeira com os códigos e a segunda com as descrições.

    Exemplo:
    2.1   LIMPEZA BUEIROS
    2.2   SARJETA REVESTIMENTO CONCRETO
    2.3   SARJETA REVESTIMENTO VEGETAL
    2.4   VALETA REVESTIMENTO DE CONCRETO

    Quando procuro o item 2.2 tenho o retorno da descrição "SARJETA REV...". Até aqui ótimo.
    Se na coluna Descrição não tiver a palavra do item procurado o retorno é 0. Este retorno deveria estar em branco, porque utilizo aspas ("") dupla quando o valor é falso, e mesmo colocando algum valor entre aspas ("NÃO ENCONTRADO") o resultado é o mesmo.

    Agora a coisa fica ainda pior (rsrsrs...)
    Se na coluna código não for encontrado o código procurado o retorno é #N/D. Este retorno deveria estar em branco, porque utilizo aspas ("") dupla quando o valor é falso, e mesmo colocando algum valor entre aspas o resultado é o mesmo.

    Se você ou alguém poder me ajudar fico muito agradecido.

    obrigado!

    Jean Braga

    #N/D
    Friday, January 27, 2017 11:56 AM
  • Faça algo como:

    =SE(K21=K20;SE(PROCV(K21;L16:M21;2;FALSO)=0;"";PROCV(K21;L16:M21;2;FALSO));"")


    http://www.ambienteoffice.com.br || Grupo de WhatsApp: https://chat.whatsapp.com/K1uey5Q4yJdKnsgWkVQAZG

    Sunday, January 29, 2017 12:33 PM
  • Com a Referência travada como vou arrastar? Vai puxar sempre a mesma "matrícula".
    Thursday, June 08, 2017 2:02 PM