none
Internet Explorer 11 on Windows 7 is not displaying embedded flash video contents on Facebook and some other sites RRS feed

  • Question

  • When I want to watch Flash videos embedded into Facebook pages videos are not displayed as they should be. Where the video should be seen there is only blank white space. Audio is running normally though. If I click FULL SCREEN video mode Flash video is displayed normally. Only in small screen modes Flash videos are not displayed properly.

    I have tried playing same videos using Google Chrome which is also using Flash ActiveX and everything is working fine there. Firefox which is using Flash Plugin also works fine. Only IE11 is not working as it should.

    I have already reinstalled Flash Player and disabled all IE11 addons but problem is still there. I would say this is not Adobe Flash Player problem as in Chrome everything works fine.

    Both the latest versions of Adobe Flash Player and updated IE11 are installed on my computer.

    Can you, please, tell me what should I do to fix this problem.

    A screenshot of embedded video:

    Sunday, August 17, 2014 12:37 PM

Answers

  • Hello,

    Select explorer settings > Internet Options > Advanced tab / in Settings - Accelerated graphics check mark “Use software rendering instead of GPU rendering*” / then select OK.

    I hope it will help you, if still you are facing problem then feel free to ask me.

    • Edited by Fahadking07 Sunday, August 17, 2014 4:40 PM
    • Marked as answer by Cefizelj' Sunday, August 17, 2014 6:59 PM
    Sunday, August 17, 2014 4:37 PM

All replies

  • Hello,

    Select explorer settings > Internet Options > Advanced tab / in Settings - Accelerated graphics check mark “Use software rendering instead of GPU rendering*” / then select OK.

    I hope it will help you, if still you are facing problem then feel free to ask me.

    • Edited by Fahadking07 Sunday, August 17, 2014 4:40 PM
    • Marked as answer by Cefizelj' Sunday, August 17, 2014 6:59 PM
    Sunday, August 17, 2014 4:37 PM
  • If I click FULL SCREEN video mode Flash video is displayed normally. Only in small screen modes Flash videos are not displayed properly.

    I would say this is not Adobe Flash Player problem as in Chrome everything works fine.

    Comparing with Chrome may not be relevant but it sounds like something about the screen size is making the Flash program act differently in the two environments.  Supposedly there is a debug version of Flash but I don't know if there is a debug version for the Flash that is embedded in W8.

    Is there a publicly accessible repro page someone could use to compare their symptoms with yours?



    Robert Aldwinckle
    ---

    Sunday, August 17, 2014 4:47 PM
    Answerer
  • Hello,

    Select explorer settings > Internet Options > Advanced tab / in Settings - Accelerated graphics check mark “Use software rendering instead of GPU rendering*” / then select OK.

    I hope it will help you, if still you are facing problem then feel free to ask me.

    THANK YOU VERY MUCH FOR YOUR TIP! Everything is working fine now. Problem is solved. THANK YOU!
    Sunday, August 17, 2014 6:56 PM
  • Hello,

    Select explorer settings > Internet Options > Advanced tab / in Settings - Accelerated graphics check mark “Use software rendering instead of GPU rendering*” / then select OK.

    I hope it will help you, if still you are facing problem then feel free to ask me.

    THANK YOU VERY MUCH FOR YOUR TIP! Everything is working fine now. Problem is solved. THANK YOU!

    Anytime mate. Just select my comment as answer.

    EDIT: Thanks :)

    • Edited by Fahadking07 Sunday, August 17, 2014 7:01 PM
    Sunday, August 17, 2014 7:00 PM
  • This solution did not work for me (even after restarting Windows 7).  I am still unable to see embedded videos which I can see and play without issues on Firefox.  I cannot hear any sound, and cannot select the option to view in FULL SCREEN.  The space where the video is supposed to be embedded is simply "blank".  Frustrating, frustrating, frustrating!
    Wednesday, March 4, 2015 5:36 PM
  • AMAZING - just figured out what the problem was in my case!!  I had added several "Tracking Protection Lists" under ""Manage add-ons".  After disabling and re-enabling them one at a time, I discovered that for some reason the TRUSTe tracking protection list will prevent embedded videos from displaying on IE 11 - instead you'll just get a blank space.  I disabled this particular list, and now  embedded videos do display properly on IE 11.  Ironically, afterwards I learned that TRUSTe is funded by advertisers and works for their benefit, not yours, so it would not be a good idea to add this list if you don't want to be tracked by advertisers :-) 
    • Edited by cfrcsv1 Friday, March 13, 2015 6:29 PM
    Friday, March 13, 2015 6:25 PM
  • I've got the same problem, but it won't go away with restarting Win7, restarting IE, enabling/disabling protected lists, using full-screen mode, or anything else I can think of, and “Use software rendering instead of GPU rendering” is already checked.  I know it's a youtube video in an iframe as I did an "inspect element".  When I go directly to youtube for the video, it works fine.  Chrome plays the embedded video just fine.  Any further ideas?

    Thursday, May 7, 2015 6:48 PM
  • Thank you!

    I turned off Microsoft's "Stop Google Tracking" add-on, and video now displays.

    Thanks very much sir!

    Sunday, May 10, 2015 8:58 AM
  • Thank you Fahadking07 for your answer in how to resolve IE11 and Facebook video play problems.  I appreciate your direct, concise, directions.  Love and Peace. 

    Saturday, December 24, 2016 3:28 AM