none
In a lookup custom field select subordinates only... RRS feed

  • Question

  • Hi 

    I've created a custom field look up with Countries and in a new mask I've added towns belonging to that country.  However is there any way I can stop the user selecting the Country and only the town (or subordinate)

    Many thanks 

    James





    • Edited by JamesP435 Tuesday, September 25, 2018 8:22 PM
    Tuesday, September 25, 2018 8:21 PM

Answers

  • JamesP435 --

    Create your enterprise lookup table first with the countries and cities and then save the lookup table.  Then begin the process of creating the custom enterprise field that uses the lookup table.  In the Custom Attributes section of the New Custom Field page, select the Lookup Table option and then select your custom lookup table.  In the Custom Attributes section of the page, select the Allow Only Codes With No Subordinate Values checkbox.  Set other values for the custom field as needed and then save your custom field.  Hope this helps.


    Dale A. Howard [MVP]

    • Marked as answer by JamesP435 Tuesday, October 9, 2018 1:17 AM
    Thursday, September 27, 2018 10:58 PM
    Moderator

All replies

  • JamesP435 --

    In the Edit Lookup Table dialog for your custom field, expand the Data Entry Options section.  Select the Allow Only Codes That Have No Subordinate Values option and click the OK button.  Hope this helps.


    Dale A. Howard [MVP]

    Tuesday, September 25, 2018 8:35 PM
    Moderator
  • Hi Dale 

    I should have mentioned that I wanted this for a POL lookup and not an MS Project look up

    Many thanks

    James 




    • Edited by JamesP435 Wednesday, September 26, 2018 1:59 PM
    Wednesday, September 26, 2018 1:59 PM
  • JamesP435 --

    Create your enterprise lookup table first with the countries and cities and then save the lookup table.  Then begin the process of creating the custom enterprise field that uses the lookup table.  In the Custom Attributes section of the New Custom Field page, select the Lookup Table option and then select your custom lookup table.  In the Custom Attributes section of the page, select the Allow Only Codes With No Subordinate Values checkbox.  Set other values for the custom field as needed and then save your custom field.  Hope this helps.


    Dale A. Howard [MVP]

    • Marked as answer by JamesP435 Tuesday, October 9, 2018 1:17 AM
    Thursday, September 27, 2018 10:58 PM
    Moderator
  • Ah... so that's what the checkbox does.  Thanks Dale

    James 




    • Edited by JamesP435 Tuesday, October 9, 2018 1:18 AM
    Tuesday, October 9, 2018 1:18 AM