locked
Missing system .dll files RRS feed

  • Question

  • Hi,

    Running into an interesting issue and need some help.  I've recently rebuilt several PCs from scratch:

    • Installed Windows XP from a SP3 CD
    • Installed MS .NET Framework 1.1, 2.0 sp2, 3.0 sp2, 3.5 sp1, & 4.0
    • Installed drivers from HP's website for those components that needed drivers still
    • Applied all updates via MS's Windows Update except for 2: Windows Search 4.0 and Smart Card Cryptographic Service Provider

    I then attempt to install an .msi installer to put in some runtime components for in-house developed software using Sybase PowerBuilder 12.5.  It gives me an error saying it can't register one of its modules (pbjvm125.dll).

    In trying to track down why, I discovered that missing dependencies can cause .dll files to not register.  I downloaded "Dependency Walker" and took a look at pbjvm125.dll.  The Walker shows 4 .dll files missing:

    • MSVCP71.dll
    • MSVCR71.dll
    • IESHIMS.dll
    • WER.dll

    Now here's the real kicker... this only happens on some of the systems.  Some of them, the files are present (c:\windows\system32) and I get no error.  Now please note, the ones that work vers the ones that don't are different model PCs, but all had the same operations done to them as I mentioned above.  The only real difference, I suppose, would be the drivers from HP.

    Now, I know I could easily copy these files over from a system where they exist, but I have no way of knowing what else might be missing that is needed.  So, my question is this: what is supposed to put these files onto the system?


    • Edited by FotS Thursday, October 18, 2012 7:49 PM
    Thursday, October 18, 2012 7:40 PM

All replies

  • First of all start always with chipset driver from motherboart vendor, follow with audio,video,nic,...etc drivers.

    Second step is installation of critical updates

    Third step is installation optional updates (Be aware of updating older components first and think of search twice because of there is more problems than gains)

    Check your Event logs and resolve errors as soon as you find it.

    Install .NET Frameworks that you really needs. Remember that higher version may contain lower ones. Any problems with updating .NET Frameworks solve with Aaron Stebner's removal and reinstall.

    If you run into problems with unregistered dll, try to reregister them. For procedure and troubleshooting see here http://support.microsoft.com/kb/249873

    Regards

    Milos

    Friday, October 19, 2012 5:25 AM
  • Install VC++ Redist 2003 for MSVCP71

    Refer below link IESHIMS.dll and WER.dll

    http://stackoverflow.com/questions/2465111/dependency-walker-reports-ieshims-dll-and-wer-dll-missing


    Thanks, Renjith V R

    Friday, October 19, 2012 7:20 AM
  • Thanks for the replies.

    Milos,

    I actually have to install at least some of the .NET framework before some of the drivers as they will throw up an error saying they need .NET installed before they can continue.  As such, rather than doing some drivers/some .NET/rest of the drivers/rest of the .NET, I just do all of the .NET first and then all of the drivers second.

    I never put in Search 4.0... more of a pain then anything else.

    With .NET, I've actually been under the impression that programs written for one version will often require that version specifically and newer ones don't work.

    Well, the unregistered .dll is what started it all with the runtime components I was trying to install.  I then tried manually registering it, using regsvr32, getting the error message that the module could not be found (despite that I could see it).  So I did some research and found that I could get that error message if one of the dependencies was missing, thus leading to finding those 4 .dlls missing.

    -------------------------

    Renjith,

    Thanks for the suggestion, however, upon searching for VC++ 2003 redist, I have found that there is no separate installer for it and it should actually be included as a part of .NET 1.1... which I have installed.  I even installed the 1.1 SP1 update (KB867460) and I believe MS Update found 1 more for it.  Still no MSVCP/R 71.  And actually, what I'm finding says that these files should be a part of .NET 1.1.  I even tried uninstalling the entire .NET suite, used the .NET cleanup utility, and then tried reinstalling them all 1 by 1, starting with 1.1 and working my way up, checking c:\windows\system32 for the files after each install.  Nothing.

    And thank you for the link concerning the other 2.  So it's just down to the MSVCP/R 71 files now....

    ________________

    Oh, and to also note, I have tried installing the VC++ 2005, 2008, and 2010 redists just in case, but to no avail.

    • Edited by FotS Friday, October 19, 2012 1:40 PM
    Friday, October 19, 2012 1:23 PM
  • So, to update and bump this....

    I've snagged a copy of the MSVCP/R 71 dll files from a PC where they existed and copied them over to the ones that were missing.  After this the PowerBuilder 12.5 runtime installer works fine.

    I'd still like to investigate why these files are not getting on certain systems in the first place.

    Wednesday, October 24, 2012 5:19 PM
  • No one has any idea?
    Monday, November 5, 2012 8:18 PM
  • A quick google search suggests that it's Visual C++ 2005 Re-distributable package that contains the missing files.

    amd64

    x86

    Because its a Redistributable package it should be able to silently install. It's not an MSI so a /Q or /Silent should suffice across all of your computers (test it first obviously). 

    Alternatively I suppose you could create a batch script that checks for the existence of the files and upon failing to locate them copies them from a File Server but if you can install the missing components from a legit Microsoft Installer that's obviously a lot cleaner. Good Luck.

    Jake,


    • Edited by Jake S Nelson Tuesday, November 6, 2012 2:40 AM Added information.
    Tuesday, November 6, 2012 2:34 AM
  • Vegan,

    Yes, they are (as far as my own research could determine), and a 2003 C++ redist is supposed to have them, except the 2003 C++ redist is actually a part of .NET Framework 1.1 instead of a separate installer.  Again, some systems it gets in... some it doesn't.

    • Edited by FotS Thursday, November 8, 2012 3:20 PM
    Thursday, November 8, 2012 3:20 PM
  • Jake,

    My own research showed 2003, but either way, I already tried installing the 2005, 2008, and 2010 C++ redist packages and that didn't work either.

    And yeah, I'm looking for the "legit Microsoft Installer" method, which everything points to .NET Framework 1.1... but it's not working.

    Thursday, November 8, 2012 3:20 PM
  • Vegan,

    Thanks, but we're already painfully aware of EoL for XP.  Unfortunately, the CEO doesn't want to spend the money on upgrading all the other systems that support no later than XP....

    Either way, as already stated, I had tried completely uninstalling and reinstalling .NET and I did this on multiple boxes.

    Tuesday, November 13, 2012 1:41 PM