locked
Windows 7 100% CPU Utilization CRAP? RRS feed

  • Question

  • I am using dell Studio 14z (Core 2 duo, 5GB Ram). It was fine until last month when it's battery was good.
    Now, it is giving me very hard time. I have already formatted system drive and re-installed Win 7 64bit SP1 (Genuine) three times. It boots fast but while doing internet stuffs like online video, skype video chat, fb, CPU utilization reaches to 100% and it stays there for some time until I close browser or other programs. I don't know what is going on. I don't think battery is the cause of problem because I tried to use it without battery without success. Toolbarupdate service was also causing problem but I disabled that service but still there was problem.
    Interesting thing is when it was running good, I had run lot of big server (like sharepoint 2010 server, MS SQL server 2008), visual studio 2010 along with FB, Skype, Messenger concurrently. But now phew :-(.
    So, can anyone suggest me what is wrong or any MBR virus or any way I can improve performance of my laptop.
    Thank you in advance.

    A person who never made a mistake never tried anything new.
    • Changed type Niki Han Wednesday, November 2, 2011 8:53 AM
    • Changed type Niki Han Thursday, November 3, 2011 9:16 AM
    Thursday, October 20, 2011 6:03 PM

Answers

  • Hi,

     

    Please try the methods from the following article to improve the performance.

    http://windows.microsoft.com/en-US/windows7/Optimize-Windows-7-for-better-performance

     

    Also, please update the latest driver of network card, reset IE, test the issue in Safe Mode and clean boot.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Wednesday, February 15, 2012 9:35 AM
    Tuesday, October 25, 2011 9:55 AM

All replies

  • Hi. I think it will be not a MBR virus :)
    First of all it would be nice to identify, what cause 100% CPU utilization. Please open a Task manager, click on Processes, click on CPU column to sort processes according their utilization and provide futher information.

    About toolbars - in case of IExplorer (internet explorer) the performance does not have to be affected by toolbars only. Please see what addons are installed and disable unused addons.

    If you need futher assistance, please provide process names, that cause high CPU utilization. Thanks

    M.


    • Edited by MStoppl Friday, October 21, 2011 1:24 PM
    Friday, October 21, 2011 1:24 PM
  • Thank you for the reply.

    I have tried seeing task manager. But it is just not consistent. Sometimes IE, sometimes Chrome, sometimes Windows update, sometimes VLC player is consuming large CPU percentage. Regarding add-ons I have disabled most of them.

    Regards,

    Pradip Shrestha


    A person who never made a mistake never tried anything new.
    Monday, October 24, 2011 6:25 PM
  • Hi,

     

    Please try the methods from the following article to improve the performance.

    http://windows.microsoft.com/en-US/windows7/Optimize-Windows-7-for-better-performance

     

    Also, please update the latest driver of network card, reset IE, test the issue in Safe Mode and clean boot.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Wednesday, February 15, 2012 9:35 AM
    Tuesday, October 25, 2011 9:55 AM