locked
Windows 7 Home premium - Unidentified Network / Public Network RRS feed

  • Question

  • 2 weeks ago i got a brand new computer from Dell with Win 7 Home premium.  I cannot access the internet as the the network is saying unidentified network / public network.

    The ISP is able to see the modem is working correctly.  Dell have replaced the motherboard.  Almost 2 weeks on the phone to dell and virgin media with no solution. 

    When i run ipconfig i can see the virgin media ip address and default gateway are fine.  

    From what i can tell i need to change the network to a private network.   And because it is home premium i dont have gpedit.msc to alter it to a private network.

    Please, please help...

    Friday, June 18, 2010 8:48 AM

Answers

  • Hi,

     

    Here are some suggestions you can try:

     

    1. Bypass the router (If there is) and connect to cable modem directly for a test. Do you need disable Local Area Connection now? If so, please let me know. Otherwise, please upgrade the router firmware and then connect to router again.

     

    2. Temporarily turn off firewall on the machine.

     

    3. Upgrade the NIC driver.

     

    4. Restart the computer to Safe Mode with Networking to check the result.

     

    5. Configure the connection to obtain an IP address automatically

    =======================================

    a. Click "Start", input "NCPA.CPL" (without quotation marks) to Start Search bar and press "Enter".

    b. Right-click the network connection and click "Properties".

     

    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

     

    c. Click to highlight "Internet Protocol Version 6 (TCP/IPv6)" and click "Properties".

    d. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    e. Click "OK".

    f. Click to highlight "Internet Protocol Version 4 (TCP/IPv4)" and click "Properties".

    g. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    h. Click "OK".

    i. Reboot the computer.

     

    What's the result now? If the issue persists, please type “IPCONFIG /ALL” in Command Console and post the result here.

     

    Thanks,

    Novak

     

     

    • Marked as answer by Novak Wu Monday, June 28, 2010 2:01 AM
    Monday, June 21, 2010 2:04 AM

All replies

  • Have you tried opening the Network and Sharing Center in the Control Panel and selecting Set up a new connection or network and in that panel select Connect to the Internet?
    Friday, June 18, 2010 3:11 PM
  • Hi Rick,

    Yes i have tried that and i choose home network.  As soon as i've finished it defaults back to unidentified public network

    Friday, June 18, 2010 3:56 PM
  • In your Network and Sharing Center how many Active Networks are being shown and how are they labeled?
    Friday, June 18, 2010 5:05 PM
  • Just a shot in the dark here, but I had to fix a very similar issue on a friend's Dell desktop just last week.  (The fact that it was also a Dell has absolutely nothing to do with the problem.)

    Open up your Program Files (or Program Files (x86)) folder and see if it contains a folder named "Bonjour".  If so, restart in Safe Mode and rename the Bonjour folder to Bonjour.old or something similar.  Reboot and see if the issue's solved.  If it is, delete the Bonjour.old folder (or whatever).  

    Unless, of course, you need to stream content to an Apple device more than you need to connect to your network.

    • Proposed as answer by Hans Liss Monday, June 28, 2010 12:54 PM
    Friday, June 18, 2010 5:21 PM
  • Hi,

     

    Here are some suggestions you can try:

     

    1. Bypass the router (If there is) and connect to cable modem directly for a test. Do you need disable Local Area Connection now? If so, please let me know. Otherwise, please upgrade the router firmware and then connect to router again.

     

    2. Temporarily turn off firewall on the machine.

     

    3. Upgrade the NIC driver.

     

    4. Restart the computer to Safe Mode with Networking to check the result.

     

    5. Configure the connection to obtain an IP address automatically

    =======================================

    a. Click "Start", input "NCPA.CPL" (without quotation marks) to Start Search bar and press "Enter".

    b. Right-click the network connection and click "Properties".

     

    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

     

    c. Click to highlight "Internet Protocol Version 6 (TCP/IPv6)" and click "Properties".

    d. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    e. Click "OK".

    f. Click to highlight "Internet Protocol Version 4 (TCP/IPv4)" and click "Properties".

    g. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    h. Click "OK".

    i. Reboot the computer.

     

    What's the result now? If the issue persists, please type “IPCONFIG /ALL” in Command Console and post the result here.

     

    Thanks,

    Novak

     

     

    • Marked as answer by Novak Wu Monday, June 28, 2010 2:01 AM
    Monday, June 21, 2010 2:04 AM
  • Just a shot in the dark here, but I had to fix a very similar issue on a friend's Dell desktop just last week.  (The fact that it was also a Dell has absolutely nothing to do with the problem.)

    Open up your Program Files (or Program Files (x86)) folder and see if it contains a folder named "Bonjour".  If so, restart in Safe Mode and rename the Bonjour folder to Bonjour.old or something similar.  Reboot and see if the issue's solved.  If it is, delete the Bonjour.old folder (or whatever).  

    Unless, of course, you need to stream content to an Apple device more than you need to connect to your network.

    This solved this particular problem for a computer I was trying to troubleshoot. All I did was find the  Bonjour service (which was called something like "##Id_String2.6844F930_1628_4223_B5CC_5BB94B879762##") and stop and disable it, and then rename the folder like you suggested, and then restart.

    The network connection then worked as expected. Thanks for the tip!

    Monday, June 28, 2010 12:53 PM
  • hi, i just start getting this problem on a computer that was working perfectly fine. both wirelesses and wired connection get this issue. this is not a router issue as i have several other computers in the house connecting to the same router and running windows 7. I tried everything described, resetting adapter, re-installing things looked for bonjur service disable IP v6. nothing works. it can't get IP address from the router. i don't know how to force switch of unidentified network.

    any help is really appreciated.

    a little background, the only thing i did right before it started happening is to uninstall Norton anti virus corp addition and install AVG Free

    Wednesday, January 12, 2011 1:52 AM
  • This tip worked beautifully, Thanks!!
    Wednesday, January 4, 2012 2:51 AM
  • I have seen this problem all over the internet with numerous suggested fixes. Most reported as not working.

    The below worked for me and symptoms might be key!!!

    My symptom for Windows 7 Home Premium on a wireless LAN connection in my home was same as everyone else,... everytime I tried to connect it identified the network as unidentified, it would never ask me what it was, IE Home, Public etc...when adding. After finding on MS Technet a suggestion to run the MS utility to reset my TCPIP stack & running it and before rebooting, it  fixed my problem. It was asking me what kind of network I was adding, Home, Public etc.. it had not done that since my problem started. I had ran my laptop for years on the same SSID and had forgotten it was suppose to ask ? When it broke it never did ask so I thought that was normal. Silly me. No promises this will fix your problem but it fixed mine and after rebooting came up without a problem. Previously every time I shut down it would always say unidentified network when I booted back up & I had to jump through hoops to get it working again each time. Fix:

    Copy your security key first from properties security tab (if correct) from your SSID connection the delete all your connections in the Network & sharing center under manage wireless networks that have your SSID.  After you run the utility to fix your TCP/IP stack from MS Technet add your network back in again by selecting Setup a new connection or network, add required settings & PW, suggest check to connect even if SSID not broadcast. It should ask you what kind of network select home if at home as it will be trusted and not block TCP/IP access each time. If it asks you what type of network but was not before your probably home free. My VAIO connected before rebooting and after! Now says Home Network every time! Started after the last patch Tuesday, seems to be a common thread. Problems seem to start after updates.


    • Edited by NukeCT Tuesday, July 23, 2013 4:48 AM fix typo clarify
    Tuesday, July 23, 2013 4:39 AM