none
Delayed acknowledgment and Shadow redundancy

    Question

  • We are in coexistence 2010/2013. In 2010 we had a custom receive connector used by some applications to send mail to users internally and externally. Everything was fine until the internal users moved to 2013 and then we started to see latency in the mail sent by the applications to the exchange 2013 users. A verbose logging showed entries like "Tarpit for '0.00:00:08.665' due to 'DelayedAck',Delivered". I understand Delayed acknowledgment feature in 2010. Why is the delay to 2013 users and not 2010 users? Also, I am trying to avoid setting MaxAcknowledgementDelay  to 0. What are the implications on the messages coming from the applications servers in case of failure?
    Wednesday, March 22, 2017 1:04 AM

All replies

  • Hi Mike,

    We are currently looking into this issue and will give you an update as soon as possible.
    Thank you for your understanding and support.

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 23, 2017 10:40 AM
    Moderator
  • Hello Mike,

    As TechNet document, it note that:
    The MaxAcknowledgementDelay parameter specifies the period the transport server delays acknowledgement when receiving messages from a host that doesn't support shadow redundancy. When receiving messages from a host that doesn't support shadow redundancy, a Microsoft Exchange Server 2010 transport server delays issuing an acknowledgement until it verifies that the message has been successfully delivered to all recipients. However, if it takes too long to verify successful delivery, the transport server times out and issues an acknowledgement anyway. The default value is 30 seconds.

    The shadow redundancy is an Exchange 2010 feature and later, previous server or non-Exchange source not support it, however the source server can’t send the expected XSHADOW command, and shadow redundancy isn’t used.

    In scenario, we can set MaxAcknowledgementDelay to 0 to disable delayed acknowledgement time-out.

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 24, 2017 2:54 AM
    Moderator
  • The part I am still not clear on is that the delay is noticeable when users moved to 2013. When users were on 2010, the delay acknowledgement was still kicking in because messages were received by 2010 hub server from non exchange servers. However the latency was not noticeable. As soon as we moved users to 2013 the latency is much much more noticeable. Can someone explain this part?
    Tuesday, March 28, 2017 12:57 AM
  • Hello,

    Sorry for delay.

    To narrow down your issue, please try to new a special connector in Exchange 2013 and check the results.

    Meanwhile, if this issue remain exists, provide more information about your current environment:
    1. How many Exchange 2010 server, and Exchange 2013?
    2. Is it a DAG environment?

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 7, 2017 8:15 AM
    Moderator