locked
Exchange 2010 Throttling Issue RRS feed

  • Question

  • Hello,

    Issue: User has to use Send/Receive option, while in Exchange Cached Mode, to receive new emails.

    I suspect a user might be maxing out the connections to the Exchange 2010 servers. She had a similiar issue while were on Exchange 2007. We had to set some registry vaules to allow for more concurrent connections. How can I verify that the user is maxing out the connections? She is currently set the default Throttling policy?

    [PS] C:\Windows\system32>Get-LogonStatistics -Identity sjn | fl applicationid


    ApplicationId : Client=MSExchangeRPC

    ApplicationId : Client=MSExchangeRPC;COW=Delegate

    ApplicationId : Client=MSExchangeRPC;COW=Delegate

    ApplicationId : Client=MSExchangeRPC

    ApplicationId : Client=MSExchangeRPC

    ApplicationId : Client=CI

    ApplicationId : Client=CI

    ApplicationId : Client=CI


    Jason

    Tuesday, July 17, 2012 2:34 PM

All replies

  • Typically, events will fire on the CAS server identfying the Exchange GUID of the user when the max allowed is exceeded.

    Tuesday, July 17, 2012 10:24 PM
  • Hi Jason,

    Any updates?

    Please check whether there is any relevant event in the Event Viewer as Andy said.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Frank Wang

    TechNet Community Support

    Thursday, July 19, 2012 3:38 AM
  • Frank and A_D,

    Thanks for your tips. I am still researching this issue. I now have two reported users where their Outlook Profiles do not update with new email messages unless the hit Send/Receive.

    The two users do not have this issue when Outlook is placed into Online Mode.

    When a similar issue happened in our Exchange 2007 environment, we had to increase the number of MAPI sessions allowed.

    http://support.microsoft.com/kb/830836
    http://support.microsoft.com/kb/842022

    Here are the steps we took to resolve the issue on Exchange 2007.

    Added the following Registry Key's Below:
    MS Support #: 110121576482495
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    Key Name:Maximum Allowed Sessions Per User
    DWORD
    Value = 256

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    On the Edit menu, point to New, and then click Key.
    Add Key MaxObjsPerMapiSession, and then press ENTER.

    Key Names:
    objtFolder
    objtFolderview

    Both are DWORD and both are set to 1000 value.


    Jason

    Thursday, July 19, 2012 6:25 PM
  • Hi Jason,

    Did you also see the Event 9646 on Exchange 2010 server?

    A user mailbox has hit session limits

    http://technet.microsoft.com/en-us/library/ff360476(v=exchg.140).aspx


    Frank Wang

    TechNet Community Support


    • Edited by emma.yoyo Wednesday, July 25, 2012 2:26 AM
    Tuesday, July 24, 2012 6:14 AM
  • Where will I see this event? On the CAS/Hub Transport or on the Mailbox server?

    Jason

    Tuesday, July 24, 2012 1:24 PM
  • We might be heading somewhere. This is the first time I have seen this event on the Exchange 2010 servers.

    Log Name:      Application
    Source:        MSExchangeIS
    Date:          7/24/2012 9:22:30 AM
    Event ID:      9646
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      EXMBX01.lawfirm.local
    Description:
    Mapi session "c201ac38-392a-41ac-9141-715ff3ac806f: /o=Law Firm/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=JWilliams" exceeded the maximum of 500 objects of type "objtFolder".
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchangeIS" />
        <EventID Qualifiers="49158">9646</EventID>
        <Level>2</Level>
        <Task>6</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-07-24T13:22:30.000000000Z" />
        <EventRecordID>112382</EventRecordID>
        <Channel>Application</Channel>
        <Computer>EXMBX01.lawfirm.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>c201ac38-392a-41ac-9141-715ff3ac806f: /o=Law Firm/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=JWilliams</Data>
        <Data>500</Data>
        <Data>objtFolder</Data>
        <Binary>5B444941475F4354585D000016000000FF341B00000000000002080000003A67F01F02000000</Binary>
      </EventData>
    </Event>


    Jason

    Tuesday, July 24, 2012 1:29 PM
  • Hi Jason,

    Please follow the steps as the Technet article listed to solve the 9646 issue.

    By the way, please make sure you installed the lastest service pack and rollup for Exchange 2010(SP2 RU3) in order to avoid some known issue first.


    Frank Wang

    TechNet Community Support

    Wednesday, July 25, 2012 2:47 AM
  • Hey Frank,

    Thanks for the advice. Once we saw the Event ID 9646, we opened up a support case with Microsoft. They had us to update the registry entry to allow for my folder connections. Let me know if I need to pose the support case number for your as well.

    http://technet.microsoft.com/en-us/library/aa996193(EXCHG.80).aspx


    Jason

    Thursday, July 26, 2012 5:05 AM