none
Flash object does not read height value in % RRS feed

  • Question

  • Hi!

    Have a problem with IE 11 and maby lower versions. Know that older versions work.

    The problem is that flash objects does not show correct height.

    <!--
    writeFlashCode( "...... here is other code bla bla",
    "width=100%;height=100%;mobilesupport=true;mobiletouchtext=Tryck%20f%C3%B6r%20mobilversion");

    // -->

    The code above is situated in a table without specified height or width.


    IE will read the flashcode % value on width but not the height.

    If I change % to px then it will accept it. Width will function with both % and px.

    It does not seem to work setting height and width value to the table either.

    But if I put the flash code inside a div, where i specify width and height to 100% then the flash object will show the same as in any other browser and plattform.

    Cant see anything but an IE fault, because it has been working in older versions of IE and never (ok can't back that up but not in recent years anyway) been a problem in other web browsers.

    Thursday, October 30, 2014 2:10 PM

Answers

  • Hi,

    What's your system version, Windows 7 or later? If you are using Windows 7, you can try to reinstall Flash Player for test to fix this problem.

    In addition, is this problem occures to all website in IE 11? Please try to clear IE cache and reset IE for test.

    If problem persists, please check IE adds-on, try to open IE with No adds-on mode for test.


    Roger Lu
    TechNet Community Support

    Wednesday, November 5, 2014 8:35 AM
    Moderator

All replies

  • Hello ,

    It is better if you ask this question on Adobe Forums, you may get better answer there. You may ask it here https://forums.adobe.com/community/flashplayer. However, if you want, you can wait for someone here to give you answer. 

    Anyways, according to me, I don't think so there might be a problem with IE. There must be a mistake with your code!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, October 30, 2014 5:00 PM
  • Seems odd but maby flash player has changed something to. Or maby there is some specifications from adobe in what types the flash object can be places. My conclusion when the code has worked before is not that the code is faulty, but has become faulty from new rules.

    Thanks for the tip though, better check with adobe also.

    Friday, October 31, 2014 12:31 PM
  • Hi,

    What's your system version, Windows 7 or later? If you are using Windows 7, you can try to reinstall Flash Player for test to fix this problem.

    In addition, is this problem occures to all website in IE 11? Please try to clear IE cache and reset IE for test.

    If problem persists, please check IE adds-on, try to open IE with No adds-on mode for test.


    Roger Lu
    TechNet Community Support

    Wednesday, November 5, 2014 8:35 AM
    Moderator