none
Caps Lock Detection RRS feed

  • Question

  • I recently upgraded our Citrix environment from IE 8 to IE10 and we are now getting Caps Lock warning balloon popups on password fields which did not appear in the old version.  Our users typically use all caps passwords so having the Caps Lock feature on makes it much easier for them to type their password in.

    These balloon popups are blocking the buttons that a user needs to click on to complete their logon into the application. 

    Is there anyway to disable those balloons from appearing without changing the page code? If not, is there a way to change the way they are displayed (smaller, different location, etc..), again, without changing the page code itself?

    Thursday, July 17, 2014 7:01 PM

Answers

  • Adding to Rowdy's answer...

    legacy CapsLock detection relies on comparing the entered charCode with the uppercase value...

    IE10 uses standards KeyboardEvent properties. Most probably your legacy CapsLock detection script is using MS proprietary keyboardEvent properties.

    Use the IE developer tool to debug your scripts (IE10 should be throwing an error on your legacy code).

    F12>Script console tab, refresh the current page to show suppressed error messages.

    You can force IE to use a legacy rendering mode by

    1. Adding the site to your GPO compatibility view list or Enterprise Mode lists.

    2. Adding x-ua meta or response headers.

    3. checking "Display intranet sites in compatibility view" (this can be over-ridden with x-ua meta/response headers.

    4. Updating your legacy website to 'standards'

    Post questions about html, css and scripting for website development to the IE Web Development forum... Include with your questions

    a link to your website or a mashup that shows the issue....together with the full output from your Developer tool console.

    Regards.


    Rob^_^

    • Marked as answer by Rowdy Retski Monday, July 21, 2014 2:59 PM
    Monday, July 21, 2014 12:59 PM

All replies

  • Hi,

    Based on my research, it seems that on the website, the balloon tips on or off is depends on the code:

    msCapsLockWarningOff property

    http://msdn.microsoft.com/en-us/library/ie/jj128374(v=vs.85).aspx

    If following method "to disable all balloon tips in Windows" doesn't work, I suppose that to change code could be the only way:

    • Click Start, click Run, type regedit, and then press ENTER.
    • Locate the following subkey:
      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    • Right-click the right side pane, create a new DWORD value, and then name it EnableBalloonTips.
    • Double-click EnableBalloonTips, and then give it a value of 0.
    • Close Registry Editor.
    • Log off Windows, and then log back on.


    Kate Li
    TechNet Community Support

    Friday, July 18, 2014 9:19 AM
    Moderator
  • Adding to Rowdy's answer...

    legacy CapsLock detection relies on comparing the entered charCode with the uppercase value...

    IE10 uses standards KeyboardEvent properties. Most probably your legacy CapsLock detection script is using MS proprietary keyboardEvent properties.

    Use the IE developer tool to debug your scripts (IE10 should be throwing an error on your legacy code).

    F12>Script console tab, refresh the current page to show suppressed error messages.

    You can force IE to use a legacy rendering mode by

    1. Adding the site to your GPO compatibility view list or Enterprise Mode lists.

    2. Adding x-ua meta or response headers.

    3. checking "Display intranet sites in compatibility view" (this can be over-ridden with x-ua meta/response headers.

    4. Updating your legacy website to 'standards'

    Post questions about html, css and scripting for website development to the IE Web Development forum... Include with your questions

    a link to your website or a mashup that shows the issue....together with the full output from your Developer tool console.

    Regards.


    Rob^_^

    • Marked as answer by Rowdy Retski Monday, July 21, 2014 2:59 PM
    Monday, July 21, 2014 12:59 PM