none
PXE Extremely Slow and OSD TS Fails | SCCM 1902 RRS feed

  • Question

  • Hello everyone, we have had some issues lately with SCCM 1902.  Before my time, one of the IT admins used the fix here to resolve some speed issues we were having.  After upgrading SCCM over time and now to 1902, PXE has become incredibly slow in 18** and now PXE as well as OSD TS's are failing constantly in 1902.  

    Everything else appears to be working fine, updates are being pushed with WSUS, applications are being configured and deployed as expected.  

    The issue seems to be related to only PXE and OSD TSs it appears.. I tried these steps but haven't got it to work yet..

    1. Disable PXE in SCCM
    2. Uninstall WDS
    3. Reboot
    4. Enable PXE
    5. Expected behavior should be for WDS to reinstall on its own correct?  It never does.
    6. Manually install WDS
    7. PXE is slow or does not work at all, common errors during PXE are 0xC000001

    I am really at a loss here and my guys are losing their minds.. in the meantime I am going to need to provide USB imaging for them so they can work.  The beginning of the school year is always a little crazy for us.  Any help would be greatly appreciated.


    • Edited by TravisMN Wednesday, August 14, 2019 12:43 AM
    Tuesday, August 13, 2019 10:54 PM

All replies

  • I just went through this so I know how crazy it can be. Lets start with something basic. Under Monitoring > System Status > Site Status. Is everything green and happy there or do we have problem messages? You are right btw when you add PXE back it should install it back. Also make sure the DP you are working with does show there. For now I would say let's get PXE working. Once it is we can address why it is slow. 

    Thomas Faherty


    • Edited by Kiodos Tuesday, August 13, 2019 11:21 PM
    Tuesday, August 13, 2019 11:19 PM
  • Try this:

    On your PXE DP settings, enable the option "Enable a PXE responder without Windows Deployment Service."

    Then, remove the TFTP windows size and block size registry values on the PXE DP (if there are any).

    • Proposed as answer by Kiodos Thursday, August 15, 2019 3:28 PM
    Wednesday, August 14, 2019 3:32 AM
  • I just went through this so I know how crazy it can be. Lets start with something basic. Under Monitoring > System Status > Site Status. Is everything green and happy there or do we have problem messages? You are right btw when you add PXE back it should install it back. Also make sure the DP you are working with does show there. For now I would say let's get PXE working. Once it is we can address why it is slow. 

    Thomas Faherty


    Everything is green except my DP (only have 1) which has some warning.  They are all either of these three:

    5413

    5416

    5418

    Appears to be related to hardware inventory issues?  One thing that has been super odd is that my smspxe.log does not show anything, is it because its using WDS?

    Wednesday, August 14, 2019 4:51 AM
  • Try this:

    On your PXE DP settings, enable the option "Enable a PXE responder without Windows Deployment Service."

    Then, remove the TFTP windows size and block size registry values on the PXE DP (if there are any).

    I see this option but its greyed out.. I Googled it and I guess I had to disable Multicast, which I did for now.

    I am now rebooting, will enable this, remove the regedit settings and try again when I get back to work.  Will report back.

    Note: When I went to remove the regedit settings, I saw that there was a LOT more settings there, since I assume enabling PXE on the DP itself added new settings.  The Window settings were gone and new TFTPBlockSize was changed to 16*k  When I last set that it was was to 1456 so that was automatically done, so I will leave that alone for now.


    • Edited by TravisMN Wednesday, August 14, 2019 5:11 AM
    Wednesday, August 14, 2019 5:03 AM
  • Hi,

    Please note that "Enable a PXE responder without Windows Deployment Service" option has a limitation here: It does not support multicast, if you need multicast, you need to stick with Windows Deployment Service. For more information on this option please see:
    If you enable this option on a distribution point that's already PXE-enabled, Configuration Manager suspends the WDS service. If you disable this option, but still Enable PXE support for clients, then the distribution point enables WDS again.
    If you Enable PXE support for clients and Enable multicast to simultaneously send data to multiple clients, then you can't Enable a PXE responder without Windows Deployment Service.
    If you Enable PXE support for clients and Enable a PXE responder without Windows Deployment Service, then you can't Enable multicast to simultaneously send data to multiple clients



    Best regards,
    Larry

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, August 14, 2019 7:05 AM
  • Hi,

    Please note that "Enable a PXE responder without Windows Deployment Service" option has a limitation here: It does not support multicast, if you need multicast, you need to stick with Windows Deployment Service. For more information on this option please see:
    If you enable this option on a distribution point that's already PXE-enabled, Configuration Manager suspends the WDS service. If you disable this option, but still Enable PXE support for clients, then the distribution point enables WDS again.
    If you Enable PXE support for clients and Enable multicast to simultaneously send data to multiple clients, then you can't Enable a PXE responder without Windows Deployment Service.
    If you Enable PXE support for clients and Enable a PXE responder without Windows Deployment Service, then you can't Enable multicast to simultaneously send data to multiple clients



    Best regards,
    Larry

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Without Multicast, the DP can still send data to multiple clients at the same time correct, just our other machines cannot peer-to-peer trasmit data.  So in reality, all data is streaming from the DP, correct?  I am trying to make sure I understand fully what happens if I disable multicast.
    Wednesday, August 14, 2019 2:14 PM
  • Also, as an update.. the steps that Kerwin Medina explained at first glance appears to have solved the problem.. the PXE time went from about 1-2 minutes to about 5 seconds.  I am still watching my first test image..
    Wednesday, August 14, 2019 2:15 PM
  • Hi,

    Multicast deployments conserve network bandwidth by simultaneously sending data to your multiple ConfigMgr clients. If we disable multicast, the server sends a copy of the data to each client over a separate connection.
    Please refer to the following article for more details:

    https://docs.microsoft.com/en-us/sccm/core/servers/deploy/configure/install-and-configure-distribution-points#bkmk_config-multicast

    Best regards,
    Larry


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 15, 2019 3:28 AM