locked
exec.exe HELP RRS feed

  • Question

  • i have vista installed on my laptop and i keep having this program

     

    program: exec.exe

    Location: c:\users\Jeff\appdata\temp\exec.exe

    i keep getting this windows message saying:

    an unidentified program wants to access to your computer

     

    everytime i get it i cancel but what is this program and how do i remove it. i have tried booting into safe mode and trying to find the program and it is not there. even if i set it so no files hidden it is still not there i have searched as well as go to its location and it is no where to be found yet it keeps trying to access my computer

     

     

    please help!!!

    Thursday, October 19, 2006 7:38 AM

All replies

  • I am having the same issue.  I find it very frustrating that every time i do anything on the laptop I get the Exec.exe pop up.  Is their anyway to make this go away.  Also, I cann't install certain Active X controls for gaming.  Any ideas
    Wednesday, January 31, 2007 6:48 PM
  • Just started to have the same problem too.

    It seemed to start to occur after I changed the networking settings on my computer.  I was trying to open up a home network to exchange files.  I dont know if changing one of these settings caused this to occur.

    Wednesday, January 31, 2007 8:37 PM
  • I've had the same problems, but one thing that is consistent is that I am always running AOL Instant Messenger.  I also found this that might confirm the cause as AIM: http://blogs.chron.com/techblog/archives/2006/09/did_windows_vis.html

     

    Anyone else using AIM when this happened?

    Saturday, February 10, 2007 6:24 PM
  • Everytime it pops up, I am using AIM. I dont know how to fix it either. BTW, I am having the same problem. I cant seem to find the file on my computer. Is anyone running norton internet security on Vista? if you are, did you dl the updated one from symantec.com?
    Monday, February 12, 2007 10:59 PM
  • You probably can't find the file on your computer because it seems to be auto-compiled on the fly by AIM.  I haven't seen the message in a few days and I've rebooted several times, so it might be gone for now? Who knows.  BTW, I am running Windows Live OneCare as my virus/firewall app.
    Monday, February 12, 2007 11:17 PM
  • I just purchased a Toshiba Satellite with Vista home Premium on it... Installed AIM... and instantly started getting the request to launch Exec.exe... Research told me the same thing it told everyone else... It's a Worm... W32/Spybot-Z; or it's a part of netZero.... which I don't use.

    This is the FIRST place I've found that mentions it might be a part of AIM... and as I think about it, everytime I encounter it, I'm running AIM.

    I'm glad to know I'm not the Only one, and that it isn't as malicious as I though.

    Wednesday, February 14, 2007 3:44 PM
  • Seeing all the same items everyone has mentioned...Bradn new DELL....installed AOL....when it starts exec.exe file warning window pops up....at one point it tried to open 20 IE Windows...strange....

    Loaded all the latest NAV scans and even SPYBOT.com scan....and nothing detected....

     

    Come on MS...get tough with AOL IM !!!!   

     

     

     

    Wednesday, February 14, 2007 4:54 PM
  • My hubby has been checking it out. He plans on calling Microsoft today to find out. He thinks it is apart of the Vista security. BTW Exec.exe is the worm, but exec.exe is something differnt(according to my hubby who is quite a bit more experienced with this then I am).
    Wednesday, February 14, 2007 6:12 PM
  • did anyone let the executable run... im kinda interested in seeing what happens.
    Wednesday, February 14, 2007 9:53 PM
  • I accidently clicked run a few days ok, but nothing happened, and it still keeps popping up.
    Wednesday, February 14, 2007 10:49 PM
  • I cleared my temp internet files and it went away for the time being....
    Thursday, February 15, 2007 6:47 PM
  • I went to the directory that the "details" button reveals after clicking cancel to look for it, (C:/users/appdata...) where I could not find it.  However, after a minute or two I got the cancel/allow message and at the same time, Exec.exe appeared in the directory.  And mine, (capitalized, so apparently the malicious version?) does only run when AIM is up too.  Can't delete it though because it goes away when you click cancel.  Not happy.
    Thursday, February 15, 2007 10:50 PM
  • So far i have figred out it only runs while using aim. if you are letting aol sit idle, it seems not to pop up, but once you click on a buddy and start to chat, it shows up. one alternate method which i have not tried yet, is to use Gaim, instead of aim. i will be attempting that sometime today, and i will let you know what happens.
    Friday, February 16, 2007 1:07 PM
  • I have installed Gaim, set up my aol account throuth that, and i do not get the exec.exe message anymore. If you are looking for gaim, you can get it here http://gaim.sourceforge.net/downloads.php  Hope this helps
    Friday, February 16, 2007 2:00 PM
  • Thanks for the heads up. I to was having this issue, and hitting cancel, and I finally just got tired of it.

    I ran the AIM Fix tool, and it caught a virus, but a few minutes later the pop-up came back. I deleted files and cookies as one post suggested, pop up came back. I hate that AIM has been having so many security breaches lately. I ran spy-bot, windows defender, Norton, and Ad-aware - nothing!

    So, thanks to your suggstion I researched and then downloaded GAIM. It's pretty close to AIM, and I'm a little sad at having to see AIM go, but... We'll see if I find the pop up anytime in the future! Glad we have sights like this where we can help each other out!

    Tuesday, March 6, 2007 11:54 AM
  • Guys, when you update Vista, it stops.
    Tuesday, March 6, 2007 3:04 PM
  •  MindlessRants87 wrote:
    Guys, when you update Vista, it stops.

    What do mean by "update Vista"?  Do you mean run microsoft update?

    Tuesday, March 6, 2007 3:16 PM
  • Yes, run microsoft update. The updates from... a week or two ago.

    I forgot about this thread since it stopped. lol.

    Tuesday, March 6, 2007 5:18 PM
  • nope ... i'm completely updated and still receiving these (exec.exe) whenever i have AIM open

    windows vista ultimate, aim 6.0

    Wednesday, March 7, 2007 12:27 AM
  • hmm i am running the same thing. Are you also running nis '07? MAybe it was the updated norton that stopped it.
    Wednesday, March 7, 2007 4:05 AM
  •  I was also having the same problem. I ran across the following site:

    http://www.thegline.com/windows/2007/01/uac-unwanted-annoying-***-not.html

    Apparently when downloading AIM, we also agreed to downloaded another program - Viewpoint Media Player. I've deleted the program and have not seen the prompt since.

    Good luck

    Monday, March 12, 2007 4:07 AM
  • I have notice the same thing. I too am running AIM and its giving me the same pop-up.
    Wednesday, April 4, 2007 7:15 PM
  • I have updated everytime i get on comp .welll does it mean that if you get rid of aol you get rid of exec.exe ? this thing is a big pain.AOL has always caused a problem with EVERY computer i have had.
    Monday, April 9, 2007 3:39 PM
  • Thank you very much for shareing that . I did the same thing and so far ....its gone!!!   thank you very much
    Monday, April 9, 2007 3:47 PM
  • iam getting the same thing on my computer,i use cable and it is no better ,also i keep getting a message that said that my internet is not working ,have to restore the computer to get it working again and i know its working because i have 3 other computer hooked up and they all work but this one  the other ones is all h.ps and have xp on them .i got this one a few weeks ago and i wish i never got it ,my son works on computers and very good at it but he cant do anything with window vista can anyone tell me what to do with it thank you
    Monday, April 9, 2007 10:29 PM
  • ok, here's the deal people.  the uac prompt that you've been getting in vista is more likely than not a result of aim, which has been covered in past posts.  furthermore, it is also in fact a product of viewpoint media player which comes bundled with aim, which has also been covered.  if you go to your control panel and uninstall viewpoint media player, the prompts should stop.  my guess is that viewpoint is used by aim to display certain advertisements in the buddy list window, and the prompt is windows vista not knowing what's going on when aim/viewpoint is trying to execute.

    so, in summary, for those of you experiencing the exec.exe uac prompt, check and see if you are running aim when you get it.  if so, uninstall viewpoint media player.  it should go away

    for those of you that this is not the case, there may be something else going on.  this is directed at you (perhaps) -- the anonymous person who is having their internet cut out as well.  there is certain spyware, trojans, etc, that do utilize an executable called exec.exe.  some symptoms of having such a trojan are your internet cutting out.  also be warned that trojans that are known to execute a program called "exec.exe" also have your typical characteristcs of a trojan which include key logging (meaning every keystroke you make is being recorderd and most likely viewed at a remote location).

    so, to sum everything up, uninstall viewpoint media player if it is installed, cuz it's a piece of *** and serves no constructive purpose, and if that doesn't clear up the exec.exe uac prompt, then get your hands on some spyware removal software and some antivirus, and let them do their thing.

    any more questions i'll be more than happy to help or attempt to point you in the right direction.

    -Brook


    Wednesday, April 11, 2007 3:54 PM
  • Windows Vista is completely up to date for me and I STILL get it.
    Wednesday, April 11, 2007 4:33 PM
  • I have sinced solved the problem by getting rid of standard AIM and I've moved over to AIM Secure.  It's free and there are no "exec.exe" prompts:

    http://aimpro.premiumservices.aol.com/

     

    Enjoy!

    Wednesday, April 11, 2007 5:18 PM
  • I had AIM 6.0 installe and was getting the exec prompt. I uninstalled and installed the 5.9 version and the prompt never came back.
    Saturday, April 14, 2007 7:01 PM
  • I have been using the AIM 5.9 version with Vista Home Premium and experiencing the same Issues. For those of you not reading previous posts the Exec.exe issue is related to Viewpoint Media Player.

    To Resolve the issue...

    Go to Control Panel > Programs and Features > Click on Viewpoint Media Player > Click Uninstall.

    Then resume happy Vista experiences.
    Monday, June 23, 2008 3:16 PM
  • Hi,

     

    I agree with the above resolution, biut in my case, i'm working in a computer without Administration authorization. How can i overcome this problem?

     

     

     

    Tuesday, October 28, 2008 11:27 AM