none
Disabling SMBv1 on Windows Server 2008r2 Error

    Question

  • Hi all,

    When i attempt to disable SMBv1 or even enable SMBv2 i get the below error on powershell (ran as admin)

    PS C:\Users\Administrator> Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB1
     -Type DWORD -Value 0 -Force
    Set-ItemProperty : Requested registry access is not allowed.
    At line:1 char:17
    + Set-ItemProperty <<<<  -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB1 -Type DWORD -Valu
    e 0 -Force
        + CategoryInfo          : PermissionDenied: (HKEY_LOCAL_MACH...rver\Parameters:String) [Set-ItemProperty], Securit
       yException
        + FullyQualifiedErrorId : System.Security.SecurityException,Microsoft.PowerShell.Commands.SetItemPropertyCommand

    Then i tried to access the registry folder (HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters)

    When i attempt to create the DWORD, i get the error: Cannot Create value: Error Writing to registry

    i then attempted to change the permissions on the parameter folder by right clicking it. I added the admin user but when i tried to save and apply the changes

    i get the error: Unable to save permission changes on parameters. Access denied.

    Kindly assist

    Monday, July 9, 2018 10:43 AM

All replies

  • Hello,

    Did you attempt to run it with an elevated prompt (Powershell or Registry) ?

    Best Regards,

    Monday, July 9, 2018 4:07 PM
  • Hi,

    Please check your powershell version.

    This method requires PowerShell 2.0 or later version of PowerShell.

    https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

    As said above, even if you have log on as admin account,  please still run powershell with "run as administrator"

    Generally, this issue can be caused by the incorrect permissions. According to your description, the account is already a admin account, right?

    Please also  temporarily UAC settings on this computer. And restart to check again, same results?

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 10, 2018 3:00 AM
    Moderator
  • Hi Dokoh,

    Yes i ran powersheel as admin (Run as Administrator)

    Best Regards

    Wednesday, July 11, 2018 7:18 AM
  • Hi Mary,

    On UAC settings:

    Am a member of the Administrators group

    My password never expires

    Remote control is enabled 

    I think am using powershell 2 as below

    

    Wednesday, July 11, 2018 7:28 AM
  • Dokoh,

    Yes i did and below is the Error i get

    Wednesday, July 11, 2018 7:31 AM
  • Hi SecExpert,

    I mean maybe you could test to disable UAC to do a check.

    As we know, users in Local Administrators group or domain will work as standard user. When it needs to run as Admin, a prompt will occur to promote the permission to Admin level.  Or sometimes even you have log on the computer as the administrator, when you run application or use commands to run some task , you will get access denied.

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc709691(v=ws.10)

    So you could temporarily disable UAC settings on this computer. And restart to run again.

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 11, 2018 8:52 AM
    Moderator
  • Hi,

    If you have the updates, please feel free to contact us.

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 13, 2018 6:33 AM
    Moderator
  • Hi Mary,

    On the user account control settings i put it to never notify and restarted but still the powershell error persisted.

    From the Local Security Settings console tree, on Local Policies, on Security Options. On the part of User Account Control: Run all administrators in Admin Approval Mode i temporarirly disabled this but still the error persisted.

    Monday, July 16, 2018 11:05 AM
  • Hi,

    I'm afraid you might need to contact  Microsoft Customer Support Services (CSS) for dedicated Support.

    It is also appreciated that the other members in our forum can share their experience with us about this scenario.

    To obtain the phone numbers for specific technology request, please refer to the website listed below:

    https://www.microsoft.com/en-us/worldwide.aspx

    Appreciate your support and understanding.

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 17, 2018 1:22 AM
    Moderator