locked
PXE boot will not work RRS feed

  • Question

  • Hello All,

    I know there are tonnes of questions and answers about PXE issues. I think I have now gone through them all, none of them have fixed my issue.

    When any client is PXE booting to our SCCM server we get a blue screen with the following error.

    File: \boot\bcd

    error code: 0xc000000f

    We are also running a second WDS server. When I change the DHCP settings to point to it everything runs fine. So I know DHCP is fine.

    The SMSPXE log file shows no errors. I can see the machine coming in and it says "device is in the database"

    I have checked to see if Boot image x86/x64, OS is distributed to the DP , which they are. PXE is enabled on the DP.

    The machine is in a group that has a TS applied to it, the TS has a boot image also applied to it.

    Not sure what else to look at, any suggestion would be a greet help.


    • Edited by OptimAdam Tuesday, May 20, 2014 2:55 PM
    Tuesday, May 20, 2014 2:55 PM

All replies

  • I've often had to disable and re-enable PXE to fix similar issues. This uninstalls and reinstalls WDS.

    http://www.gerryhampsoncm.blogspot.ie/2013/02/sccm-2012-task-sequence-fails-with-bcd.html



    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    Tuesday, May 20, 2014 3:00 PM
  • I have tried un-installing and reinstalling WDS and the DP as well as enabling and disabling PXE, make no diffeence :(

    I did notice the following errors in the SMSPXE log, will have a look into this.

    CContentDefinition::GetFileProperties failed; 0x80070003

    CContentDefinition::CopyFileW failed; 0x80070003

    CContentDefinition::ExpandContentDefinitionItems failed; 0x80070003

    CContentDefinition::Expand failed; 0x80070003

    • Edited by OptimAdam Wednesday, May 21, 2014 10:14 AM
    Wednesday, May 21, 2014 9:24 AM
  • Are you using IPhelpers or DHCP options? What does smspxe.log tell? Have you already tried using USB boot media (for testing purposes)?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, May 21, 2014 9:41 AM
  • We are using DHCP options which we use for our WDS/MDT set up. I can see the client connecting to SCCM so the rules look like there working correctly.

    The smspxe.log says:

    Client lookup reply: <ClientIDReply><Identification Unknown="0" ItemKey="16777223" ServerName=""><Machine><ClientID/><NetbiosName/></Machine></Identification></ClientIDReply>
    00:1D:D8:B7:1C:F9, 4EFC1C42-8FCF-E1C9-ACD7-F686327977B2: device is in the database.

    Thats it :S, after that the client drops with a blue screen saying:

    File: \boot\bcd

    error code: 0xc000000f

    USB boot image works fine.


    • Edited by OptimAdam Tuesday, May 27, 2014 3:46 PM
    Tuesday, May 27, 2014 3:24 PM
  • Have you tried re-distributing your boot image?

    Wednesday, May 28, 2014 4:19 AM
  • Yes tried re-distributing the boot image, made no difference.

    Yesterday I removed the DP, all the content and rebuilt it, I still get the same issue.

    Wednesday, May 28, 2014 9:14 AM
  • I have done a complete rebuild of SCCM 12 and are still running into the same issue.
    Tuesday, June 24, 2014 3:41 PM
  • Which DHCP options are you using and how are they set? (BTW: using IPhelpers would be the preferred way)

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, June 24, 2014 4:08 PM
  • 066 - serverDNS name
    067 - smsboot\x86\wdsnbp.com

    The machine is picking up and IP and talking to configuration manager. I can see in the smspxe log that its getting that fair "device is in the database". After that it just fails. 

    Wednesday, June 25, 2014 8:13 AM
  • What does smspxe.log tell exactly then?
    Have you already tried to wipe the disk of the client (manually)?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, June 25, 2014 9:01 AM
  • Yes i have tried wiping the disk and it has made no difference.

    The whole smspxe.log when a pc connects

    Client lookup reply: <ClientIDReply><Identification Unknown="0" ItemKey="16777223" ServerName=""><Machine><ClientID/><NetbiosName/></Machine></Identification></ClientIDReply>
    SMSPXE 25/06/2014 15:05:56 2636 (0x0A4C)
    00:50:56:9C:0A:4C, 10C51C42-AD0B-508D-2042-A0D4FFE82AFB: device is in the database. SMSPXE 25/06/2014 15:05:56 2636 (0x0A4C)

    Wednesday, June 25, 2014 2:08 PM