none
Rich Text not displaying in Firefox or Chrome

    Question

  • Hi,

    I have a custom InfoPath 2010 form that is being used for a Tasks list.

    I can create, save, and edit the form fine in all browsers (IE, FF, Chrome).

    When I am opening a Task item to read, I can see all the contents of the fields fine in IE, and partially fine in FF and Chrome.  The problem is that I noticed for Rich Text that are not mandatory or requires any validation, then the data does not display in FireFox or Chrome at all!

    One of the form has a repeating table for history comments, in IE I can see (read) the text from previous users, but in Firefox and Chrome, I can only see the names and the date/times of when a comment was made and cannot see the actual comments.

    Browser versions being used are:

    Internet Explorer 9.08 on Windows 7

    Firefox 12.0 on Windows 7

    Chrome 19.0.1 on Windows 7

    I need this to be resolved since it is also affecting users on the Mac platform.

    Any help would be greatly appreciated.. Thanks in advance


    • Edited by RoadRunnr Monday, May 28, 2012 5:10 PM
    Monday, May 28, 2012 4:43 PM

All replies

  • Hi RoadRunnr,

    I am unable to reproduce your issue on Firefox with 32 bit.

    Could you please add your site as Intranet site in Firefox or Chrome, so that the script associated with rich text control is not blocking by browser security factors?

    If the problem persists after you added the site as Intranet site, could you please tell more details about how you custom the task form and the rich text field?

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    Tuesday, May 29, 2012 9:50 AM
  • Hi Emir,

    Thank you for your response.

    i've just added my site url to Trusted Site in Firefox (using this method --> http://support.mozilla.org/en-US/questions/784746#answer-138252), restarted FF and it still doesn't show up the text.

    The custom Task Form was done in InfoPath 2010 and the only difference I see between the Rich Text fields that do show up in all browsers, and the Rich Text fields that do NOT show up in FF or Chrome, is that of the Rich Text Box Properties --> Data Tab --> Validation , the "Cannot be blank" is checked for the ones that do show on all browsers.

    Even when I do check that and publish the form, it still does not display.

    I thought that it may be a permission thing, but I'm using my own id to create these customes tasks, and still i don't see those particular fields.  I'm stumped here and not sure what else to look for.

    Tuesday, May 29, 2012 3:13 PM
  • Hi RoadRunnr,

    Will all Rich Text field in InfoPath form cannot be display in FF and Chrome except when the "Cannot be blank" option is checked?

    If no, could you please delete the InfoPath task form from SharePoint Designer and new task form can be created when you save and publish the workflow. I think there should some rules affect the control in the form.


    Emir Liu

    TechNet Community Support


    • Edited by Emir Liu Wednesday, May 30, 2012 11:44 AM
    Wednesday, May 30, 2012 11:44 AM
  • Hi Emir,

    I already tried changing the problem rich text fields to be the same as the ones that actually do show, but no luck. I even created a new rich text field that has "Cannot be blank" NOT checked, and it still doesn't display.

    As for the form itself, all I did was when I created a new Task List, I edit the form in InfoPath (clicked on the Infopath Ribbon option "Customize Form" on the SharePoint site).  I did not add any workflow to the form at all. 

    Can this be a bug?


    • Edited by RoadRunnr Thursday, May 31, 2012 1:26 PM
    Thursday, May 31, 2012 1:17 PM
  • Its not just you RoadRunnr - I'm going through a similar situation.  My team and I are unable to access the rich text features for InfoPath forms (which we enabled in InfoPath Designer 2010).  The special text features are disabled on public facing sites for Chrome and Firefox browsers.  On the other hand...IE9 and IE8 work perfectly with this, which is kinda funny.   I smell browser specific feature here....



    • Edited by blackhawx Friday, June 1, 2012 5:28 PM
    Friday, June 1, 2012 5:20 PM
  • Blackhawx,

    Well it's good to know that it's not just me.  But the thing that kills me is that the Rich Text fields does show up for fields that I had already set up as mandatory fields!  So I have no idea why the non-mandatory rich text fields won't show up.  I even tried to make them mandatory fields as well, and yet still it doesn't gets displayed!

    Anyone else having similar problems?

    Friday, June 1, 2012 7:19 PM