FIM 2010 R2 & Oracle Internet Directory 11 RRS feed

  • Question

  • I was excited to see in some (non-Microsoft) blog posts that FIM 2010 R2 had native support for Oracle Internet Directory 11.  I just tried to connect to OID using the Oracle directory servers MA, but received an error:

    "Failed to read attribute version on distinguished name cn=monitor"

    Combing through the FIM 2010 R2 feature list, I see it only mentions directory support for "Oracle 11," which is not very specific because Oracle has at least two directory products (OID and ODS), both at version 11.

    Has anyone had any luck with OID?

    Monday, October 7, 2013 10:40 PM

All replies

  • Does the service account have access to read that attribute? If you grab a network trace you should be able to see the precise LDAP calls being made.

    Thanks, Brian

    Tuesday, October 8, 2013 3:08 PM
  • I've tried connecting as a service account I created and as the OID superuser (cn=orcladmin) with the same result.  I also connected with an LDAP browser and with Oracle Directory Services Manager and cannot locate the "cn=monitor" object anywhere in the tree.

    OID's docs do not mention being able to retrieve statistics with cn=monitor, so I suspect it's not a supported feature.

    Tuesday, October 8, 2013 4:47 PM
  • A wireshark trace while attemtping to create the Oracle directory MA reveals the following:

    1. Successful bind as cn=orcladmin
    2. searchRequest baseObject:cn=monitor scope:baseObject filter:(objectClass=*) attributes:version
    3. searchResponse resultCode:noSuchObject
    4. unbindRequest
    5. connection closed


    Tuesday, October 8, 2013 5:33 PM