locked
Microsoft AppV Client v5.1.86.0 - Connection Group Issue RRS feed

  • Question

  • Hi,

    Appreciate any advice / suggestions / experience / knowledge anyone has with an issue I am experiencing with MS AppV Client V5.1.86.0 and Connection Groups (CG).  The issue being that when making an amendment to an existing, published connection group, resulting in an amended version of the CG being made available on the Publishing Servers, this amended CG when sync'd with AppV Clients causes an issue to the AppV client with regards multiple CGs - an issue seemingly due to not synchronising CG correctly

    Clients when syncing with the publishing server, the amended CG is added to the AppV Client configuration, have confirmed this in Powershell.

    When launching locally installed Iexplore.exe (utilising User RunVirtual Key associated with the first AppV App in the Connection Group) the app fails to launch, a popup dialog is presented advising:

    "Microsoft Application Virtualization (App-V)"

    The application failed to launch.

    This may be due to a network failure.

    Error code: 0x8CE03002-0000050A

    Error Messages are generated in the Event Log (... AppV -> Client -> Admin)

    Event ID: 13003

    Description: The virtual application '\Device\Harddisk\volume\Program Files\Internet Explorer\iexplore.exe' could not be launched because the App-V Client could not determine which environment to use.  Provide a priority to the app connection group for the package and try again"

    The resolution to this is manually via PS on the client remove the old CG and the RunVirtual / AppV App(s) / CG work without issue.

    I have set the connection group priority (set to 999), unpublished / re-published, amended the connection group priority to 998, made the amendment to the CG (added additional AppV Package).  This as before results in the generation of a new VersionID (Same GroupID) for the CG.

    When the client syncs with the publishing server the same scenario occurs, the AppV client has reference to multiple CG, this time, on with CG priority of 999 and one with CG priority of 998. 

    When launching locally installed Iexplore.exe (utilising User RunVirtual Key associated with the first AppV App in the Connection Group) the app fails to launch, a popup dialog is presented advising same as before, the EM in the Event Log (... AppV -> Client -> Operational) is slightly different:

    Event ID: 13003

    Description: "C:\Program Files\Internet Explorer\iexplore.exe application from the package ID {{APPV CG GroupID}) failed to launch. process ID 8360 error 0x8CE03002-0x50A"

    It seems that there is an inherent failure in the AppV Client to sync with the publishing servers with regards CG resulting in the issue of an AppV Package being a member of multiple CG and being unable to launch, irrespective if (as per guidance) CG priorities are set?

    Thanks in advance, any help most welcome, am also in process of raising support call.


    Mike

    Thursday, February 22, 2018 4:56 PM

All replies

  • My first recommendation would be to upgrade to the latest Hotfix as we had similar issues regarding connectiongroups and they where resolved by upgrading. (Server/Client)
    Friday, February 23, 2018 9:11 AM
  • Thanks Danny,

    I can see that there are at least 10 Hotfix releases to the RTM version I am using.  I have read the release summaries and whilst none seem to reflect the issue I am encountering, I am hopeful that implementing HF10 (September 2017 MDOP) KB4041137 will correct issue.

    Will post update to advise outcome.

    Thanks

    Mike


    Mike

    Tuesday, February 27, 2018 9:22 AM
  • RTM is alsmost 2,5 years old… please upgrade to the latest HF first please. If I recall correct this issue was resolved in HF8... Also, do not forget to patch your app-v server with the same hotfix (ment for server ofc).

    Roy Essers

    Saturday, March 3, 2018 6:47 PM
  • Can you try with the latest fix.

    https://support.microsoft.com/en-in/help/4074878/march-2018-servicing-release-for-microsoft-desktop-optimization-pack


    (Please click on Vote as Helpful and/or Mark as Answer, if it has helped you.)

    MVP - Windows and Devices for IT

    app2pack.blogspot.com: app2pack.blogspot.com

    Wednesday, March 7, 2018 8:40 AM
  • Update:

    Have raised Cat C support call with MS.

    Have applied HF10 Sep 2017 MDOP to Mgmt, Pub and client, still encounter issue.

    Workaround to avoid the issue is to:

    * - Set CG priority to arbitrary high value such as 999;

    * - Remove AppV Content Cache on the endpoint;

    * - Logon to endpoint generating sync;

    * - Confirm App(s) (Virtual / Physical) in CG bubble;

    * - Logoff;

    * - Amend CG priority, make amendment to CG, confirm in DB and Pub Server new versionID;

    * - Logon to endpoint, sync occurs, Confirm App(s) (Virtual / Physical) still launches in CG bubble;

    * - Can via PS with elevated privilege, see that the AppV Client has reference to two CG, current and prev.

    So can see that method viable as workaround, but appreciate that CG priority not intended for workaround and AppV Client should when sync, mirror the state that the Pub Server dictates, one CG!

    Will advise outcome of MS Cat C Support Call.  Will, with consultation to MS Support Agent, consider implementation of Mar 2018 MDOP HF11, but having read detail of fixes provided not sure will resolve.

    Thanks for all your assistance, thus far.


    Mike

    Wednesday, March 7, 2018 10:13 AM