locked
IIS wsuspool stops Again and Again RRS feed

  • Question

  • Hello,

    I have installed WSUS in one of the SCCM 2012 Primary servers and it was working for almost a month.  For last one week, I am unable to connect to the WSUS console.  Please find the error below.

    Error: Connection Error

    An error occurred trying to connect the WSUS server.  The error can happen for a number of reasons.  Check connectivity with the server.  Please contact your network administrator if the problem persists

    Click Reset server node to try to connect to the server again.

    While analysing I found that the wsuspool is getting stopped automatically and that is the cause for this issue.  Could anyone please help me to resolve this problem?

    Regards

    Nikhil S

    Friday, August 15, 2014 8:41 PM

Answers

  • I've seen this happening when the WSUS app pool was suffering of low memory conditions. Double check that.

    Torsten Meringer | http://www.mssccmfaq.de

    • Marked as answer by S Nikhil Saturday, November 15, 2014 1:06 PM
    Tuesday, October 7, 2014 8:41 AM

All replies

  • My Infrastructure is with  Windows Server 2012 R2 Standard, System Center 2012 R2 and WSUS Version: 6.3.9600.16384

    Nikhil S

    Friday, August 15, 2014 8:55 PM
  • Let's start with that you normally should manage WSUS via the ConfigMgr.

    Did you check the event viewer and the log files for more information?

    • WSUS log location: C:\Program Files\Update Services\LogFiles
    • ConfigMgr log location: <InstallDir>\Microsoft Configuration Manager\Logs

    My Blog: http://www.petervanderwoude.nl/
    Follow me on twitter: pvanderwoude

    Saturday, August 16, 2014 7:31 AM
  • I have the same problem, did anyone solve this??

    Tuesday, October 7, 2014 8:32 AM
  • I've seen this happening when the WSUS app pool was suffering of low memory conditions. Double check that.

    Torsten Meringer | http://www.mssccmfaq.de

    • Marked as answer by S Nikhil Saturday, November 15, 2014 1:06 PM
    Tuesday, October 7, 2014 8:41 AM
  • The below link could be of some help!!

    http://blog.coretech.dk/kea/house-of-cardsthe-configmgr-software-update-point-and-wsus/


    Kindly mark as answer/Vote as helpful if a reply from anybody helped you in this forum. Delphin

    Tuesday, October 7, 2014 12:02 PM
  • And there's this one:  http://mnscug.org/blogs/brian-mason/361-how-to-melt-a-sup

    and this one: http://mnscug.org/blogs/sherry-kissinger/360-wsus-sup-servers-in-configmgr-2012-custom-configuration-settings

    basically, S Nikhil, you aren't alone.  The current supposition is that "sometime" within the last 2-3 months, something to do with the Catalog size--which is "slightly" controllable by you for what products you select in your SUM configuration--grew over some critical size.  For default iis / wsuspool configurations, the private memory pool default is no longer adequate, and you need to increase it.  We also took the extra precaution of having RapidFail be disabled, so that IF it does fail on the WsusPool, it will restart.


    Standardize. Simplify. Automate.

    Tuesday, October 7, 2014 12:21 PM
  • Finally, I fix the problem by disable the memory limitation of wsuspool in IIS recycling setting. 
    • Proposed as answer by SonJim Friday, May 19, 2017 12:05 PM
    Tuesday, October 28, 2014 3:01 PM
  • Yes, The issue was with memory limitation.  I had found that a day after creating this thread but missed to update the solution here :(

    Anyway, thanks for your post and hope Microsoft will have a look in to increase the default memory for WSUS Pool. :)


    Nikhil S
    • Edited by S Nikhil Saturday, November 15, 2014 1:16 PM
    Saturday, November 15, 2014 1:15 PM
  • Finally, I fix the problem by disable the memory limitation of wsuspool in IIS recycling setting. 

     Can you tell exactly where to disable the memory limitation of the wsuspool in IIS recycling?

    Thanks.

    Thursday, February 12, 2015 2:56 PM
  • Manually, Internet Information Services Manager,  Expand your server, Application Pools, find WsusPool, Click on Recycling...  

    We upped our Private memory Limit, we didn't disable.  We did want to let other things have memory before a recycle. 

    For disabling rapid fail, on your WsusPool, Advanced Settings... scroll down to Rapid Fail and change from True to False.


    Standardize. Simplify. Automate.

    Thursday, February 12, 2015 3:29 PM
  • THANK YOU!
    Thursday, February 12, 2015 3:47 PM
  • thanks for that, I'd like to automate that during CM installation.

    powershell lines

    #change the memory size

    &"c:\Windows\System32\inetsrv\appcmd.exe" set apppool /apppool.name:wsuspool /recycling.periodicRestart.privateMemory:"3145728"

    &"c:\Windows\System32\inetsrv\appcmd.exe" set apppool /apppool.name:wsuspool /failure.rapidFailProtection:"false"

    you get all values with that:

    &"c:\Windows\System32\inetsrv\appcmd.exe"  list apppool "wsuspool" /text:*

    cheers, roland

    • Proposed as answer by Alon.or Wednesday, May 2, 2018 4:47 AM
    Tuesday, April 28, 2015 10:07 AM
  • Same thing was happening to me, the WsusPool application pool in IIS would stop itself. This would cause clients to receive a "Service Unavailable" status.

    I changed the advanced settings for the app pool so that the Recycling > Private Memory Limit was much higher (4GB) and also set the Queue length to a higher number (5000)

    The numbers you set will be different depending on your server but this seemed to work for me! Thanks for the tip. 

    Tuesday, February 23, 2016 5:35 PM
  • Thanks, that was the script I was looking for to fix WSUS on W2012R2 and W2016.
    • Edited by Forch Thursday, April 6, 2017 12:03 PM
    Thursday, April 6, 2017 11:55 AM
  • You legend!
    Friday, May 19, 2017 12:06 PM