locked
How can I configure CTRL+Backspace to delete the previous word only and not the preceding space? RRS feed

  • Question

  • The title pretty much explains it all. I'm using a different computer than usually and I'm pretty sure it used to only delete the word and not the space.
    Friday, June 21, 2013 1:55 PM

All replies

  • Your observation is correct: Ctrl+BackSpace shouldn't delete the preceding space. However, if words are separated by two spaces, one of those spaces will be deleted.

    Stefan Blom, Microsoft Word MVP

    Friday, June 21, 2013 5:17 PM
  • Your observation is correct: Ctrl+BackSpace shouldn't delete the preceding space. However, if words are separated by two spaces, one of those spaces will be deleted.

    Stefan Blom, Microsoft Word MVP

    This is not the observed functionality in every case. It seems that MSWord haphazardly either removes the space or doesn't remove it.

    As an example, if I type "and when" and hit CTRL+Backspace, it will either delete the word only or the word and the space, but in most cases it will remove the space as well ("and when" becomes "and"). It seems to toggle between the two but I have no idea what is triggering it.

    Friday, June 21, 2013 5:40 PM
  • Personally, I haven't noticed any inconsistencies with Ctrl+BackSpace in Word.

    Is there any pattern at all? For example, do you see it in all documents or just in some?

    Also, are you running any add-ins?


    Stefan Blom, Microsoft Word MVP

    Friday, June 21, 2013 5:52 PM
  • Personally, I haven't noticed any inconsistencies with Ctrl+BackSpace in Word.

    Is there any pattern at all? For example, do you see it in all documents or just in some?

    Also, are you running any add-ins?


    Stefan Blom, Microsoft Word MVP

    As far as I know there is no pattern that I've been able to detect. It happens inconsistently within the same document. I believe this holds for all documents. I don't think there are any add-ins either.
    Monday, June 24, 2013 12:31 PM
  • Have you tried disabling add-ins (temporarily) to see if that makes a difference?


    Stefan Blom, Microsoft Word MVP

    Monday, June 24, 2013 12:56 PM
  • Have you tried disabling add-ins (temporarily) to see if that makes a difference?


    Stefan Blom, Microsoft Word MVP

    Disabling all add-ins and restarding MSWord fixed the issue until the feature was used twice in a row. It now deletes the space again.
    Monday, June 24, 2013 1:52 PM
  • Disabling all add-ins and restarding MSWord fixed the issue until the feature was used twice in a row. It now deletes the space again.





    You should disable one add-in at a time to find out which specific add-in is responsible. See the sections referring to add-ins in the Knowledge Base article at http://support.microsoft.com/kb/921541/en-us/ (How to troubleshoot problems that occur when you start or use Word).


    Stefan Blom, Microsoft Word MVP


    • Edited by Stefan BlomMVP Tuesday, June 25, 2013 7:37 AM (clarification)
    Monday, June 24, 2013 4:08 PM
  • Fresh install (no addins) Office 2010 and then on a different machine Office 2013.  The same result happens every time.  CTRL-Backspace deletes the word AND the space.  It also happens in Outlook 2010 and 2013 but I believe Outlook uses Word as its editor.

    Sincerely,
    Brian Bergin
    Terabyte Computers, Inc.

    Information posted by me in these forums is provided "As-Is" with no warranties or rights conferred. Use at your own discretion/risk.

    Tuesday, January 28, 2014 3:05 PM
  • hey fuckface, this post is still not answered from 2014. 

    Why the fuck does Ctrl+Backspace delete the space as well? 

    Who the fuck designed this shit

    Friday, September 30, 2016 3:23 AM
  • Not sure if it's the same in Word, but this fixed it for me in Outlook. In Options > Advanced under the "Cut, copy and paste" section, there is a checkbox for "Use smart cut and paste". Click on the Settings button next to this option and uncheck the option for "Adjust sentence and word spacing automatically". I can't seem to reproduce the same issue in Word so I can't verify this will work, but I know this fixed the exact same issue in my Outlook so maybe it will work for you. 

    I know this thread is ancient, but I figured I'd put this out there just in case anybody else is suffering as I was. 
    Tuesday, April 17, 2018 4:57 PM
  • Just wanted to say thank you because it totally worked for me (MS Office 2016).

    This "feature" was driving me crazy.

    Cheers!

    Sunday, April 29, 2018 1:55 PM
  • Thank you so much for this answer Jakeinator! It came 5 years post-question but it's very timely for me!
    Friday, October 26, 2018 6:26 PM
  • Of course, the problem here is/was that the original poster described an inconsistency in the behavior. I could never reproduce the inconsistency, and I haven't changed the default settings for smart copy & paste. More precisely, the "Adjust sentence and word spacing automatically" option is selected on my installation.


    Stefan Blom, Microsoft Word MVP

    Saturday, October 27, 2018 10:01 PM
  • Not sure if it's the same in Word, but this fixed it for me in Outlook. In Options > Advanced under the "Cut, copy and paste" section, there is a checkbox for "Use smart cut and paste". Click on the Settings button next to this option and uncheck the option for "Adjust sentence and word spacing automatically". I can't seem to reproduce the same issue in Word so I can't verify this will work, but I know this fixed the exact same issue in my Outlook so maybe it will work for you. 

    I know this thread is ancient, but I figured I'd put this out there just in case anybody else is suffering as I was. 

    I couldn't understand why Word (and I'm still using Word 2003, BTW—the last version before MS replaced good ol' menus with goofy "ribbons") suddenly started deleting the leading spaces of words I deleted with Ctrl+Backspace. Your fix fixed it—thank you!

    This shows why there's nothing wrong with replying to "ancient" posts. When people have computing problems, they don't care when a particular thread was started; they just want good solutions.  :?)

    Saturday, January 12, 2019 12:45 PM
  • If Ctrl + Shift then Backspace is the desired behaviour.

    1. Record a macro (or use below and press Alt+F11)
    2. Save it to normal.docx (see figure below)
    3. Assign it to Ctrl+Backspace (File --> Options --> Customize Ribbon --> Keyboard shortcuts: Customize...
          Categories: Macros
          Find your newly created macro

    Done.

    Sub CtrlBackspace()
    '
    ' CtrlBackspace Macro
    '
    '
        Selection.MoveLeft Unit:=wdWord, Count:=1, Extend:=wdExtend
        Selection.TypeBackspace
    End Sub

    Step 2:
    (I cannot do this bit)

    Monday, October 21, 2019 3:18 AM
  • Jakeinator21, this worked for me!  THANK YOU SO MUCH!  It was driving me crazy.  :)
    Tuesday, November 5, 2019 1:41 PM