App-V 5.0 SP2 RDS Client with hotfix 2 breaks frequently on Windows 2012R2 with User Profile Disks enabled


  • Hi All,

    I am at my wit's end trying to troubleshoot this, so any help would be greatly appreciated.

    We are having serious stability issues with App-V 5.0 SP2 RDS in our environment with User Profile Disks enabled.

    We have applied the latest hotfix but the issues persist.

    The main problems are:

    1. Periodically the client seems to become corrupted and all applications stop working for all users. All applications including the official Microsoft Office 2013 ones - not just our packages.

    The symptoms are the same as if I change the App-V Client Service account to run under a user account instead of SYSTEM, so it suggests a file access issue. The log files also hint at this, and one of there errors is similar to this:

    The virtual application 'C:\Users\rds.user9\AppData\Local\Microsoft\AppV\Client\Integration\A3EF9C01-C0E9-4AC5-B21F-DB9B1D2F700C\Root\Mindjet\MindManager 14\MindManager.exe' could not be started because the App-V Subsystem 'Virtual Filesystem' could not be initialized. {error: 0x6740090A-0x20003}

    Once this problem occurs the only way I have found to fix it is to either completely remove and reinstall the client, or (perhaps this is the big clue) rename the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\MAV\Configuration\Volumes , unpublish an application, then republish said application.

    I don't even think it matters which application gets published. The point seems to be that this 'Volumes' key gets rewritten.

    I am highly suspicious that our issues are caused by User Profile disks in our RDS environment, as when I disable them on our staging collection all of these issues seem to disappear.

    I have made sure all of the servers have permissions on the share (folder and share permissions). It doesn't seem to make a difference.

    2.  Some application fail completely with User Profile Disks enabled. If we switch the setting from "Store all settings and data on the user profile disk" to "Store Only the following folders" there seems to be some improvement, in that at least one application that fails on the other setting starts to work.

    3. We have already set that NTFS 8 dot 3 reg fix some time ago.


    We have gone live this week (not my call) and this is having disasterous consequences. :(

    Thanks in advance,


    Tuesday, March 11, 2014 5:31 PM


All replies

  • Hello,

    Since this seems to be a critical issue for you (as you stated in the last sentence), I would raise a support call

    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, March 11, 2014 10:05 PM
  • Setup a seperate rdsh server with user profile disks enabled and sequenced the application on that server solved the problem as posted by TapII


    Monday, March 17, 2014 7:19 AM
  • Hi,

    Thanks for your response.

    I did try this a while ago without success, although it may be worth revisiting with SP2 applied.

    I have left this client now.

    I left them a Powershell script that deletes HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\MAV\Configuration\Volumes and triggers an Unpublish/Publish of an application we have deployed to all of the servers.

    This seems to work, but a fix would be better than a workaround.

    Not really my problem now though - I did my best.



    Wednesday, March 26, 2014 2:39 PM
  • This (probably) will not solve your problem, but if you are not using Hotfix 2 for SP2 on the client, you should be.  If nothing else, it will help eliminate a second problem (issue 2 in the hotfix description) from confusing the first.

    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" ( )

    Friday, March 28, 2014 1:05 PM
  • I'm having the same issue. Not entirely sure it's triggered only when using UPD's. Pulling my hair out, but still investigating.

    Hoping the "me too" post will help to get some focus on the development team/s working together to resolve the issue.



    Wednesday, November 12, 2014 12:22 AM
  • I have not worked with UPD, but we often see problems with Citrix PVS that are likely related.

    The App-V client expects fidelity between registry state and file system state.  With PVS this showsmitself as a inconsistency between HKLM and ProgramData/Microsoft.  Clearing the bad item often solves the problem, but the real solution lies in keeping the inconsistency from occurring. Nicke's suggestion of opening a support call with Microsoft makes sense.  Publishing your final solution here to help everyone else would be precious.

    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" ( )

    Wednesday, November 12, 2014 3:33 AM