locked
Mobile devices cannot connect unless on the internal network RRS feed

  • Question

  • I've been digging through this issue for a week now and can't seem to find the problem.  The Skype for Business mobile app will not allow users to sign in unless on the internal network.  

    Our setup: Skype for Business 2015, 1 SfB Standard FE, 1 SfB Edge

    When the desktop client is set to automatic configuration what exactly is it looking for?  Does it look for the autodiscover.domain.com record or the lyncdiscover.domain.com record?  Does SfB even use the autodiscover.domain.com record?

    The desktop client will work when I enter sip.domain.com:443 which points to the external IP of our edge server but it fails for the mobile app (iOS).  

    Wednesday, April 18, 2018 3:42 PM

Answers

  • Thank you for the responses, sorry it's taken me a little bit to get back.  We do have a reverse proxy setup.  I went through our DNS and port settings to make sure they're all what they're supposed to be and found our lyncdiscover and external web url were pointing to the wrong IPs.  We've updated both to point to our reverse proxy and now the app is connecting just fine internal and external.  Thanks again to both of you!!  Now to get federation setup!
    • Proposed as answer by Alice-Wang Friday, April 20, 2018 1:32 AM
    • Marked as answer by IndyBeerGuy Friday, April 20, 2018 1:15 PM
    Thursday, April 19, 2018 3:18 PM

All replies

  • The client is primarily looking for the lyncdiscover record and the external web services URL of the front end server.  Those two items published on port 443 with a certificate the mobile client trusts is really all you should need.  The desktop client is almost a web front end and it connects differently than the desktop app for that reason.  

    autodiscover is also used for EWS on the backend to talk to Exchange, but it won't stop you from logging in.


    Please remember, if you see a post that helped you please click "Vote" on the left side of the response, and if it answered your question please click "Mark As Answer". SWC Unified Communications This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, SWC, their employees, or other MVPs.

    • Proposed as answer by Alice-Wang Thursday, April 19, 2018 2:52 AM
    Wednesday, April 18, 2018 5:08 PM
  • Hi IndyBeerGuy,

    Agree with Anthony.

    Did you deploy reverse proxy in your environment?

    For Lync mobility, it is required reverse proxy. If you don’t have reverse proxy, please deploy it check again, you can use IIS ARR, TMG or F5.

    Please check if you have set lyncdiscover record in the DNS server. And also make sure the autodiscover service is open in IIS on the FE server .

    You could refer to the following for Lync server 2013 but similar to SFB 2015

    https://technet.microsoft.com/en-us/library/hh690030(v=ocs.15).aspx


    Best Regards,
    Alice Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    • Edited by Alice-Wang Thursday, April 19, 2018 3:05 AM
    Thursday, April 19, 2018 3:05 AM
  • Thank you for the responses, sorry it's taken me a little bit to get back.  We do have a reverse proxy setup.  I went through our DNS and port settings to make sure they're all what they're supposed to be and found our lyncdiscover and external web url were pointing to the wrong IPs.  We've updated both to point to our reverse proxy and now the app is connecting just fine internal and external.  Thanks again to both of you!!  Now to get federation setup!
    • Proposed as answer by Alice-Wang Friday, April 20, 2018 1:32 AM
    • Marked as answer by IndyBeerGuy Friday, April 20, 2018 1:15 PM
    Thursday, April 19, 2018 3:18 PM
  • Thanks for your response.

    You can mark your reply as an answer, it will help others who has similar issue.


    Best Regards,
    Alice Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by Alice-Wang Friday, April 20, 2018 9:43 AM
    Friday, April 20, 2018 1:33 AM