locked
Need to improve the performance when web professional is launched RRS feed

  • Question

  • Hi All,

         We are using Web professional for adhoc analysis. The problem we are facing is that the web professional takes long time to generate the report. When we filter the report  on a single month and  drag the leaf level of a dimension containing 500,000 records in the database the query takes a long time to generate. It gives a warning that it has reached a threshold of 1000 records. On clicking the yes button it takes a long time to generate. Infact the report does not come at all. we need to kill the process using the task manager. Please let me know how can we increase the performance.

    Thanks and regards,
    Ram
    Thursday, August 20, 2009 1:01 PM

All replies

  • Hi Ram,

    The Web Pro was designed to do analysis - maybe in the hundreds or thousands of rows.  500,000 is an immense amount of data and I would expect it to take a long time since this is more of a tabular reporting requirement.  Web Pro can handle that much data, it is just limited by the resources - network connection, CPU, RAM, etc., of the clients, networks and servers involved.  I suggest the following:

    1.  Reduce the amount of data.  Ask the question, can my users really use that much data at once?  
    2.  Create an SSAS action that can return that large report if nessary.
    3.  Try increasing resources at the server, client and network.
    4.  Try disabling the "check query size" option in Pro before running the query.
    5.  Design the cube to be more focused on used needs, provide actions for reporting, and increase performance. 

    HTH,

    -Joey 
    Friday, August 21, 2009 8:22 PM