none
"Preparing Automatic repair" on boot when bitlocker is enabled RRS feed

  • Question

  • Hello, I'm having trouble getting bitlocker to work on my new drive.

    The drive is Intel pro 6000p, which is a self encrypting drive. I have eDrive enabled and did a fresh windows 10 install on it.

    I then enabled bitlocker with a password (don't have a TPM), so to integrate with the eDrive feature. I could confirm bitlocker was enabled by entering "manage-bde -status", which reported hardware encryption and protection on. 

    But after that, whenever I boot it just go straight into "Preparing Automatic Repair", then follow by enter Bitlocker recovery key screen. No prompt for a password. 

    I tried repairing it with the Windows media and the correct recovery key, but automatic repair was not successful.

    I was able to get back into Windows, by unlocking the drive in advanced option-->command prompt, using "manage-bde -unlock C: -pw". The system seems fine so I don't think there is a corruption in file. After disabling bitlocker in control panel (or via command prompt) the system boots normal again.

    Note: Fast boot is OFF, CSM is OFF, secure boot is ON, no other drive is present. Latest bios and latest firmware on SSD. I have performed several clean windows install attempts after both secure ease by Intel SSD Toolbox and "clean all" command from diskpart but the problem persisted.

    Please I need your help. I did everything clean and tidy, I just want it to work!

    Monday, October 16, 2017 4:01 AM

All replies

  • Hi,

    Have you tried it with UEFI in legacy mode?

    Or in your bios setup that you have USB boot as priority over HDD boot.

    You could get past the recovery screen. Once at the recovery screen, "skip this drive".

    Once skipped enter the advanced options screen:

    Advanced Options > Troubleshoot > Advanced Options > Command Prompt

    Manage-bde -status c:

    Manage-bde -unlock c: -rp <recovery-key-including-dashes>

    Manage-bde -protectors -disable c:

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 17, 2017 7:51 AM
    Moderator
  • I've just tried "Legacy OPROM" mode in CSM, if that's what you mean by legacy mode.

    No, instead of the recovery screen, the system just kick me straight back to uefi screen everytime I reboot. 

    The boot drive is always the 1st in boot order, and there's no USB boot option as none is connected. (The problem persisted even when the boot drive was the only drive)

    I know how to get past recovery screen through command prompt. Unfortunately. suspending protection by entering "manage-bde -protectors -disable C:" like you suggested didn't help the situation.

    The only way I could make it into windows is by:

    1. Unlocking C: by going through skip this drive > advanced option > command prompt, using "manage-bde -unlock C: -pw" everytime I boot, as the drive will lock itself again once PC is shut down.

    2. Or by disabling bitlocker all together with "manage-bde -off C:"



    Tuesday, October 17, 2017 11:03 AM
  • Hi,

    Sorry for the late reply.

    Try to disable Secure Boot . This has a similar problem, the user is disable Secure Boot solve.

    “I tried to repair the boot in many ways, but unsuccessful. Then I had to disable Secure Boot to get into Windows.”

    https://forum.drweb.com/index.php?showtopic=322306

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Then try to disable Automatic Startup Repair using the command below to disable.

    bcdedit /set {default} recoveryenabled No

    bcdedit /set {default} bootstatuspolicy ignoreallfailures

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 2, 2017 1:20 AM
    Moderator
  • I'm afraid I have to report that, disabling secure boot and startup recovery as suggested did not solve the problem.

    Instead, a new recovery screen appears telling me that \Windows\system32\winload.efi couldn't be loaded and the error code 0xc0000185

    Thanks for the reply anyway


    Thursday, November 9, 2017 8:42 AM