none
Can't disable "Windows update hasn't been able to check for new updates for the last 30 days. Go to Windows Update to resolve this issue"

    Question

  • I am looking for a script to disable the annoying Windows Update notification.

    For a single PC I can go ahead and turn the message off in the Action Center.

    Any help with registry edit?

    Friday, April 22, 2016 5:27 PM

All replies

  • Hello,

    Suggest you to run Windows Update troubleshooter:

    http://www.kapilarya.com/how-to-use-built-in-troubleshooters-in-windows-10

    Let us know if you need more help, Good luck :)

    Windows Troubleshooting & How to guides - http://www.kapilarya.com

    Saturday, April 23, 2016 4:04 AM
  • Hello,

    Suggest you to run Windows Update troubleshooter:

    http://www.kapilarya.com/how-to-use-built-in-troubleshooters-in-windows-10

    Let us know if you need more help, Good luck :)

    Windows Troubleshooting & How to guides - http://www.kapilarya.com

    Is your Windows 10 Troubleshooter's Guide valid for Windows 7?  The OP asked the question in a Windows 7 forum, not a Windows 10 forum?
    Saturday, April 23, 2016 10:40 AM
  • I am specifically looking for a solution to Windows 7 OS.

    We have multiple Windows 7 machines in our environment, can not turn off the message manually logging onto machines.

    I wanted to know if there is any way out with registry so that I can create a batch file and execute on all the machines.

    Thanks :)

    Saturday, April 23, 2016 2:20 PM
  • Hi Mohd Farhan,

     

    Sounds like we could collect binary values of registry from a reference PC and then export it to check if it helps.

     

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, April 25, 2016 11:53 AM
    Moderator
  • Hi Tao, 

    I tried that as well but its working when we manually import the registry binary. Below are steps that I followed:

    1. Manually turned off the message in the Action Center.

    2. Rebooted the machine.

    3. Exported the registry binary "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Action Center\Checks".

    4. Imported on another machine, it worked perfectly but for one user for which I had exported the registry.

    Now, I would like to find a way by which the message can be disabled irrespective of the currently logged on user.

    Thanks,

    Farhan

    Monday, April 25, 2016 4:36 PM
  • After my test, as a workaround, we may turn off the message by GUI in Control Panel\System and Security\Action Center, in the right pane, click "Change Action Center Settings", then untick the "Windows Update" option.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, May 03, 2016 7:19 AM
    Moderator
  • Hi Tao,

    Thank you for the reply!

    This will work only for the account by which you have logged on to the machine.

    And the other user's would still be getting the same pop up messages.

    Still looking for solution :(

    Tuesday, May 03, 2016 7:52 AM
  • Hi,

    We haven’t heard from you in a couple of days, have you solved the problem? We are looking forward to your good news.

    Best Regards,
    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, May 05, 2016 7:38 AM
    Moderator
  • Hi Tao,

    I did not get the solution.

    In case I will find one, definitely update the post !!

    Thanks for the follow-up.

    Farhan

    Saturday, May 07, 2016 10:05 PM